aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_roaming
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-03-05 20:35:23 +0800
committerknu <knu@FreeBSD.org>2001-03-05 20:35:23 +0800
commit47e0fbf81f760eeef55bdb6a4b2005395e08992c (patch)
tree87243f6217cb525d1bc95b976d2f8f74097be43e /www/mod_roaming
parent208131929b701cefcd803fdfd007eeecac8d6376 (diff)
downloadfreebsd-ports-graphics-47e0fbf81f760eeef55bdb6a4b2005395e08992c.tar.gz
freebsd-ports-graphics-47e0fbf81f760eeef55bdb6a4b2005395e08992c.tar.zst
freebsd-ports-graphics-47e0fbf81f760eeef55bdb6a4b2005395e08992c.zip
Bentofy. Show some instruction and point at the example file and the
documents instead of directly modifying httpd.conf by apxs -A.
Diffstat (limited to 'www/mod_roaming')
-rw-r--r--www/mod_roaming/Makefile10
-rw-r--r--www/mod_roaming/files/httpd.conf.mod_roaming20
-rw-r--r--www/mod_roaming/pkg-message16
-rw-r--r--www/mod_roaming/pkg-plist3
4 files changed, 36 insertions, 13 deletions
diff --git a/www/mod_roaming/Makefile b/www/mod_roaming/Makefile
index 7ebed6b2dcb..98f44a0bc4f 100644
--- a/www/mod_roaming/Makefile
+++ b/www/mod_roaming/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mod_roaming
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.klomp.org/mod_roaming/
@@ -24,13 +25,14 @@ do-build:
${APXS} -c mod_roaming.c
do-install:
- ${APXS} -i -A -n roaming ${WRKSRC}/mod_roaming.so
+ ${APXS} -i -n roaming ${WRKSRC}/mod_roaming.so
+ ${INSTALL_DATA} ${FILESDIR}/httpd.conf.${PORTNAME} ${PREFIX}/etc/apache/
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/mod_roaming
+ ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/mod_roaming/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/${PORTNAME}/
.endfor
.endif
- ${CAT} ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/www/mod_roaming/files/httpd.conf.mod_roaming b/www/mod_roaming/files/httpd.conf.mod_roaming
new file mode 100644
index 00000000000..b55a57334b8
--- /dev/null
+++ b/www/mod_roaming/files/httpd.conf.mod_roaming
@@ -0,0 +1,20 @@
+#
+# Example configuration for the mod_roaming module
+#
+# $FreeBSD$
+#
+
+LoadModule roaming_module libexec/apache/mod_roaming.so
+
+AddModule mod_roaming.c
+
+<IfModule mod_roaming.c>
+ RoamingAlias /roaming /usr/local/etc/apache/roaming
+
+ <Location /roaming>
+ AuthUserFile /usr/local/etc/apache/roaming-htpasswd
+ AuthType Basic
+ AuthName "Roaming Access"
+ require valid-user
+ </Location>
+</IfModule>
diff --git a/www/mod_roaming/pkg-message b/www/mod_roaming/pkg-message
index c1d3bf270a0..c700b771f87 100644
--- a/www/mod_roaming/pkg-message
+++ b/www/mod_roaming/pkg-message
@@ -1,13 +1,15 @@
************************************************************
-Please edit your apache.conf or httpd.conf to enable and
-setup this module, and you might also need to create an
-htpasswd file, if you introduce basic authentication.
+Please edit your Apache configuration file to enable and set
+up this module. You may also need to create an htpasswd
+file if you are going to use basic authentication.
-You can always refer to the useful documents held in
-${PREFIX}/share/doc/mod_roaming/, where ${PREFIX} is
-typically /usr/local.
+Look at the file ${PREFIX}/etc/apache/httpd.conf.mod_roaming
+and the documents held in ${PREFIX}/share/doc/mod_roaming/
+for indications on what to do.
-When it's done, do the following to take effect:
+(${PREFIX} is typically /usr/local)
+
+When it's all set up, do the following to take effect:
apachectl configtest (and correct any errors reported)
apachectl restart
diff --git a/www/mod_roaming/pkg-plist b/www/mod_roaming/pkg-plist
index a083fa817e1..78a02ee60c5 100644
--- a/www/mod_roaming/pkg-plist
+++ b/www/mod_roaming/pkg-plist
@@ -1,6 +1,5 @@
+etc/apache/httpd.conf.mod_roaming
libexec/apache/mod_roaming.so
-@exec %D/sbin/apxs -e -A -n roaming %D/%F
-@unexec %D/sbin/apxs -e -A -n roaming %D/%F
%%PORTDOCS%%share/doc/mod_roaming/CHANGES
%%PORTDOCS%%share/doc/mod_roaming/INSTALL
%%PORTDOCS%%share/doc/mod_roaming/LICENSE