aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_throttle/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-03-13 05:56:51 +0800
committerwill <will@FreeBSD.org>2001-03-13 05:56:51 +0800
commit3547cc4029629061244b4efb51a3e87860fe30de (patch)
tree2d440639589056c3be01aacfd28e0d4d80927755 /www/mod_throttle/Makefile
parent27c0885dc10ce67d40cbea40d2b034c1c1751e4f (diff)
downloadfreebsd-ports-graphics-3547cc4029629061244b4efb51a3e87860fe30de.tar.gz
freebsd-ports-graphics-3547cc4029629061244b4efb51a3e87860fe30de.tar.zst
freebsd-ports-graphics-3547cc4029629061244b4efb51a3e87860fe30de.zip
Add mod_throttle 3.1.2, an Apache module that provides bandwidth &
request throttling. PR: 25003 Submitted by: Anders Nordby <anders@fix.no>
Diffstat (limited to 'www/mod_throttle/Makefile')
-rw-r--r--www/mod_throttle/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/www/mod_throttle/Makefile b/www/mod_throttle/Makefile
new file mode 100644
index 00000000000..ecdce6176f4
--- /dev/null
+++ b/www/mod_throttle/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: mod_throttle
+# Date created: 11 February 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_throttle
+PORTVERSION= 3.1.2
+CATEGORIES= www
+MASTER_SITES= http://www.snert.com/Software/mod_throttle/ \
+ http://www.freenix.no/~anders/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= anders@fix.no
+
+BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+APXS?= ${LOCALBASE}/sbin/apxs
+
+DOCS= CHANGES.txt LICENSE.txt index.shtml
+
+do-build:
+ @cd ${WRKSRC} && \
+ ${APXS} -c mod_throttle.c
+
+do-install:
+ ${APXS} -i -A -n throttle ${WRKSRC}/mod_throttle.so
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/mod_throttle
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/mod_throttle/
+.endfor
+.endif
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>