aboutsummaryrefslogtreecommitdiffstats
path: root/www/momspider/Makefile
diff options
context:
space:
mode:
authorwosch <wosch@FreeBSD.org>1997-10-12 01:58:56 +0800
committerwosch <wosch@FreeBSD.org>1997-10-12 01:58:56 +0800
commit325c3e0f4c388fdbe5b3bbc43e1c6a248612e58d (patch)
treec8963d34935b531ace3db43307b178bdb8d3d070 /www/momspider/Makefile
parent8e93d14907911991ddafd59e181a266e7bfddaf9 (diff)
downloadfreebsd-ports-graphics-325c3e0f4c388fdbe5b3bbc43e1c6a248612e58d.tar.gz
freebsd-ports-graphics-325c3e0f4c388fdbe5b3bbc43e1c6a248612e58d.tar.zst
freebsd-ports-graphics-325c3e0f4c388fdbe5b3bbc43e1c6a248612e58d.zip
MOMspider is a web-roaming robot that specializes in the maintenance
of distributed hypertext infostructures (i.e. wide-area webs). The program is written in Perl and, once customized for your site, should work on any UNIX-based system with Perl 4.036.
Diffstat (limited to 'www/momspider/Makefile')
-rw-r--r--www/momspider/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/www/momspider/Makefile b/www/momspider/Makefile
new file mode 100644
index 00000000000..40da08fd3c5
--- /dev/null
+++ b/www/momspider/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: dict
+# Version required: 1.00
+# Date created: 11 October 1997
+# Whom: wosch
+#
+# $Id$
+
+DISTNAME= MOMspider-1.00
+CATEGORIES= www
+MASTER_SITES= ftp://www.ics.uci.edu/pub/websoft/libwww-perl/ \
+ ftp://www.ics.uci.edu/pub/websoft/MOMspider/ \
+ http://www.freebsd.org/~wosch/src/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} libwww-perl-0.40.tar.gz
+
+MAINTAINER= wosch@FreeBSD.org
+
+momdir= ${PREFIX}/momspider
+wwwdir= libwww-perl-0.40
+
+do-build:
+
+do-install:
+ ${MKDIR} ${momdir}/${wwwdir}
+ ${CP} -r ${WRKSRC}/* ${momdir}
+ ${RM} -rf ${WRKSRC}/../${wwwdir}/RCS
+ ${CP} -r ${WRKSRC}/../${wwwdir} ${momdir}
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
+ ${FILESDIR}/momspider.sh ${PREFIX}/bin/momspider
+
+.include <bsd.port.mk>