aboutsummaryrefslogtreecommitdiffstats
path: root/www/moonshine
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2009-05-14 23:45:34 +0800
committerflz <flz@FreeBSD.org>2009-05-14 23:45:34 +0800
commited743d84067ced5aa0bc95e549fe615668381c23 (patch)
tree033705eeae3dcaeda66abeb92ab6e978b0dfc230 /www/moonshine
parentd2d9c1d4601d73e483977edc76f1b17e79d07fdb (diff)
downloadfreebsd-ports-graphics-ed743d84067ced5aa0bc95e549fe615668381c23.tar.gz
freebsd-ports-graphics-ed743d84067ced5aa0bc95e549fe615668381c23.tar.zst
freebsd-ports-graphics-ed743d84067ced5aa0bc95e549fe615668381c23.zip
Add Moonshine 0.2 (www/moonshine).
Moonshine leverages the Windows Media capabilities from Silverlight, provided by the Moonlight browser plugin, and the Firefox web browser framework to enable the playback of embedded Windows Media content on the web and local files on a user's desktop. Note: The desktop player doesn't work yet.
Diffstat (limited to 'www/moonshine')
-rw-r--r--www/moonshine/Makefile50
-rw-r--r--www/moonshine/distinfo3
-rw-r--r--www/moonshine/files/patch-configure10
-rw-r--r--www/moonshine/pkg-descr9
-rw-r--r--www/moonshine/pkg-plist52
5 files changed, 124 insertions, 0 deletions
diff --git a/www/moonshine/Makefile b/www/moonshine/Makefile
new file mode 100644
index 00000000000..259145e30dc
--- /dev/null
+++ b/www/moonshine/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: moonshine
+# Date created: May 14 2009
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= moonshine
+PORTVERSION= 0.2
+CATEGORIES= multimedia www
+MASTER_SITES= http://abock.org/${PORTNAME}/releases/
+
+MAINTAINER= mono@FreeBSD.org
+COMMENT= Windows Media playback through Moonlight and Firefox
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GECKO= libxul
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-browser-plugin-dir=${PREFIX}/lib/browser_plugins/${PORTNAME}/
+
+USE_WEBPLUGINS= gecko19
+WEBPLUGINS_DIR= ${PREFIX}/lib/browser_plugins/${PORTNAME}/
+WEBPLUGINS_FILES= libmoonshine-plugin.so
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
+
+.if defined(WITH_XPI_PLUGIN_ONLY)
+CONFIGURE_ARGS+=--enable-xpi-build
+PLIST= ${NONEXISTENT}
+PLIST_FILES= ${WEBPLUGINS_DIR}/${PKGNAME}-freebsd-${OSREL}.xpi
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|^SHELL=.*|SHELL=${LOCALBASE}/bin/bash|' \
+ ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|sed -r|sed -E|' \
+ ${WRKSRC}/plugin/Makefile.in \
+ ${WRKSRC}/plugin/generate-resource
+
+.if defined(WITH_XPI_PLUGIN_ONLY)
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/plugin/xpi/moonshine.xpi \
+ ${WEBPLUGINS_DIR}/${PKGNAME}-freebsd-${OSREL}.xpi
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/moonshine/distinfo b/www/moonshine/distinfo
new file mode 100644
index 00000000000..dec121ab9fb
--- /dev/null
+++ b/www/moonshine/distinfo
@@ -0,0 +1,3 @@
+MD5 (moonshine-0.2.tar.bz2) = 471ddae37a45395bf996645a52911456
+SHA256 (moonshine-0.2.tar.bz2) = aac0c4f8dcd2ae26f4a597c7584ed072ca6186856f4280bc048df6dd371d6984
+SIZE (moonshine-0.2.tar.bz2) = 321716
diff --git a/www/moonshine/files/patch-configure b/www/moonshine/files/patch-configure
new file mode 100644
index 00000000000..0a0bb3e84d1
--- /dev/null
+++ b/www/moonshine/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig 2009-04-15 21:26:53.000000000 +0100
++++ configure 2009-04-15 21:28:20.000000000 +0100
+@@ -11543,6 +11543,7 @@
+
+ case "$target_os" in
+ *linux*) TARGET_PLATFORM="Linux" ;;
++ *freebsd*) TARGET_PLATFORM="FreeBSD" ;;
+ *) { { $as_echo "$as_me:$LINENO: error: Target os $target_os is not supported" >&5
+ $as_echo "$as_me: error: Target os $target_os is not supported" >&2;}
+ { (exit 1); exit 1; }; } ;;
diff --git a/www/moonshine/pkg-descr b/www/moonshine/pkg-descr
new file mode 100644
index 00000000000..f31d96410bf
--- /dev/null
+++ b/www/moonshine/pkg-descr
@@ -0,0 +1,9 @@
+Moonshine leverages the Windows Media capabilities from Silverlight,
+provided by the Moonlight browser plugin, and the Firefox web
+browser framework to enable the playback of embedded Windows Media
+content on the web and local files on a user's desktop.
+
+WWW: http://abock.org/moonshine/
+
+- Florent Thoumie
+flz@FreeBSD.org
diff --git a/www/moonshine/pkg-plist b/www/moonshine/pkg-plist
new file mode 100644
index 00000000000..e3812333677
--- /dev/null
+++ b/www/moonshine/pkg-plist
@@ -0,0 +1,52 @@
+bin/moonshine
+lib/browser_plugins/moonshine/libmoonshine-plugin.la
+lib/browser_plugins/moonshine/libmoonshine-plugin.so
+share/applications/moonshine.desktop
+%%DATADIR%%/application.ini
+%%DATADIR%%/chrome/chrome.manifest
+%%DATADIR%%/chrome/content/moon-utilities.js
+%%DATADIR%%/chrome/content/player-shell.js
+%%DATADIR%%/chrome/content/player-shell.xul
+%%DATADIR%%/chrome/content/player/moonshine-full-screen-button.js
+%%DATADIR%%/chrome/content/player/moonshine-play-pause-button.js
+%%DATADIR%%/chrome/content/player/moonshine-player.js
+%%DATADIR%%/chrome/content/player/moonshine-plugin-player.js
+%%DATADIR%%/chrome/content/player/moonshine-seek-bar.js
+%%DATADIR%%/chrome/content/player/moonshine-volume-bar.js
+%%DATADIR%%/chrome/content/player/moonshine-wmp-controls.js
+%%DATADIR%%/chrome/content/player/mtk/mtk-box.js
+%%DATADIR%%/chrome/content/player/mtk/mtk-button.js
+%%DATADIR%%/chrome/content/player/mtk/mtk-color.js
+%%DATADIR%%/chrome/content/player/mtk/mtk-console.js
+%%DATADIR%%/chrome/content/player/mtk/mtk-container.js
+%%DATADIR%%/chrome/content/player/mtk/mtk-label.js
+%%DATADIR%%/chrome/content/player/mtk/mtk-media-element.js
+%%DATADIR%%/chrome/content/player/mtk/mtk-object.js
+%%DATADIR%%/chrome/content/player/mtk/mtk-popup.js
+%%DATADIR%%/chrome/content/player/mtk/mtk-screen.js
+%%DATADIR%%/chrome/content/player/mtk/mtk-slider.js
+%%DATADIR%%/chrome/content/player/mtk/mtk-style.js
+%%DATADIR%%/chrome/content/player/mtk/mtk-toolbar.js
+%%DATADIR%%/chrome/content/player/mtk/mtk-widget.js
+%%DATADIR%%/chrome/content/player/mtk/mtk-window.js
+%%DATADIR%%/chrome/content/player/mtk/mtk-xaml.js
+%%DATADIR%%/chrome/icons/default/moonshine-window.png
+%%DATADIR%%/chrome/locale/en-US/player-shell.dtd
+%%DATADIR%%/chrome/locale/en-US/version.dtd
+%%DATADIR%%/chrome/skin/dialog-error.png
+%%DATADIR%%/chrome/skin/player-shell.css
+%%DATADIR%%/defaults/preferences/prefs.js
+@dirrm %%DATADIR%%/defaults/preferences
+@dirrm %%DATADIR%%/defaults
+@dirrm %%DATADIR%%/chrome/skin
+@dirrm %%DATADIR%%/chrome/locale/en-US
+@dirrm %%DATADIR%%/chrome/locale
+@dirrm %%DATADIR%%/chrome/icons/default
+@dirrm %%DATADIR%%/chrome/icons
+@dirrm %%DATADIR%%/chrome/content/player/mtk
+@dirrm %%DATADIR%%/chrome/content/player
+@dirrm %%DATADIR%%/chrome/content
+@dirrm %%DATADIR%%/chrome
+@dirrm %%DATADIR%%
+@dirrm lib/browser_plugins/moonshine
+@dirrm lib/browser_plugins