aboutsummaryrefslogtreecommitdiffstats
path: root/www/mozilla
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-09-25 08:59:25 +0800
committermarcus <marcus@FreeBSD.org>2005-09-25 08:59:25 +0800
commita5898ceba3f25ec407aa1110e5ee0eafa863d02f (patch)
tree991f22a4b8890c59fd12f2f0c267d15270b8ebcd /www/mozilla
parent77a2c7aa9e7379cb5d50e478ece9e2a667f9d798 (diff)
downloadfreebsd-ports-graphics-a5898ceba3f25ec407aa1110e5ee0eafa863d02f.tar.gz
freebsd-ports-graphics-a5898ceba3f25ec407aa1110e5ee0eafa863d02f.tar.zst
freebsd-ports-graphics-a5898ceba3f25ec407aa1110e5ee0eafa863d02f.zip
Update to 1.7.12. See
http://www.mozilla.org/releases/mozilla1.7.12/README.html#new for a list of the fixes in this release. Security: Many important security bugs were fixed. See the URL above for more details.
Diffstat (limited to 'www/mozilla')
-rw-r--r--www/mozilla/Makefile4
-rw-r--r--www/mozilla/distinfo4
-rw-r--r--www/mozilla/files/patch-CAN-2005-2871104
-rw-r--r--www/mozilla/files/patch-xpfe_bootstrap_mozilla.in14
4 files changed, 12 insertions, 114 deletions
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index badc7046f33..67deaff032a 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= mozilla
-PORTVERSION= 1.7.11
-PORTREVISION?= 2
+PORTVERSION= 1.7.12
+PORTREVISION?= 0
PORTEPOCH= 2
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
diff --git a/www/mozilla/distinfo b/www/mozilla/distinfo
index 391463c5494..55c22a62d69 100644
--- a/www/mozilla/distinfo
+++ b/www/mozilla/distinfo
@@ -1,4 +1,4 @@
-MD5 (mozilla-1.7.11-source.tar.bz2) = ed54ad54b4b5de85c7916e7d1efa0ae3
-SIZE (mozilla-1.7.11-source.tar.bz2) = 30448903
+MD5 (mozilla-1.7.12-source.tar.bz2) = f1ad6adbbc0510eb76d352c94c801fac
+SIZE (mozilla-1.7.12-source.tar.bz2) = 30446836
MD5 (libart_lgpl-1.tar.bz2) = c6dba83a091336ef8abdb7c85694f16e
SIZE (libart_lgpl-1.tar.bz2) = 102977
diff --git a/www/mozilla/files/patch-CAN-2005-2871 b/www/mozilla/files/patch-CAN-2005-2871
deleted file mode 100644
index eca8515adbd..00000000000
--- a/www/mozilla/files/patch-CAN-2005-2871
+++ /dev/null
@@ -1,104 +0,0 @@
-Index: netwerk/base/src/nsStandardURL.cpp
-===================================================================
-RCS file: /cvs/mozilla/netwerk/base/src/nsStandardURL.cpp,v
-retrieving revision 1.60.16.2
-diff -p -u -1 -2 -r1.60.16.2 nsStandardURL.cpp
---- netwerk/base/src/nsStandardURL.cpp 17 Feb 2005 23:40:53 -0000 1.60.16.2
-+++ netwerk/base/src/nsStandardURL.cpp 9 Sep 2005 16:34:46 -0000
-@@ -403,24 +403,25 @@ nsStandardURL::AppendToBuf(char *buf, PR
- // 4- update url segment positions and lengths
- nsresult
- nsStandardURL::BuildNormalizedSpec(const char *spec)
- {
- // Assumptions: all member URLSegments must be relative the |spec| argument
- // passed to this function.
-
- // buffers for holding escaped url segments (these will remain empty unless
- // escaping is required).
- nsCAutoString encUsername;
- nsCAutoString encPassword;
- nsCAutoString encHost;
-+ PRBool useEncHost;
- nsCAutoString encDirectory;
- nsCAutoString encBasename;
- nsCAutoString encExtension;
- nsCAutoString encParam;
- nsCAutoString encQuery;
- nsCAutoString encRef;
-
- //
- // escape each URL segment, if necessary, and calculate approximate normalized
- // spec length.
- //
- PRInt32 approxLen = 3; // includes room for "://"
-@@ -440,34 +441,36 @@ nsStandardURL::BuildNormalizedSpec(const
- approxLen += encoder.EncodeSegmentCount(spec, mBasename, esc_FileBaseName, encBasename);
- approxLen += encoder.EncodeSegmentCount(spec, mExtension, esc_FileExtension, encExtension);
- approxLen += encoder.EncodeSegmentCount(spec, mParam, esc_Param, encParam);
- approxLen += encoder.EncodeSegmentCount(spec, mQuery, esc_Query, encQuery);
- approxLen += encoder.EncodeSegmentCount(spec, mRef, esc_Ref, encRef);
- }
-
- // do not escape the hostname, if IPv6 address literal, mHost will
- // already point to a [ ] delimited IPv6 address literal.
- // However, perform Unicode normalization on it, as IDN does.
- mHostEncoding = eEncoding_ASCII;
- if (mHost.mLen > 0) {
-+ useEncHost = PR_FALSE;
- const nsCSubstring& tempHost =
- Substring(spec + mHost.mPos, spec + mHost.mPos + mHost.mLen);
- if (IsASCII(tempHost))
- approxLen += mHost.mLen;
- else {
- mHostEncoding = eEncoding_UTF8;
- if (gIDNService &&
-- NS_SUCCEEDED(gIDNService->Normalize(tempHost, encHost)))
-+ NS_SUCCEEDED(gIDNService->Normalize(tempHost, encHost))) {
- approxLen += encHost.Length();
-- else {
-+ useEncHost = PR_TRUE;
-+ } else {
- encHost.Truncate();
- approxLen += mHost.mLen;
- }
- }
- }
-
- //
- // generate the normalized URL string
- //
- mSpec.SetLength(approxLen + 32);
- char *buf;
- mSpec.BeginWriting(buf);
-@@ -483,25 +486,30 @@ nsStandardURL::BuildNormalizedSpec(const
- mAuthority.mPos = i;
-
- // append authority
- if (mUsername.mLen > 0) {
- i = AppendSegmentToBuf(buf, i, spec, mUsername, &encUsername);
- if (mPassword.mLen >= 0) {
- buf[i++] = ':';
- i = AppendSegmentToBuf(buf, i, spec, mPassword, &encPassword);
- }
- buf[i++] = '@';
- }
- if (mHost.mLen > 0) {
-- i = AppendSegmentToBuf(buf, i, spec, mHost, &encHost);
-+ if (useEncHost) {
-+ mHost.mPos = i;
-+ mHost.mLen = encHost.Length();
-+ i = AppendToBuf(buf, i, encHost.get(), mHost.mLen);
-+ } else
-+ i = AppendSegmentToBuf(buf, i, spec, mHost);
- net_ToLowerCase(buf + mHost.mPos, mHost.mLen);
- if (mPort != -1 && mPort != mDefaultPort) {
- nsCAutoString portbuf;
- portbuf.AppendInt(mPort);
- buf[i++] = ':';
- i = AppendToBuf(buf, i, portbuf.get(), portbuf.Length());
- }
- }
-
- // record authority length
- mAuthority.mLen = i - mAuthority.mPos;
-
diff --git a/www/mozilla/files/patch-xpfe_bootstrap_mozilla.in b/www/mozilla/files/patch-xpfe_bootstrap_mozilla.in
index 7a7b2cc5ff8..768eaf6487f 100644
--- a/www/mozilla/files/patch-xpfe_bootstrap_mozilla.in
+++ b/www/mozilla/files/patch-xpfe_bootstrap_mozilla.in
@@ -1,6 +1,6 @@
--- xpfe/bootstrap/mozilla.in.orig Fri Feb 20 19:13:46 2004
+++ xpfe/bootstrap/mozilla.in Tue Mar 22 22:40:43 2005
-@@ -29,139 +29,323 @@
+@@ -29,141 +29,324 @@
## the mozilla-bin binary to work.
##
@@ -208,7 +208,6 @@
fi
-script_args=""
--moreargs=""
-debugging=0
-MOZILLA_BIN="%MOZILLA-BIN%"
-
@@ -239,7 +238,8 @@
+moreargs= # null
+target= # null
+ALREADY_RUNNING="test"
- while [ $# -gt 0 ]
+ pass_arg_count=0
+ while [ $# -gt $pass_arg_count ]
do
- case "$1" in
- -p | -pure)
@@ -256,8 +256,11 @@
- shift 2
- ;;
- *)
-- moreargs="$moreargs \"$1\""
-- shift 1
+- # Move the unrecognized argument to the end of the list.
+- arg="$1"
+- shift
+- set -- "$@" "$arg"
+- pass_arg_count=`expr $pass_arg_count + 1`
- ;;
- esac
+ if [ -n "${target}" ]; then
@@ -336,7 +339,6 @@
done
-export MRE_HOME
--eval "set -- $moreargs"
+# test for a running copy of firefox
+# seems this is not needed
+#if [-n "${ALREADY_RUNNING}" ]; then