aboutsummaryrefslogtreecommitdiffstats
path: root/www/oops/files
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-09-18 06:36:32 +0800
committerwill <will@FreeBSD.org>2000-09-18 06:36:32 +0800
commit5e219fd889a9ce0b17fc884a1755116312c110fc (patch)
tree0e2fcc6b563c6a6c6c057c989ea215254a1ced7c /www/oops/files
parentd1dfc3f3ce39ff4909681cf75b234a65079a0fd3 (diff)
downloadfreebsd-ports-graphics-5e219fd889a9ce0b17fc884a1755116312c110fc.tar.gz
freebsd-ports-graphics-5e219fd889a9ce0b17fc884a1755116312c110fc.tar.zst
freebsd-ports-graphics-5e219fd889a9ce0b17fc884a1755116312c110fc.zip
Add oops 1.4.16, a www proxy server similar to squid but easier to configure,
threadsafe (can use more than one CPU), and faster (uses large files rather than many files). PR: 21318 Submitted by: Sergey Oskin <oZZ@FreeBSD.org.ru>
Diffstat (limited to 'www/oops/files')
-rw-r--r--www/oops/files/oops.sh24
-rw-r--r--www/oops/files/patch-aa73
-rw-r--r--www/oops/files/patch-ab11
3 files changed, 108 insertions, 0 deletions
diff --git a/www/oops/files/oops.sh b/www/oops/files/oops.sh
new file mode 100644
index 00000000000..1e25698806f
--- /dev/null
+++ b/www/oops/files/oops.sh
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ if [ -x ${PREFIX}/sbin/oopsctl ]; then
+ ${PREFIX}/sbin/oopsctl start 2>&1 > /dev/null; echo -n ' oops'
+ fi
+ ;;
+stop)
+ if [ -x ${PREFIX}/sbin/oopsctl ]; then
+ ${PREFIX}/sbin/oopsctl -s /tmp/oopsctl stop
+ fi
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0
diff --git a/www/oops/files/patch-aa b/www/oops/files/patch-aa
new file mode 100644
index 00000000000..2c325128e52
--- /dev/null
+++ b/www/oops/files/patch-aa
@@ -0,0 +1,73 @@
+--- src/Makefile.in.orig Thu Sep 14 13:19:39 2000
++++ src/Makefile.in Thu Sep 14 13:25:53 2000
+@@ -43,7 +43,7 @@
+ ${OOPSPATH}/DB \
+ ${OOPSPATH}/storages \
+ ${OOPS_SYSCONFDIR}/tables \
+- ${OOPS_LIBDIR}/modules
++ ${OOPS_LIBDIR}
+
+ if [ "X@OOPS_USER@" != "X" ]; then\
+ ${CHOWN} @OOPS_USER@ ${OOPSPATH};\
+@@ -51,51 +51,19 @@
+ ${CHOWN} @OOPS_USER@ ${OOPSPATH}/DB;\
+ ${CHOWN} @OOPS_USER@ ${OOPSPATH}/storages;\
+ ${CHOWN} @OOPS_USER@ ${OOPS_SYSCONFDIR}/tables;\
+- ${CHOWN} @OOPS_USER@ ${OOPS_LIBDIR}/modules;\
++ ${CHOWN} @OOPS_USER@ ${OOPS_LIBDIR};\
+ fi
+
+ install: all mkinstalldirs
+- $(INSTALL) oops ${OOPSPATH}
+- if [ -f ${OOPS_SYSCONFDIR}/oops.cfg ]; then\
+- $(INSTALL_DATA) oops.cfg ${OOPS_SYSCONFDIR}/oops.cfg.sample ;\
+- else\
+- $(INSTALL_DATA) oops.cfg ${OOPS_SYSCONFDIR}/oops.cfg ;\
+- fi
+- if [ -f ${OOPS_SYSCONFDIR}/err_template.html ]; then\
+- $(INSTALL_DATA) err_template.html ${OOPS_SYSCONFDIR}/err_template.html.sample ;\
+- else\
+- $(INSTALL_DATA) err_template.html ${OOPS_SYSCONFDIR}/err_template.html ;\
+- fi
+- if [ -f ${OOPS_SYSCONFDIR}/auth_template.html ]; then\
+- $(INSTALL_DATA) auth_template.html ${OOPS_SYSCONFDIR}/auth_template.html.sample ;\
+- else\
+- $(INSTALL_DATA) auth_template.html ${OOPS_SYSCONFDIR}/auth_template.html;\
+- fi
+- if [ -f ${OOPS_SYSCONFDIR}/passwd ]; then\
+- $(INSTALL_DATA) passwd ${OOPS_SYSCONFDIR}/passwd.sample ;\
+- else\
+- $(INSTALL_DATA) passwd ${OOPS_SYSCONFDIR}/passwd ;\
+- fi
+- if [ -f ${OOPS_SYSCONFDIR}/redir_rules ]; then\
+- $(INSTALL_DATA) redir_rules ${OOPS_SYSCONFDIR}/redir_rules.sample ;\
+- else\
+- $(INSTALL_DATA) redir_rules ${OOPS_SYSCONFDIR}/redir_rules ;\
+- fi
+- if [ -f ${OOPS_SYSCONFDIR}/redir_template.html ]; then\
+- $(INSTALL_DATA) redir_template.html ${OOPS_SYSCONFDIR}/redir_template.html.sample ;\
+- else\
+- $(INSTALL_DATA) redir_template.html ${OOPS_SYSCONFDIR}/redir_template.html ;\
+- fi
+- if [ -f ${OOPS_SYSCONFDIR}/accel_maps ]; then\
+- $(INSTALL_DATA) accel_maps ${OOPS_SYSCONFDIR}/accel_maps.sample ;\
+- else\
+- $(INSTALL_DATA) accel_maps ${OOPS_SYSCONFDIR}/accel_maps ;\
+- fi
+- if [ -f ${OOPS_SYSCONFDIR}/acl_local_networks ]; then\
+- $(INSTALL_DATA) acl_local_networks ${OOPS_SYSCONFDIR}/acl_local_networks.sample ;\
+- else\
+- $(INSTALL_DATA) acl_local_networks ${OOPS_SYSCONFDIR}/acl_local_networks ;\
+- fi
++ $(INSTALL) oops ${OOPS_SBINDIR}
++ $(INSTALL_DATA) oops.cfg ${OOPS_SYSCONFDIR}/oops.cfg.sample
++ $(INSTALL_DATA) err_template.html ${OOPS_SYSCONFDIR}/err_template.html.sample
++ $(INSTALL_DATA) auth_template.html ${OOPS_SYSCONFDIR}/auth_template.html.sample
++ $(INSTALL_DATA) passwd ${OOPS_SYSCONFDIR}/passwd.sample
++ $(INSTALL_DATA) redir_rules ${OOPS_SYSCONFDIR}/redir_rules.sample
++ $(INSTALL_DATA) redir_template.html ${OOPS_SYSCONFDIR}/redir_template.html.sample
++ $(INSTALL_DATA) accel_maps ${OOPS_SYSCONFDIR}/accel_maps.sample
++ $(INSTALL_DATA) acl_local_networks ${OOPS_SYSCONFDIR}/acl_local_networks.sample
+ if test "X@SOFLAGS@" != "X"; then \
+ for m in modules/*so ; do \
+ $(INSTALL) $$m ${OOPS_LIBDIR} ; \
diff --git a/www/oops/files/patch-ab b/www/oops/files/patch-ab
new file mode 100644
index 00000000000..1f72a17d111
--- /dev/null
+++ b/www/oops/files/patch-ab
@@ -0,0 +1,11 @@
+--- src/oops.cfg.in.orig Thu Sep 14 15:35:50 2000
++++ src/oops.cfg.in Thu Sep 14 15:38:56 2000
+@@ -452,7 +452,7 @@
+
+ module oopsctl {
+ # path to oopsctl unix socket
+- socket_path @OOPS_LOCALSTATEDIR@/oopsctl
++ socket_path /tmp/oopsctl
+ # time to auto-refresh page (seconds)
+ html_refresh 300
+ }