aboutsummaryrefslogtreecommitdiffstats
path: root/www/oops
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-10-15 20:13:38 +0800
committerpav <pav@FreeBSD.org>2004-10-15 20:13:38 +0800
commit650f05e38803159197036c44563d9db9420473e9 (patch)
tree00659297e71df95236231d4887001aa8b993f60e /www/oops
parent0bd7b59185e32c44fb7f2e4828db1a13a2c5b5dd (diff)
downloadfreebsd-ports-graphics-650f05e38803159197036c44563d9db9420473e9.tar.gz
freebsd-ports-graphics-650f05e38803159197036c44563d9db9420473e9.tar.zst
freebsd-ports-graphics-650f05e38803159197036c44563d9db9420473e9.zip
- Fix for multiple redir modules
PR: ports/72710 Submitted by: marck (maintainer) Obtained from: author
Diffstat (limited to 'www/oops')
-rw-r--r--www/oops/Makefile2
-rw-r--r--www/oops/files/patch-src_modules_redir.c19
2 files changed, 20 insertions, 1 deletions
diff --git a/www/oops/Makefile b/www/oops/Makefile
index c14e82090ec..618149316d4 100644
--- a/www/oops/Makefile
+++ b/www/oops/Makefile
@@ -7,7 +7,7 @@
PORTNAME= oops
PORTVERSION= ${OOPSVERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= http://oops-cache.org/
DISTNAME= ${PORTNAME}-${OOPSVERSION}
diff --git a/www/oops/files/patch-src_modules_redir.c b/www/oops/files/patch-src_modules_redir.c
new file mode 100644
index 00000000000..c931cd3b034
--- /dev/null
+++ b/www/oops/files/patch-src_modules_redir.c
@@ -0,0 +1,19 @@
+
+$FreeBSD$
+
+--- src/modules/redir.c.orig Thu Oct 16 18:21:59 2003
++++ src/modules/redir.c Sun Oct 3 17:23:08 2004
+@@ -349,11 +349,9 @@
+
+ /* if this is not on my port */
+ while( n ) {
+- if ( mp->port == port
+- && ( (mp->in_addr.s_addr == INADDR_ANY)
+- ||(mp->in_addr.s_addr == rq->my_sa.sin_addr.s_addr) ) )
+- break;
++ if ( mp->so == rq->accepted_so )
++ break;
+ n--;mp++;
+ }
+ if ( !n ) return(MOD_CODE_OK); /* not my */
+ }