aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-AnyEvent-Mojo
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2010-11-22 22:58:19 +0800
committerkuriyama <kuriyama@FreeBSD.org>2010-11-22 22:58:19 +0800
commit5ced8c59fa0b25771f6915ffaca9f1c692d1426a (patch)
tree83296b45406e5c00b1080ec77f6c60ecf4f00086 /www/p5-AnyEvent-Mojo
parent3c3784ac6e3e2ce98c3312bb1aacbf82c26baf5d (diff)
downloadfreebsd-ports-graphics-5ced8c59fa0b25771f6915ffaca9f1c692d1426a.tar.gz
freebsd-ports-graphics-5ced8c59fa0b25771f6915ffaca9f1c692d1426a.tar.zst
freebsd-ports-graphics-5ced8c59fa0b25771f6915ffaca9f1c692d1426a.zip
This module allows you to integrate Mojo applications with the
AnyEvent framework. For example, you can run a web interface for a long-lived AnyEvent daemon. WWW: http://search.cpan.org/dist/AnyEvent-Mojo/
Diffstat (limited to 'www/p5-AnyEvent-Mojo')
-rw-r--r--www/p5-AnyEvent-Mojo/Makefile31
-rw-r--r--www/p5-AnyEvent-Mojo/distinfo2
-rw-r--r--www/p5-AnyEvent-Mojo/pkg-descr5
-rw-r--r--www/p5-AnyEvent-Mojo/pkg-plist8
4 files changed, 46 insertions, 0 deletions
diff --git a/www/p5-AnyEvent-Mojo/Makefile b/www/p5-AnyEvent-Mojo/Makefile
new file mode 100644
index 00000000000..ccfabfa5d4a
--- /dev/null
+++ b/www/p5-AnyEvent-Mojo/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: AnyEvent::Mojo
+# Date created: 05 Aug 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= AnyEvent-Mojo
+PORTVERSION= 0.8003
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to start async Mojo servers easily
+
+RUN_DEPENDS= \
+ p5-AnyEvent>=5.201:${PORTSDIR}/devel/p5-AnyEvent \
+ p5-AnyEvent-HTTP>=1.43:${PORTSDIR}/www/p5-AnyEvent-HTTP \
+ p5-Mojo>=0.991251:${PORTSDIR}/www/p5-Mojo
+# p5-Test-Deep>0:${PORTSDIR}/devel/p5-Test-Deep \
+# p5-Test-Exception>0:${PORTSDIR}/devel/p5-Test-Exception
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= AnyEvent::Mojo.3 \
+ AnyEvent::Mojo::Server.3 \
+ AnyEvent::Mojo::Server::Connection.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-AnyEvent-Mojo/distinfo b/www/p5-AnyEvent-Mojo/distinfo
new file mode 100644
index 00000000000..98ae2dd3478
--- /dev/null
+++ b/www/p5-AnyEvent-Mojo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (AnyEvent-Mojo-0.8003.tar.gz) = 3e989ad3473dbeaf523303cc154e62f7cca5230a9e46daf13ccaa7bed1cdab08
+SIZE (AnyEvent-Mojo-0.8003.tar.gz) = 17360
diff --git a/www/p5-AnyEvent-Mojo/pkg-descr b/www/p5-AnyEvent-Mojo/pkg-descr
new file mode 100644
index 00000000000..b344144cdb5
--- /dev/null
+++ b/www/p5-AnyEvent-Mojo/pkg-descr
@@ -0,0 +1,5 @@
+This module allows you to integrate Mojo applications with the
+AnyEvent framework. For example, you can run a web interface for a
+long-lived AnyEvent daemon.
+
+WWW: http://search.cpan.org/dist/AnyEvent-Mojo/
diff --git a/www/p5-AnyEvent-Mojo/pkg-plist b/www/p5-AnyEvent-Mojo/pkg-plist
new file mode 100644
index 00000000000..281555a14d4
--- /dev/null
+++ b/www/p5-AnyEvent-Mojo/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent/Mojo/.packlist
+%%SITE_PERL%%/AnyEvent/Mojo.pm
+%%SITE_PERL%%/AnyEvent/Mojo/Server.pm
+%%SITE_PERL%%/AnyEvent/Mojo/Server/Connection.pm
+@dirrmtry %%SITE_PERL%%/AnyEvent/Mojo/Server
+@dirrmtry %%SITE_PERL%%/AnyEvent/Mojo
+@dirrmtry %%SITE_PERL%%/AnyEvent
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent/Mojo