aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Apache-PageKit
diff options
context:
space:
mode:
authorsheldonh <sheldonh@FreeBSD.org>2002-01-07 21:18:48 +0800
committersheldonh <sheldonh@FreeBSD.org>2002-01-07 21:18:48 +0800
commit96fc308fec18e6cf0047447cf8baf3b5184ae043 (patch)
tree31183f153483cc4b5308b4abc3a9e87217188fab /www/p5-Apache-PageKit
parentefa40ffc641d2568a871ae4ba840575b6598014e (diff)
downloadfreebsd-ports-graphics-96fc308fec18e6cf0047447cf8baf3b5184ae043.tar.gz
freebsd-ports-graphics-96fc308fec18e6cf0047447cf8baf3b5184ae043.tar.zst
freebsd-ports-graphics-96fc308fec18e6cf0047447cf8baf3b5184ae043.zip
Catch up with interface change in XML::LibXML 1.31, using a patch
officially sanctioned by the PageKit distribution maintainer. Bump PORTREVISION accordingly. Submitted by: tobez Approved by: maintainer
Diffstat (limited to 'www/p5-Apache-PageKit')
-rw-r--r--www/p5-Apache-PageKit/Makefile1
-rw-r--r--www/p5-Apache-PageKit/files/patch-src::lib::Apache::PageKit::Content.pm35
2 files changed, 36 insertions, 0 deletions
diff --git a/www/p5-Apache-PageKit/Makefile b/www/p5-Apache-PageKit/Makefile
index 6569e636493..e2f6598d6ed 100644
--- a/www/p5-Apache-PageKit/Makefile
+++ b/www/p5-Apache-PageKit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Apache-PageKit
PORTVERSION= 1.07
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Apache
diff --git a/www/p5-Apache-PageKit/files/patch-src::lib::Apache::PageKit::Content.pm b/www/p5-Apache-PageKit/files/patch-src::lib::Apache::PageKit::Content.pm
new file mode 100644
index 00000000000..76347bad316
--- /dev/null
+++ b/www/p5-Apache-PageKit/files/patch-src::lib::Apache::PageKit::Content.pm
@@ -0,0 +1,35 @@
+--- lib/Apache/PageKit/Content.pm.orig Tue Oct 23 23:49:55 2001
++++ lib/Apache/PageKit/Content.pm Thu Dec 6 15:13:16 2001
+@@ -20,11 +20,6 @@
+ require XML::LibXML;
+ require XML::LibXSLT;
+
+- # call backs so that we can note the mtimes of dependant files
+- XML::LibXML->match_callback(\&match_uri);
+- XML::LibXML->open_callback(\&open_uri);
+- XML::LibXML->close_callback(\&close_uri);
+- XML::LibXML->read_callback(\&read_uri);
+ }
+
+ $CONTENT = $content;
+@@ -62,6 +57,11 @@
+ # $INCLUDE_MTIMES->{$stylesheet_file} = $stylesheet_mtime;
+
+ my $parser = XML::LibXML->new(ext_ent_handler => \&open_uri);
++ # call backs so that we can note the mtimes of dependant files
++ $parser->match_callback(\&match_uri);
++ $parser->open_callback(\&open_uri);
++ $parser->close_callback(\&close_uri);
++ $parser->read_callback(\&read_uri);
+ my $xslt = XML::LibXSLT->new();
+ my $source = $parser->parse_file("/$component_id.xml");
+ my $style_doc = $parser->parse_file($stylesheet_file);
+@@ -155,7 +155,7 @@
+
+ sub match_uri {
+ my $uri = shift;
+- return $uri !~ /^\w+:/;
++ return $uri !~ /(^\w+:)|(catalog$)/;
+ }
+
+ sub open_uri {