aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Apache-Session
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2004-10-12 18:17:19 +0800
committermat <mat@FreeBSD.org>2004-10-12 18:17:19 +0800
commit2606238b5a6d3eba26afc0852f718da5c4dd4db6 (patch)
tree0aebfc72c6422d39f9f5459d638867b7660fed98 /www/p5-Apache-Session
parenta72c2f03f7122515a24f4e1f33a5922ed8339a9c (diff)
downloadfreebsd-ports-graphics-2606238b5a6d3eba26afc0852f718da5c4dd4db6.tar.gz
freebsd-ports-graphics-2606238b5a6d3eba26afc0852f718da5c4dd4db6.tar.zst
freebsd-ports-graphics-2606238b5a6d3eba26afc0852f718da5c4dd4db6.zip
Update to 1.60
maintainer timeout PR: 71935 Submitted by: me
Diffstat (limited to 'www/p5-Apache-Session')
-rw-r--r--www/p5-Apache-Session/Makefile17
-rw-r--r--www/p5-Apache-Session/distinfo4
-rw-r--r--www/p5-Apache-Session/files/5.005-Session::Generate::ModUniqueId.pm11
-rw-r--r--www/p5-Apache-Session/files/patch-Session::Lock::File.pm24
-rw-r--r--www/p5-Apache-Session/files/patch-Session::Store::File.pm71
-rw-r--r--www/p5-Apache-Session/pkg-plist15
6 files changed, 35 insertions, 107 deletions
diff --git a/www/p5-Apache-Session/Makefile b/www/p5-Apache-Session/Makefile
index 3a980574657..f6541b7ffcf 100644
--- a/www/p5-Apache-Session/Makefile
+++ b/www/p5-Apache-Session/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= Apache-Session
-PORTVERSION= 1.54
-PORTREVISION= 2
+PORTVERSION= 1.60
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Apache
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/0//}
MAINTAINER= frank@exit.com
COMMENT= A persistence framework for session data
@@ -21,7 +21,6 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Apache::Session.3 \
Apache::Session::DB_File.3 \
Apache::Session::File.3 \
@@ -29,10 +28,12 @@ MAN3= Apache::Session.3 \
Apache::Session::Generate::MD5.3 \
Apache::Session::Generate::ModUniqueId.3 \
Apache::Session::Generate::ModUsertrack.3 \
+ Apache::Session::Informix.3 \
Apache::Session::Lock::File.3 \
Apache::Session::Lock::MySQL.3 \
Apache::Session::Lock::Null.3 \
Apache::Session::Lock::Semaphore.3 \
+ Apache::Session::Lock::Sybase.3 \
Apache::Session::MySQL.3 \
Apache::Session::Oracle.3 \
Apache::Session::Postgres.3 \
@@ -42,6 +43,7 @@ MAN3= Apache::Session.3 \
Apache::Session::Serialize::UUEncode.3 \
Apache::Session::Store::DB_File.3 \
Apache::Session::Store::File.3 \
+ Apache::Session::Store::Informix.3 \
Apache::Session::Store::MySQL.3 \
Apache::Session::Store::Oracle.3 \
Apache::Session::Store::Postgres.3 \
@@ -51,7 +53,14 @@ MAN3= Apache::Session.3 \
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+.if ${PERL_LEVEL} < 500600
+EXTRA_PATCH= ${PATCHDIR}/5.005-Session::Generate::ModUniqueId.pm
+
+post-patch:
+ @${FIND} ${WRKSRC} -name '*.orig' -delete
+.endif
.endif
.include <bsd.port.post.mk>
diff --git a/www/p5-Apache-Session/distinfo b/www/p5-Apache-Session/distinfo
index 73b44730cd4..5d0bc7bceee 100644
--- a/www/p5-Apache-Session/distinfo
+++ b/www/p5-Apache-Session/distinfo
@@ -1,2 +1,2 @@
-MD5 (Apache-Session-1.54.tar.gz) = 6d327a8388a58260e10f5f7fc1c79123
-SIZE (Apache-Session-1.54.tar.gz) = 27355
+MD5 (Apache-Session-1.6.tar.gz) = 3a373102e3ba49f93a76994c6599e1ff
+SIZE (Apache-Session-1.6.tar.gz) = 29391
diff --git a/www/p5-Apache-Session/files/5.005-Session::Generate::ModUniqueId.pm b/www/p5-Apache-Session/files/5.005-Session::Generate::ModUniqueId.pm
new file mode 100644
index 00000000000..2d283b7321b
--- /dev/null
+++ b/www/p5-Apache-Session/files/5.005-Session::Generate::ModUniqueId.pm
@@ -0,0 +1,11 @@
+--- Session/Generate/ModUniqueId.pm~ Mon Sep 20 14:27:20 2004
++++ Session/Generate/ModUniqueId.pm Mon Sep 20 14:27:31 2004
+@@ -8,7 +8,7 @@
+ my $session = shift;
+ unless (exists $ENV{UNIQUE_ID}) {
+ require Carp;
+- Carp::croak 'Can\'t get UNIQUE_ID env variable. Make sure mod_unique_id is enabled.';
++ Carp::croak('Can\'t get UNIQUE_ID env variable. Make sure mod_unique_id is enabled.');
+ }
+ $session->{data}->{_session_id} = $ENV{UNIQUE_ID};
+ }
diff --git a/www/p5-Apache-Session/files/patch-Session::Lock::File.pm b/www/p5-Apache-Session/files/patch-Session::Lock::File.pm
deleted file mode 100644
index aea3c01aad7..00000000000
--- a/www/p5-Apache-Session/files/patch-Session::Lock::File.pm
+++ /dev/null
@@ -1,24 +0,0 @@
---- Session/Lock/File.pm.orig Sat Sep 2 00:21:17 2000
-+++ Session/Lock/File.pm Thu Dec 6 17:37:40 2001
-@@ -36,8 +36,9 @@
-
- my $LockDirectory = $session->{args}->{LockDirectory} ||
- $Apache::Session::Lock::File::LockDirectory;
-+ my $LockFile = $LockDirectory."/Apache-Session-".$session->{data}->{_session_id}.".lock";
-
-- open($fh, "+>".$LockDirectory."/Apache-Session-".$session->{data}->{_session_id}.".lock") || die $!;
-+ open($fh, "+> $LockFile") || die "$LockFile: $!";
-
- $self->{fh} = $fh;
- $self->{opened} = 1;
-@@ -58,8 +59,9 @@
-
- my $LockDirectory = $session->{args}->{LockDirectory} ||
- $Apache::Session::Lock::File::LockDirectory;
-+ my $LockFile = $LockDirectory."/Apache-Session-".$session->{data}->{_session_id}.".lock";
-
-- open($fh, "+>".$LockDirectory."/Apache-Session-".$session->{data}->{_session_id}.".lock") || die $!;
-+ open($fh, "+> $LockFile") || die "$LockFile: $!";
-
- $self->{fh} = $fh;
- $self->{opened} = 1;
diff --git a/www/p5-Apache-Session/files/patch-Session::Store::File.pm b/www/p5-Apache-Session/files/patch-Session::Store::File.pm
deleted file mode 100644
index 27d0b3aa903..00000000000
--- a/www/p5-Apache-Session/files/patch-Session::Store::File.pm
+++ /dev/null
@@ -1,71 +0,0 @@
---- Session/Store/File.pm.orig Mon Jul 24 05:44:52 2000
-+++ Session/Store/File.pm Thu Dec 6 17:49:31 2001
-@@ -33,13 +33,14 @@
- my $session = shift;
-
- my $directory = $session->{args}->{Directory} || $Apache::Session::Store::File::Directory;
-+ my $file = $directory.'/'.$session->{data}->{_session_id};
-
-- if (-e $directory.'/'.$session->{data}->{_session_id}) {
-- die "Object already exists in the data store";
-+ if (-e $file) {
-+ die "Object already exists in the data store: $file";
- }
-
-- sysopen ($self->{fh}, $directory.'/'.$session->{data}->{_session_id}, O_RDWR|O_CREAT) ||
-- die "Could not open file: $!";
-+ sysopen ($self->{fh}, $file, O_RDWR|O_CREAT) ||
-+ die "Could not open $file: $!";
-
- $self->{opened} = 1;
-
-@@ -51,10 +52,11 @@
- my $session = shift;
-
- my $directory = $session->{args}->{Directory} || $Apache::Session::Store::File::Directory;
-+ my $file = $directory.'/'.$session->{data}->{_session_id};
-
- if (!$self->{opened}) {
-- sysopen ($self->{fh}, $directory.'/'.$session->{data}->{_session_id}, O_RDWR|O_CREAT) ||
-- die "Could not open file: $!";
-+ sysopen ($self->{fh}, $file, O_RDWR|O_CREAT) ||
-+ die "Could not open $file: $!";
-
- $self->{opened} = 1;
- }
-@@ -69,11 +71,12 @@
- my $session = shift;
-
- my $directory = $session->{args}->{Directory} || $Apache::Session::Store::File::Directory;
-+ my $file = $directory.'/'.$session->{data}->{_session_id};
-
-- if (-e $directory.'/'.$session->{data}->{_session_id}) {
-+ if (-e $file) {
- if (!$self->{opened}) {
-- sysopen ($self->{fh}, $directory.'/'.$session->{data}->{_session_id}, O_RDWR|O_CREAT) ||
-- die "Could not open file: $!";
-+ sysopen ($self->{fh}, $file, O_RDWR|O_CREAT) ||
-+ die "Could not open $file: $!";
-
- $self->{opened} = 1;
- }
-@@ -96,15 +99,16 @@
- my $session = shift;
-
- my $directory = $session->{args}->{Directory} || $Apache::Session::Store::File::Directory;
-+ my $file = $directory.'/'.$session->{data}->{_session_id};
-
- if ($self->{opened}) {
- CORE::close $self->{fh};
- $self->{opened} = 0;
- }
-
-- if (-e $directory.'/'.$session->{data}->{_session_id}) {
-- unlink ($directory.'/'.$session->{data}->{_session_id}) ||
-- die "Could not remove file: $!";
-+ if (-e $file) {
-+ unlink ($file) ||
-+ die "Could not remove $file: $!";
- }
- else {
- die "Object does not exist in the data store";
diff --git a/www/p5-Apache-Session/pkg-plist b/www/p5-Apache-Session/pkg-plist
index 9191ba40da0..07cba1864a4 100644
--- a/www/p5-Apache-Session/pkg-plist
+++ b/www/p5-Apache-Session/pkg-plist
@@ -2,18 +2,18 @@
%%SITE_PERL%%/Apache/Session/DB_File.pm
%%SITE_PERL%%/Apache/Session/File.pm
%%SITE_PERL%%/Apache/Session/Flex.pm
-%%SITE_PERL%%/Apache/Session/MySQL.pm
-%%SITE_PERL%%/Apache/Session/Oracle.pm
-%%SITE_PERL%%/Apache/Session/Postgres.pm
-%%SITE_PERL%%/Apache/Session/Sybase.pm
%%SITE_PERL%%/Apache/Session/Generate/MD5.pm
%%SITE_PERL%%/Apache/Session/Generate/ModUniqueId.pm
%%SITE_PERL%%/Apache/Session/Generate/ModUsertrack.pm
+%%SITE_PERL%%/Apache/Session/Informix.pm
%%SITE_PERL%%/Apache/Session/Lock/File.pm
-%%SITE_PERL%%/Apache/Session/Lock/File.pm.orig
%%SITE_PERL%%/Apache/Session/Lock/MySQL.pm
%%SITE_PERL%%/Apache/Session/Lock/Null.pm
%%SITE_PERL%%/Apache/Session/Lock/Semaphore.pm
+%%SITE_PERL%%/Apache/Session/Lock/Sybase.pm
+%%SITE_PERL%%/Apache/Session/MySQL.pm
+%%SITE_PERL%%/Apache/Session/Oracle.pm
+%%SITE_PERL%%/Apache/Session/Postgres.pm
%%SITE_PERL%%/Apache/Session/Serialize/Base64.pm
%%SITE_PERL%%/Apache/Session/Serialize/Storable.pm
%%SITE_PERL%%/Apache/Session/Serialize/Sybase.pm
@@ -21,15 +21,18 @@
%%SITE_PERL%%/Apache/Session/Store/DBI.pm
%%SITE_PERL%%/Apache/Session/Store/DB_File.pm
%%SITE_PERL%%/Apache/Session/Store/File.pm
-%%SITE_PERL%%/Apache/Session/Store/File.pm.orig
+%%SITE_PERL%%/Apache/Session/Store/Informix.pm
%%SITE_PERL%%/Apache/Session/Store/MySQL.pm
%%SITE_PERL%%/Apache/Session/Store/Oracle.pm
%%SITE_PERL%%/Apache/Session/Store/Postgres.pm
%%SITE_PERL%%/Apache/Session/Store/Sybase.pm
+%%SITE_PERL%%/Apache/Session/Sybase.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Session/.packlist
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Session
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache 2>/dev/null || true
@dirrm %%SITE_PERL%%/Apache/Session/Store
@dirrm %%SITE_PERL%%/Apache/Session/Serialize
@dirrm %%SITE_PERL%%/Apache/Session/Lock
@dirrm %%SITE_PERL%%/Apache/Session/Generate
@dirrm %%SITE_PERL%%/Apache/Session
+@unexec rmdir %D/%%SITE_PERL%%/Apache 2>/dev/null || true