aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-CGI-modules/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-06-17 10:37:15 +0800
committerwill <will@FreeBSD.org>2000-06-17 10:37:15 +0800
commit6dd7168cddcf03645b7b524d0eaec762ba4a5c26 (patch)
treedde5ee054b255f449dc09b875bfef1cb678c4d3e /www/p5-CGI-modules/Makefile
parent09860925596143f36628cd7f462f54e90412d7ae (diff)
downloadfreebsd-ports-graphics-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.tar.gz
freebsd-ports-graphics-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.tar.zst
freebsd-ports-graphics-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.zip
Lots and lots of cleanups. Teach p5-* in general about PKGNAMEPREFIX.
Add some missing/wrong dependencies. Show how to respect CC/CFLAGS. Many miscellaneous modifications. I used more excessive hacks to force p5-Jcode and p5-WWW-Search to respect CC/CFLAGS. Patches largely done by: Christian Weisgerber <naddy@mips.inka.de>
Diffstat (limited to 'www/p5-CGI-modules/Makefile')
-rw-r--r--www/p5-CGI-modules/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/www/p5-CGI-modules/Makefile b/www/p5-CGI-modules/Makefile
index 8931cfaa944..75fa33716bd 100644
--- a/www/p5-CGI-modules/Makefile
+++ b/www/p5-CGI-modules/Makefile
@@ -5,18 +5,19 @@
# $FreeBSD$
#
-PORTNAME= p5-CGI
+PORTNAME= CGI
PORTVERSION= 2.76
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= CGI
-DISTNAME= CGI-modules-2.76
+DISTNAME= CGI-modules-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= jfitz@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP.pm:${PORTSDIR}/www/p5-libwww
-USE_PERL5= YES
+USE_PERL5= yes
MAN3= CGI::Base.3 CGI::BasePlus.3 CGI::Carp.3 CGI::Form.3 \
CGI::MiniSvr.3 CGI::Request.3