aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-HTML-Template
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2002-02-19 21:36:15 +0800
committerkuriyama <kuriyama@FreeBSD.org>2002-02-19 21:36:15 +0800
commit96496eb9547089fa5c295ec5809053ffd233bb86 (patch)
treea8a5c7fc7f81d0049f55ee0b0a3fea7c29132270 /www/p5-HTML-Template
parentfb4c46632d3fc5514bd54127bfe5843992b79562 (diff)
downloadfreebsd-ports-graphics-96496eb9547089fa5c295ec5809053ffd233bb86.tar.gz
freebsd-ports-graphics-96496eb9547089fa5c295ec5809053ffd233bb86.tar.zst
freebsd-ports-graphics-96496eb9547089fa5c295ec5809053ffd233bb86.zip
Upgrade to 2.5.
Pointed out by: nork@cityfujisawa.ne.jp (Norikatsu Shigemura)
Diffstat (limited to 'www/p5-HTML-Template')
-rw-r--r--www/p5-HTML-Template/Makefile10
-rw-r--r--www/p5-HTML-Template/distinfo2
-rw-r--r--www/p5-HTML-Template/files/patch-Template.pm12
3 files changed, 21 insertions, 3 deletions
diff --git a/www/p5-HTML-Template/Makefile b/www/p5-HTML-Template/Makefile
index effa0057ac5..d2680430111 100644
--- a/www/p5-HTML-Template/Makefile
+++ b/www/p5-HTML-Template/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= HTML-Template
-PORTVERSION= 2.4
+PORTVERSION= 2.5
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= HTML
@@ -14,10 +14,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
+BUILD_DEPENDS= ${PERL_INC}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS= ${PERL_INC}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+
PERL_CONFIGURE= yes
MAN3= HTML::Template.3
-
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+PERL_INC= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}
+
+post-patch:
+ ${PERL} -i -pe 's@%%PERL_INC%%@${PERL_INC}@' ${WRKSRC}/Template.pm
.include <bsd.port.mk>
diff --git a/www/p5-HTML-Template/distinfo b/www/p5-HTML-Template/distinfo
index a8ca2e8893e..cad2aeddbf7 100644
--- a/www/p5-HTML-Template/distinfo
+++ b/www/p5-HTML-Template/distinfo
@@ -1 +1 @@
-MD5 (HTML-Template-2.4.tar.gz) = 685845d9fbfcc93b33f8e429d1a6beb0
+MD5 (HTML-Template-2.5.tar.gz) = 2f8cb555618b2d1180534455c1e61d51
diff --git a/www/p5-HTML-Template/files/patch-Template.pm b/www/p5-HTML-Template/files/patch-Template.pm
new file mode 100644
index 00000000000..684a48b3e52
--- /dev/null
+++ b/www/p5-HTML-Template/files/patch-Template.pm
@@ -0,0 +1,12 @@
+--- Template.pm.orig Tue Feb 19 22:15:56 2002
++++ Template.pm Tue Feb 19 22:18:31 2002
+@@ -863,7 +863,9 @@
+ use strict; # and no funny business, either.
+
+ use Carp; # generate better errors with more context
++BEGIN { unshift(@INC, "%%PERL_INC%%"); }
+ use File::Spec; # generate paths that work on all platforms
++shift(@INC);
+
+ # define accessor constants used to improve readability of array
+ # accesses into "objects". I used to use 'use constant' but that