aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-HTTPD-User-Manage/Makefile
diff options
context:
space:
mode:
authorjfitz <jfitz@FreeBSD.org>1996-10-24 16:47:13 +0800
committerjfitz <jfitz@FreeBSD.org>1996-10-24 16:47:13 +0800
commitc1c8ee83180996f09397851b394203c9bd8414ae (patch)
treea3733354fa3d17158df1ddb33935ee53efe4cb7b /www/p5-HTTPD-User-Manage/Makefile
parent4d3993ebeaec5906aa8043c160db742433db016d (diff)
downloadfreebsd-ports-graphics-c1c8ee83180996f09397851b394203c9bd8414ae.tar.gz
freebsd-ports-graphics-c1c8ee83180996f09397851b394203c9bd8414ae.tar.zst
freebsd-ports-graphics-c1c8ee83180996f09397851b394203c9bd8414ae.zip
perl5 module for a HTTP server authentication class.
Diffstat (limited to 'www/p5-HTTPD-User-Manage/Makefile')
-rw-r--r--www/p5-HTTPD-User-Manage/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/www/p5-HTTPD-User-Manage/Makefile b/www/p5-HTTPD-User-Manage/Makefile
new file mode 100644
index 00000000000..b453704fd07
--- /dev/null
+++ b/www/p5-HTTPD-User-Manage/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-HTTPD-Tools
+# Version required: 0.52
+# Date created: October 20th 1996
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= HTTPD-Tools-0.52
+PKGNAME= p5-HTTPD-Tools-0.52
+CATEGORIES+= www
+MASTER_SITES= ftp://ftp.digital.com/pub/plan/perl/CPAN/modules/by-module/HTTPD/ \
+ ftp://ftp.cdrom.com/pub/perl/CPAN/modules/by-module/HTTPD/ \
+ ftp://ftp.cis.ufl.edu/pub/perl/CPAN/modules/by-module/HTTPD/ \
+ ftp://ftp.leo.org/pub/comp/programming/languages/perl/CPAN/modules/by-module/HTTPD/ \
+ ftp://ftp.demon.co.uk/pub/mirrors/perl/CPAN/modules/by-module/HTTPD/ \
+ ftp://ftp.lab.kdd.co.jp/lang/perl/CPAN/modules/by-module/HTTPD/
+
+MAINTAINER= jfitz@FreeBSD.ORG
+
+BUILD_DEPENDS= perl5.003:${PORTSDIR}/lang/perl5
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+
+post-install:
+.if !defined(NOMANCOMPRESS)
+ @ for file in HTTPD::Authen HTTPD::UserAdmin HTTPD::GroupAdmin; do \
+ gzip -9nf ${PREFIX}/lib/perl5/man/man3/$$file.3; \
+ done
+.endif
+
+.include <bsd.port.mk>