aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Kwiki-Diff
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2005-03-02 15:37:01 +0800
committerclsung <clsung@FreeBSD.org>2005-03-02 15:37:01 +0800
commit897ee19e1146506957350f78c0d155dcf2012dec (patch)
tree02c421c4cce5803722fb5b387966cbb853c614e4 /www/p5-Kwiki-Diff
parent529e77ddab40f55a85502f71b436280b7c289a08 (diff)
downloadfreebsd-ports-graphics-897ee19e1146506957350f78c0d155dcf2012dec.tar.gz
freebsd-ports-graphics-897ee19e1146506957350f78c0d155dcf2012dec.tar.zst
freebsd-ports-graphics-897ee19e1146506957350f78c0d155dcf2012dec.zip
- Kwiki::Diff display differences between the current wiki page and
older revisions. PR: 78278 Submitted by: Rong-En Fan
Diffstat (limited to 'www/p5-Kwiki-Diff')
-rw-r--r--www/p5-Kwiki-Diff/Makefile36
-rw-r--r--www/p5-Kwiki-Diff/distinfo2
-rw-r--r--www/p5-Kwiki-Diff/pkg-descr7
-rw-r--r--www/p5-Kwiki-Diff/pkg-message9
-rw-r--r--www/p5-Kwiki-Diff/pkg-plist4
5 files changed, 58 insertions, 0 deletions
diff --git a/www/p5-Kwiki-Diff/Makefile b/www/p5-Kwiki-Diff/Makefile
new file mode 100644
index 00000000000..8b9fb904bd2
--- /dev/null
+++ b/www/p5-Kwiki-Diff/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-Kwiki-Diff
+# Date created: Mar 02 2005
+# Whom: Rong-En Fan <rafan@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Kwiki-Diff
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Kwiki
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= rafan@infor.org
+COMMENT= Kwiki Diff Plugin
+
+BUILD_DEPENDS= ${SITE_PERL}/Kwiki.pm:${PORTSDIR}/www/p5-Kwiki \
+ ${SITE_PERL}/Kwiki/Revisions.pm:${PORTSDIR}/www/p5-Kwiki-Revisions \
+ ${SITE_PERL}/Algorithm/Diff.pm:${PORTSDIR}/devel/p5-Algorithm-Diff
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Kwiki::Diff.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Kwiki-Diff/distinfo b/www/p5-Kwiki-Diff/distinfo
new file mode 100644
index 00000000000..1d8100ee8e6
--- /dev/null
+++ b/www/p5-Kwiki-Diff/distinfo
@@ -0,0 +1,2 @@
+MD5 (Kwiki-Diff-0.02.tar.gz) = cb46daa63a6f0df6c6a0399988d3381c
+SIZE (Kwiki-Diff-0.02.tar.gz) = 3938
diff --git a/www/p5-Kwiki-Diff/pkg-descr b/www/p5-Kwiki-Diff/pkg-descr
new file mode 100644
index 00000000000..9c702669be6
--- /dev/null
+++ b/www/p5-Kwiki-Diff/pkg-descr
@@ -0,0 +1,7 @@
+Kwiki::Diff - Kwiki Diff plugin
+
+Kwiki::Diff display differences between the current wiki page and
+older revisions
+
+Author: Ian Langworth
+WWW: http://search.cpan.org/~ian/Kwiki-Diff/
diff --git a/www/p5-Kwiki-Diff/pkg-message b/www/p5-Kwiki-Diff/pkg-message
new file mode 100644
index 00000000000..0f22d3d482b
--- /dev/null
+++ b/www/p5-Kwiki-Diff/pkg-message
@@ -0,0 +1,9 @@
+/* ================================================================= */
+Note:
+ Kwiki-Diff plugin installed! Now you should add
+ to your kwiki in kwiki installation directory:
+
+$ cd cgi-bin/my-kwiki
+$ kwiki -add Kwiki::Diff
+
+/* ================================================================= */
diff --git a/www/p5-Kwiki-Diff/pkg-plist b/www/p5-Kwiki-Diff/pkg-plist
new file mode 100644
index 00000000000..e98233c5b4c
--- /dev/null
+++ b/www/p5-Kwiki-Diff/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Kwiki/Diff.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Kwiki/Diff/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Kwiki/Diff
+@unexec rmdir %D/%%SITE_PERL%%/Kwiki 2>/dev/null || true