aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-WWW-Search
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-11 13:37:39 +0800
committerasami <asami@FreeBSD.org>1998-11-11 13:37:39 +0800
commit559e1bc28bd975c38b561de15be3918ba1f71b5e (patch)
treecda169bf1e41b7166c2d2febd3d858c1411d0e64 /www/p5-WWW-Search
parent7aed28166a84f266be861367fc9a1add43f9219a (diff)
downloadfreebsd-ports-graphics-559e1bc28bd975c38b561de15be3918ba1f71b5e.tar.gz
freebsd-ports-graphics-559e1bc28bd975c38b561de15be3918ba1f71b5e.tar.zst
freebsd-ports-graphics-559e1bc28bd975c38b561de15be3918ba1f71b5e.zip
Use bsd.port.{pre,post}.mk. Either use them to avoid having to define
something already there (PORTOBJFORMAT, OSVERSION) or move stuff from after .include <bsd.port.mk> to before. (This is not by any means the complete list but just the ones I've noticed recently.)
Diffstat (limited to 'www/p5-WWW-Search')
-rw-r--r--www/p5-WWW-Search/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/www/p5-WWW-Search/Makefile b/www/p5-WWW-Search/Makefile
index 69a48987e43..6e487f18ff3 100644
--- a/www/p5-WWW-Search/Makefile
+++ b/www/p5-WWW-Search/Makefile
@@ -3,7 +3,7 @@
# Date created: June 26th 1997
# Whom: James FitzGibbon <jfitz@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.8 1998/09/15 21:31:57 asami Exp $
+# $Id: Makefile,v 1.9 1998/10/15 01:28:34 jseger Exp $
#
DISTNAME= WWW-Search-1.021
@@ -18,11 +18,6 @@ BUILD_DEPENDS= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/LWP.pm:${PORTSDIR}/www/
USE_PERL5= YES
-OSVERSION!= sysctl -n kern.osreldate
-.if ${OSVERSION} >= 300000
-BROKEN= perl
-.endif
-
MAN1= AutoSearch.1 \
WebSearch.1
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
@@ -51,7 +46,13 @@ MAN3= WWW::Search.3 \
WWW::Search::Gopher.3 \
WWW::Search::Simple.3
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 300000
+BROKEN= perl
+.endif
+
do-configure:
@cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>