aboutsummaryrefslogtreecommitdiffstats
path: root/www/pebble
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2009-02-06 21:55:50 +0800
committerhq <hq@FreeBSD.org>2009-02-06 21:55:50 +0800
commit23ba0df8bf5b601fb5d07a0345f9be86fc87bc61 (patch)
tree0f56c85e06e3394bc280ceb20ccccf41a48631d4 /www/pebble
parent37f03e7352c6a4bb5495e71832f062e5ed416c40 (diff)
downloadfreebsd-ports-graphics-23ba0df8bf5b601fb5d07a0345f9be86fc87bc61.tar.gz
freebsd-ports-graphics-23ba0df8bf5b601fb5d07a0345f9be86fc87bc61.tar.zst
freebsd-ports-graphics-23ba0df8bf5b601fb5d07a0345f9be86fc87bc61.zip
Pebble is a lightweight, open source, Java EE blogging tool. It's small, fast
and feature-rich with unrivalled ease of installation and use. Blog content is stored as XML files on disk and served up dynamically, so there's no need to install a database. All maintenance and administration can be performed through your web browser, making Pebble ideal for anybody who is constantly on the move or doesn't have direct access to their host. WWW: http://pebble.sourceforge.net
Diffstat (limited to 'www/pebble')
-rw-r--r--www/pebble/Makefile62
-rw-r--r--www/pebble/distinfo3
-rw-r--r--www/pebble/files/pebble.properties.in22
-rw-r--r--www/pebble/files/pkg-message.in19
-rw-r--r--www/pebble/pkg-descr8
-rw-r--r--www/pebble/pkg-plist3
6 files changed, 117 insertions, 0 deletions
diff --git a/www/pebble/Makefile b/www/pebble/Makefile
new file mode 100644
index 00000000000..820d37b8f3b
--- /dev/null
+++ b/www/pebble/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: pebble
+# Date created: 2009-02-06
+# Whom: Herve Quiroz <hq@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pebble
+PORTVERSION= 2.3.1
+CATEGORIES= www java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= pebble
+
+MAINTAINER= hq@FreeBSD.org
+COMMENT= Lightweight, open source, Java EE blogging tool
+
+PATCH_DEPENDS= zip:${PORTSDIR}/archivers/zip
+RUN_DEPENDS= ${LOCALBASE}/apache-tomcat6.0/bin/catalina.sh:${PORTSDIR}/www/tomcat6
+
+USE_ZIP= yes
+
+NO_BUILD= yes
+
+WEBAPP_SUBDIR= apache-tomcat6.0/webapps
+WEBAPP_DIR= ${PREFIX}/${WEBAPP_SUBDIR}
+
+PEBBLE_HOME?= /var/lib/${PORTNAME}
+PEBBLE_PROPERTIES= ${PREFIX}/etc/pebble.properties
+SUB_LIST+= PEBBLE_HOME=${PEBBLE_HOME} PEBBLE_PROPERTIES=${PEBBLE_PROPERTIES}
+SUB_FILES= pebble.properties pkg-message
+
+PKGMESSAGE= ${WRKSRC}/pkg-message
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= configuration.html credits.html images index.html \
+ installation.html license.txt multiblog.html screen.css \
+ screenshots.html security.html upgrading1x.html \
+ upgrading2x.html
+.endif
+PLIST_FILES= ${WEBAPP_SUBDIR}/${PORTNAME}.war etc/pebble.properties.sample
+PEBBLE_CONTEXT= WEB-INF/applicationContext-pebble.xml
+
+do-patch:
+ cd ${WRKSRC} && ${UNZIP_CMD} -o pebble.war "${PEBBLE_CONTEXT}"
+ ${SED} -i.bak 's,/WEB-INF/pebble\.properties,file:${PEBBLE_PROPERTIES},' "${WRKSRC}/${PEBBLE_CONTEXT}"
+ cd ${WRKSRC} && ${LOCALBASE}/bin/zip -u pebble.war ${PEBBLE_CONTEXT}
+
+do-install:
+ ${MKDIR} "${PEBBLE_HOME}"
+ ${CHOWN} "www:www" "${PEBBLE_HOME}"
+ ${INSTALL_DATA} ${WRKDIR}/pebble.properties ${PEBBLE_PROPERTIES}.sample
+ if [ ! -f ${PEBBLE_PROPERTIES} ]; then ${INSTALL_DATA} ${WRKDIR}/pebble.properties ${PEBBLE_PROPERTIES} ; fi
+ ${INSTALL_DATA} ${WRKSRC}/pebble.war ${WEBAPP_DIR}/${PORTNAME}.war
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC}/docs && ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${DOCSDIR}/{} \;
+ cd ${WRKSRC}/docs && ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+.endif
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/pebble/distinfo b/www/pebble/distinfo
new file mode 100644
index 00000000000..e112eec9dc0
--- /dev/null
+++ b/www/pebble/distinfo
@@ -0,0 +1,3 @@
+MD5 (pebble-2.3.1.zip) = fdce4744ad01484ac75d7fb8b8e0ed5f
+SHA256 (pebble-2.3.1.zip) = c99d8107b098af0c5cc43ef7e979e53dde66e8d72f4f3267f6f69dcff347db3a
+SIZE (pebble-2.3.1.zip) = 25635986
diff --git a/www/pebble/files/pebble.properties.in b/www/pebble/files/pebble.properties.in
new file mode 100644
index 00000000000..9a4f5a9c37b
--- /dev/null
+++ b/www/pebble/files/pebble.properties.in
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+# the location where your Pebble data is stored, default is ${pebble.home}/pebble
+dataDirectory=%%PEBBLE_HOME%%
+
+# the base URL (can start http:// or https://) where your blog is hosted, default is auto-discover at runtime
+url=
+
+# the secure URL (starting https://), which should only be set if you intend to use secure login
+secureUrl=
+
+# a flag to indicate whether Pebble is running in multi-blog mode, default is false
+multiBlog=false
+
+# the name/IP address of the server through which e-mail is sent, or a JNDI name starting java:/comp/env pointing to a preconfigured javax.mail.Session instance
+smtpHost=java:comp/env/mail/Session
+
+# the maximum file upload size in KB
+fileUploadSize=10240
+
+# a flag to indicate whether user themes are enabled, default is true
+userThemesEnabled=true
diff --git a/www/pebble/files/pkg-message.in b/www/pebble/files/pkg-message.in
new file mode 100644
index 00000000000..fd18b26209e
--- /dev/null
+++ b/www/pebble/files/pkg-message.in
@@ -0,0 +1,19 @@
+
+Pebble will store its data files in:
+
+ %%PEBBLE_HOME%%
+
+You may change this location as well as set other useful configuration settings
+(e.g blog URL, enable multi-blogs) by editing the following file:
+
+ %%PEBBLE_PROPERTIES%%
+
+Should you upgrade this package, your configuration settings will not be
+overwritten. Rather, a sample configuration file will be provided:
+
+ %%PEBBLE_PROPERTIES%%.sample
+
+To setup your blog, read the documentation at:
+
+ file://%%DOCSDIR%%/index.html
+
diff --git a/www/pebble/pkg-descr b/www/pebble/pkg-descr
new file mode 100644
index 00000000000..d032bbbde49
--- /dev/null
+++ b/www/pebble/pkg-descr
@@ -0,0 +1,8 @@
+Pebble is a lightweight, open source, Java EE blogging tool. It's small, fast
+and feature-rich with unrivalled ease of installation and use. Blog content is
+stored as XML files on disk and served up dynamically, so there's no need to
+install a database. All maintenance and administration can be performed through
+your web browser, making Pebble ideal for anybody who is constantly on the move
+or doesn't have direct access to their host.
+
+WWW: http://pebble.sourceforge.net
diff --git a/www/pebble/pkg-plist b/www/pebble/pkg-plist
new file mode 100644
index 00000000000..28ce3efe67b
--- /dev/null
+++ b/www/pebble/pkg-plist
@@ -0,0 +1,3 @@
+@comment $FreeBSD$
+@exec mkdir -p %%PEBBLE_HOME%%
+@unexec if cmp -s %D/etc/pebble.properties.sample %D/etc/pebble.properties; then rm -f %D/etc/pebble.properties; fi