aboutsummaryrefslogtreecommitdiffstats
path: root/www/pound
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-16 07:58:57 +0800
committerpav <pav@FreeBSD.org>2005-09-16 07:58:57 +0800
commitbbbad441b04c42a9e1b419ded59d8e6903e7d325 (patch)
treebc1849b2fd5e7738eb5d1d68a76fe0cd9f501537 /www/pound
parentcb4732a9064d4a8fd194026ed555dafce4dddc61 (diff)
downloadfreebsd-ports-graphics-bbbad441b04c42a9e1b419ded59d8e6903e7d325.tar.gz
freebsd-ports-graphics-bbbad441b04c42a9e1b419ded59d8e6903e7d325.tar.zst
freebsd-ports-graphics-bbbad441b04c42a9e1b419ded59d8e6903e7d325.zip
- Update to 1.9
- OPTIONSify - Convert rc script to rcNG - Install docs PR: ports/82998 Submitted by: Shinsuke Matsui <smatsui@karashi.org> Approved by: maintainer timeout (anders; 2 months)
Diffstat (limited to 'www/pound')
-rw-r--r--www/pound/Makefile35
-rw-r--r--www/pound/distinfo4
-rw-r--r--www/pound/files/pound.sh22
-rw-r--r--www/pound/files/pound.sh.in30
-rw-r--r--www/pound/pkg-plist4
5 files changed, 64 insertions, 31 deletions
diff --git a/www/pound/Makefile b/www/pound/Makefile
index f0490a53c8c..21b20d3e8f5 100644
--- a/www/pound/Makefile
+++ b/www/pound/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pound
-PORTVERSION= 1.8.5
+PORTVERSION= 1.9
CATEGORIES= www net
MASTER_SITES= http://www.apsis.ch/pound/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
@@ -18,6 +18,9 @@ COMMENT= Reverse proxy, load balancer and HTTP(S) frontend for web servers
GNU_CONFIGURE= yes
USE_OPENSSL= yes
+USE_RC_SUBR= ${PORTNAME}.sh
+
+SUB_LIST= NAME=${PORTNAME}
CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
@@ -25,9 +28,29 @@ MAKE_ARGS+= F_CONF=${PREFIX}/etc/pound.cfg
MAN8= pound.8
+OPTIONS= DAEMON "Running as a daemon" on \
+ LOG "With Syslog support" on \
+ MSDAV "With the Microsoft WebDAV extensions support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_DAEMON)
+CONFIGURE_ARGS+= --disable-daemon
+.endif
+
+.if defined(WITHOUT_LOG)
+CONFIGURE_ARGS+= --without-log
+.endif
+
+.if defined(WITH_MSDAV)
+CONFIGURE_ARGS+= --enable-msdav
+.endif
+
post-install:
- @${ECHO} "===> Installing ${PREFIX}/etc/rc.d/pound.sh"
- @${ECHO} "===> startup file as ${PREFIX}/etc/rc.d/pound.sh.sample"
- @${INSTALL_SCRIPT} -m 751 ${FILESDIR}/pound.sh \
- ${PREFIX}/etc/rc.d/pound.sh.sample
-.include <bsd.port.mk>
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/FAQ ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/pound/distinfo b/www/pound/distinfo
index b5c96ed73ce..b20072baf0d 100644
--- a/www/pound/distinfo
+++ b/www/pound/distinfo
@@ -1,2 +1,2 @@
-MD5 (Pound-1.8.5.tgz) = 508ef4411ae4bf292c17c966746935d5
-SIZE (Pound-1.8.5.tgz) = 142055
+MD5 (Pound-1.9.tgz) = f1ec64357e0a53ed8050847517209525
+SIZE (Pound-1.9.tgz) = 143284
diff --git a/www/pound/files/pound.sh b/www/pound/files/pound.sh
deleted file mode 100644
index 0bfd99c622b..00000000000
--- a/www/pound/files/pound.sh
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/bin/sh
-
-if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
- echo "$0: Cannot determine the PREFIX" >&2
- exit 1
-fi
-
-case "$1" in
- start)
- if [ -x ${PREFIX}/sbin/pound ]; then
- ${PREFIX}/sbin/pound &
- echo -n ' pound'
- fi
- ;;
- stop)
- killall pound
- echo -n ' pound'
- ;;
- *)
- echo "Usage: `basename $0` {start|stop}" >&2
- ;;
-esac
diff --git a/www/pound/files/pound.sh.in b/www/pound/files/pound.sh.in
new file mode 100644
index 00000000000..51af6cca04f
--- /dev/null
+++ b/www/pound/files/pound.sh.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: %%NAME%%
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: FreeBSD shutdown
+
+# Add the following line to /etc/rc.conf to enable `%%NAME%%':
+#
+#%%NAME%%_enable="YES"
+#
+# and be sure to configure %%PREFIX%%/etc/%%NAME%%.conf
+
+. "%%RC_SUBR%%"
+
+name="%%NAME%%"
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/sbin/$name"
+pidfile="/var/run/$name.pid"
+required_files="%%PREFIX%%/etc/$name.cfg"
+
+# read configuration and set defaults
+load_rc_config $name
+: ${%%NAME%%_enable="NO"}
+
+run_rc_command "$1"
diff --git a/www/pound/pkg-plist b/www/pound/pkg-plist
index e551e07ed9d..869533f7eaf 100644
--- a/www/pound/pkg-plist
+++ b/www/pound/pkg-plist
@@ -1,2 +1,4 @@
-etc/rc.d/pound.sh.sample
sbin/pound
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%@dirrm %%DOCSDIR%%