aboutsummaryrefslogtreecommitdiffstats
path: root/www/seamonkey2
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-06-02 09:06:51 +0800
committermarcus <marcus@FreeBSD.org>2004-06-02 09:06:51 +0800
commitebee3090ffd4fe5bac41633e1bf41c4399103f88 (patch)
tree8be0f5c5c03da1117179e8f901499720bec951fc /www/seamonkey2
parent1591540c0a61defc664b0c2a8d45bc31ae53c51a (diff)
downloadfreebsd-ports-graphics-ebee3090ffd4fe5bac41633e1bf41c4399103f88.tar.gz
freebsd-ports-graphics-ebee3090ffd4fe5bac41633e1bf41c4399103f88.tar.zst
freebsd-ports-graphics-ebee3090ffd4fe5bac41633e1bf41c4399103f88.zip
Enable optional debugging support by specifying WITH_DEBUG or by enabling it
through OPTIONS. Submitted by: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
Diffstat (limited to 'www/seamonkey2')
-rw-r--r--www/seamonkey2/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index 0e90aad4619..3c5cd950b55 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -60,8 +60,6 @@ CONFIGURE_ARGS= \
--disable-cpp-exceptions \
--disable-cpp-rtti \
--enable-crypto \
- --disable-debug \
- --disable-debug \
--disable-gtktest \
--disable-freetypetest \
--disable-installer \
@@ -72,7 +70,6 @@ CONFIGURE_ARGS= \
--disable-pedantic \
--disable-bidi \
--disable-plaintext-editor-only \
- --enable-strip \
--enable-svg \
--enable-svg-renderer-libart \
--disable-tests \
@@ -112,6 +109,7 @@ OPTIONS=XFT "Enable Xft font anti-aliasing" on \
CALENDAR "Enable the Calendar module" off \
MAILNEWS "Enable Mail and News modules" on \
COMPOSER "Enable the HTML Composer module" on \
+ DEBUG "Enable debugging (i.e. gdb) support" off \
LDAP "Enable LDAP support for Mailnews" on \
CHATZILLA "Enable the Chatzilla IRC module" on \
XMLTERM "Enable the XMLTerm module" on \
@@ -140,6 +138,14 @@ BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
CONFIGURE_ARGS+=--disable-xft
.endif
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--enable-debug \
+ --disable-strip
+.else
+CONFIGURE_ARGS+=--disable-debug \
+ --enable-strip
+.endif
+
.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
defined(WITHOUT_COMPOSER))
BROKEN= "Calendar requires Composer and Mailnews support."