aboutsummaryrefslogtreecommitdiffstats
path: root/www/tclhttpd
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-03-14 17:35:20 +0800
committersobomax <sobomax@FreeBSD.org>2001-03-14 17:35:20 +0800
commit4d56d7b211315db79c52cdbccdcc66549e9fd184 (patch)
tree76e99553200a000d12a4033f278219a771c2c9d0 /www/tclhttpd
parent141ee9d632af3cb03055d5ab107e981a73fd3b60 (diff)
downloadfreebsd-ports-graphics-4d56d7b211315db79c52cdbccdcc66549e9fd184.tar.gz
freebsd-ports-graphics-4d56d7b211315db79c52cdbccdcc66549e9fd184.tar.zst
freebsd-ports-graphics-4d56d7b211315db79c52cdbccdcc66549e9fd184.zip
o Fix build by replacing custom do-build target with set of stock
MAKEFILE/MAKE_ENV/MAKE_ARGS variables. o Slightly reorder variables to make Makefile more readable. Submitted by: bento
Diffstat (limited to 'www/tclhttpd')
-rw-r--r--www/tclhttpd/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/www/tclhttpd/Makefile b/www/tclhttpd/Makefile
index c97043b91c9..da549e1e818 100644
--- a/www/tclhttpd/Makefile
+++ b/www/tclhttpd/Makefile
@@ -19,20 +19,21 @@ LIB_DEPENDS= tcl${TCL_VER}:${PORTSDIR}/lang/tcl${TCL_VER}
TCL_DVER?= 8.3
TCL_VER= ${TCL_DVER:S/.//}
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-tcl="${LOCALBASE}/lib/tcl${TCL_DVER}" \
--with-tclinclude="${LOCALBASE}/include/tcl${TCL_DVER}"
-RCD= ${LOCALBASE}/etc/rc.d/tclhttpd.sh
-
-.include <bsd.port.pre.mk>
-SHLIB_NAME!= ${MAKE} -f "${FILESDIR}/Makefile.lib" ech
+MAKEFILE= ${FILESDIR}/Makefile.lib
+MAKE_ENV= TCL_DVER="${TCL_DVER}" FILESDIR="${FILESDIR}"
+MAKE_ARGS= -j2
PLIST_SUB+= TCL_VER=${TCL_VER} PORTVERSION=${PORTVERSION} \
SHLIB_NAME=${SHLIB_NAME}
-do-build:
- cd ${WRKSRC} && ${MAKE} -j 2 TCL_DVER="${TCL_DVER}" \
- FILESDIR="${FILESDIR}" -f "${FILESDIR}/Makefile.lib"
+RCD= ${LOCALBASE}/etc/rc.d/tclhttpd.sh
+
+.include <bsd.port.pre.mk>
+SHLIB_NAME!= ${MAKE} -f ${MAKEFILE} ech
pre-install:
${MKDIR} ${LOCALBASE}/tclhttpd/custom