aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-05-11 03:24:28 +0800
committersat <sat@FreeBSD.org>2006-05-11 03:24:28 +0800
commit03532778ce1ba125e5fe150a2adc52bf2152490a (patch)
treeb52a901674728895243bc55f0f88b87c60dc9bb9 /www
parent0df5929ccd94cfcc7242caed5ee8c8096cfa5115 (diff)
downloadfreebsd-ports-graphics-03532778ce1ba125e5fe150a2adc52bf2152490a.tar.gz
freebsd-ports-graphics-03532778ce1ba125e5fe150a2adc52bf2152490a.tar.zst
freebsd-ports-graphics-03532778ce1ba125e5fe150a2adc52bf2152490a.zip
- Update my e-mail address
- Add support for snatching desktop entries to -devel ports Approved by: osa (co-mentor)
Diffstat (limited to 'www')
-rw-r--r--www/linux-seamonkey/Makefile4
-rw-r--r--www/linux-seamonkey/Makefile.common10
-rw-r--r--www/linux-seamonkey/files/linux-seamonkey.desktop.in2
3 files changed, 10 insertions, 6 deletions
diff --git a/www/linux-seamonkey/Makefile b/www/linux-seamonkey/Makefile
index 6bec3fb2cbb..81e16fad757 100644
--- a/www/linux-seamonkey/Makefile
+++ b/www/linux-seamonkey/Makefile
@@ -1,6 +1,6 @@
# New ports collection makefile for: linux-seamonkey
# Date created: 1 February 2006
-# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
#
# $FreeBSD$
#
@@ -11,7 +11,7 @@ DISTVERSIONSUFFIX= .en-US.linux-i686
CATEGORIES= www
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
-MAINTAINER= infofarmer@gmail.com
+MAINTAINER= infofarmer@FreeBSD.org
COMMENT= The open source, standards compliant web browser
.include "${.CURDIR}/Makefile.common"
diff --git a/www/linux-seamonkey/Makefile.common b/www/linux-seamonkey/Makefile.common
index e2bec99d552..fd4e2b688ac 100644
--- a/www/linux-seamonkey/Makefile.common
+++ b/www/linux-seamonkey/Makefile.common
@@ -1,6 +1,6 @@
# New ports collection makefile for: mozilla linux binary ports
# Date created: 1 May 2006
-# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
#
# $FreeBSD$
#
@@ -31,6 +31,10 @@ SUB_LIST+= APP_NAME=${APP_NAME}
SUB_FILES= ${APP_NAME}.desktop
PKGMESSAGE= ${WRKDIR}/pkg-message
PREFS_FILE= ${WRKSRC}/defaults/pref/browser-prefs.js
+.if defined(PKGNAMESUFFIX) && ${PKGNAMESUFFIX:M*devel*}
+DESKTOP_SUFFIX?= (Linux, devel)
+.endif
+DESKTOP_SUFFIX?= (Linux)
UNAME?= /usr/bin/uname
@@ -89,8 +93,8 @@ create-plist:
snatch-desktop:
${SED} -E -e 's/${PORTNAME}/${APP_NAME}/' \
- -e 's/^(Name.*=.+)$$/\1 (Linux)/' \
- -e 's/^(GenericName.*=.+)$$/\1 (Linux)/' \
+ -e 's/^(Name.*=.+)$$/\1 ${DESKTOP_SUFFIX}/' \
+ -e 's/^(GenericName.*=.+)$$/\1 ${DESKTOP_SUFFIX}/' \
-e 's!^Icon=.*$$!Icon=%%PREFIX%%/lib/%%APP_NAME%%/chrome/icons/default/default.xpm!' \
${PORTSDIR}/${PKGCATEGORY}/${PORTNAME}/files/${PORTNAME}.desktop.in > \
${FILESDIR}/${APP_NAME}.desktop.in
diff --git a/www/linux-seamonkey/files/linux-seamonkey.desktop.in b/www/linux-seamonkey/files/linux-seamonkey.desktop.in
index fff008486c7..212d753da2e 100644
--- a/www/linux-seamonkey/files/linux-seamonkey.desktop.in
+++ b/www/linux-seamonkey/files/linux-seamonkey.desktop.in
@@ -164,6 +164,6 @@ Exec=linux-seamonkey %U
StartupNotify=true
Terminal=false
Type=Application
-Icon=%%PREFIX%%/lib/linux-seamonkey/chrome/icons/default/default.xpm
+Icon=%%PREFIX%%/lib/%%APP_NAME%%/chrome/icons/default/default.xpm
Categories=Application;Network;
MimeType=text/html;text/xml;application/xhtml+xml;