aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-01-07 00:40:14 +0800
committeraaron <aaron@FreeBSD.org>2006-01-07 00:40:14 +0800
commit135e6536fcb434772eaf98dcf198cd78c05dd835 (patch)
treedc177c71385a578ec920ccdc4e7ef50b12cb2261 /www
parent27225a0978e0105ec81f7352e8df68afdd901cec (diff)
downloadfreebsd-ports-graphics-135e6536fcb434772eaf98dcf198cd78c05dd835.tar.gz
freebsd-ports-graphics-135e6536fcb434772eaf98dcf198cd78c05dd835.tar.zst
freebsd-ports-graphics-135e6536fcb434772eaf98dcf198cd78c05dd835.zip
- Don't propose sqlite backend if PHP_VER != 5
- apply correct permissions - fix php5 detection Approved by: tobez
Diffstat (limited to 'www')
-rw-r--r--www/serendipity-devel/Makefile21
-rw-r--r--www/serendipity/Makefile21
2 files changed, 32 insertions, 10 deletions
diff --git a/www/serendipity-devel/Makefile b/www/serendipity-devel/Makefile
index 06dd2df55ce..3357e12b245 100644
--- a/www/serendipity-devel/Makefile
+++ b/www/serendipity-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= serendipity
PORTVERSION= 0.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= php-blog
@@ -23,10 +23,20 @@ USE_PHP= session pcre gd openssl mbstring iconv zlib xml
SUB_LIST+= SERENDIPITY=${SERENDIPITY}
SUB_FILES= pkg-message
+LOCALBASE?= /usr/local
+
OPTIONS= MYSQL "Use MySQL backend" on \
- PGSQL "Use PostgreSQL backend" off \
- SQLITE "Use SQLite backend (PHP5)" off \
- MAGICK "Use ImageMagick Library" on
+ PGSQL "Use PostgreSQL backend" off
+
+.if exists(${LOCALBASE}/etc/php.conf)
+.include "${LOCALBASE}/etc/php.conf"
+.endif
+
+.if defined(PHP_VER) && ${PHP_VER} == 5
+OPTIONS+= SQLITE "Use SQLite backend" off
+.endif
+
+OPTIONS+= MAGICK "Use ImageMagick Library" on
PORT_DBDIR?= /var/db/ports
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
@@ -54,8 +64,9 @@ RUN_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick
do-install:
@-${MKDIR} ${PREFIX}/${SERENDIPITY}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${SERENDIPITY}
+ @${CHMOD} 755 ${PREFIX}/${SERENDIPITY}
@(cd ${WRKSRC} && ${CP} -R * ${PREFIX}/${SERENDIPITY}/ )
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${SERENDIPITY}
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/www/serendipity/Makefile b/www/serendipity/Makefile
index 06dd2df55ce..3357e12b245 100644
--- a/www/serendipity/Makefile
+++ b/www/serendipity/Makefile
@@ -7,7 +7,7 @@
PORTNAME= serendipity
PORTVERSION= 0.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= php-blog
@@ -23,10 +23,20 @@ USE_PHP= session pcre gd openssl mbstring iconv zlib xml
SUB_LIST+= SERENDIPITY=${SERENDIPITY}
SUB_FILES= pkg-message
+LOCALBASE?= /usr/local
+
OPTIONS= MYSQL "Use MySQL backend" on \
- PGSQL "Use PostgreSQL backend" off \
- SQLITE "Use SQLite backend (PHP5)" off \
- MAGICK "Use ImageMagick Library" on
+ PGSQL "Use PostgreSQL backend" off
+
+.if exists(${LOCALBASE}/etc/php.conf)
+.include "${LOCALBASE}/etc/php.conf"
+.endif
+
+.if defined(PHP_VER) && ${PHP_VER} == 5
+OPTIONS+= SQLITE "Use SQLite backend" off
+.endif
+
+OPTIONS+= MAGICK "Use ImageMagick Library" on
PORT_DBDIR?= /var/db/ports
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
@@ -54,8 +64,9 @@ RUN_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick
do-install:
@-${MKDIR} ${PREFIX}/${SERENDIPITY}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${SERENDIPITY}
+ @${CHMOD} 755 ${PREFIX}/${SERENDIPITY}
@(cd ${WRKSRC} && ${CP} -R * ${PREFIX}/${SERENDIPITY}/ )
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${SERENDIPITY}
post-install:
@${CAT} ${PKGMESSAGE}