aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2000-08-09 10:16:31 +0800
committerkuriyama <kuriyama@FreeBSD.org>2000-08-09 10:16:31 +0800
commit30bb41ed6d36c9743ffab0b6b593421e2c51dfa3 (patch)
tree9361cf84aa5b14e19751d5a6d5b1b213f1219267 /www
parent7947151475ef3b7847af068a953121bfc1caffb1 (diff)
downloadfreebsd-ports-graphics-30bb41ed6d36c9743ffab0b6b593421e2c51dfa3.tar.gz
freebsd-ports-graphics-30bb41ed6d36c9743ffab0b6b593421e2c51dfa3.tar.zst
freebsd-ports-graphics-30bb41ed6d36c9743ffab0b6b593421e2c51dfa3.zip
Use files/apache.sh instead of making in Makefile.
No response from: maintainer
Diffstat (limited to 'www')
-rw-r--r--www/apache13+ipv6/Makefile4
-rw-r--r--www/apache13+ipv6/files/apache.sh2
2 files changed, 2 insertions, 4 deletions
diff --git a/www/apache13+ipv6/Makefile b/www/apache13+ipv6/Makefile
index 2c0133b529f..22d85c92cc4 100644
--- a/www/apache13+ipv6/Makefile
+++ b/www/apache13+ipv6/Makefile
@@ -77,9 +77,7 @@ pre-configure:
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/apache.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/apache.sh startup file."; \
- ${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/apache.sh; \
- ${ECHO} "[ -x ${PREFIX}/sbin/apachectl ] && ${PREFIX}/sbin/apachectl start > /dev/null && ${ECHO} -n ' apache'" >> ${PREFIX}/etc/rc.d/apache.sh; \
- ${CHMOD} 751 ${PREFIX}/etc/rc.d/apache.sh; \
+ ${INSTALL_SCRIPT} -m 751 ${FILESDIR}/apache.sh ${PREFIX}/etc/rc.d/apache.sh; \
fi
.include <bsd.port.post.mk>
diff --git a/www/apache13+ipv6/files/apache.sh b/www/apache13+ipv6/files/apache.sh
index 61991825485..ca4321814e5 100644
--- a/www/apache13+ipv6/files/apache.sh
+++ b/www/apache13+ipv6/files/apache.sh
@@ -10,7 +10,7 @@ start)
[ -x ${PREFIX}/sbin/apachectl ] && ${PREFIX}/sbin/apachectl start > /dev/null && echo -n ' apache'
;;
stop)
- [ -r /var/run/httpd.pid ] && ${PREFIX}/apachectl stop > /dev/null && echo -n ' apache'
+ [ -r /var/run/httpd.pid ] && ${PREFIX}/sbin/apachectl stop > /dev/null && echo -n ' apache'
;;
*)
echo "Usage: `basename $0` {start|stop}" >&2