aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbillf <billf@FreeBSD.org>1999-05-07 06:09:11 +0800
committerbillf <billf@FreeBSD.org>1999-05-07 06:09:11 +0800
commit445266f93b3a20c93a2fcb85c88306cce730f030 (patch)
treebf6332c968a8f69f38abcac2c61fe39d51078540 /www
parentf49bb2be8d817deba249303ed7338358fabadc7b (diff)
downloadfreebsd-ports-graphics-445266f93b3a20c93a2fcb85c88306cce730f030.tar.gz
freebsd-ports-graphics-445266f93b3a20c93a2fcb85c88306cce730f030.tar.zst
freebsd-ports-graphics-445266f93b3a20c93a2fcb85c88306cce730f030.zip
Fix packaging for this port by doing Good Things with the location of
site_perl by using bsd.port.mk's variables, instead of hard coding. Also: apache now only installs httpd.conf, so depending on srm.conf is a really bad idea. Initiated by: bento's logs
Diffstat (limited to 'www')
-rw-r--r--www/wwwstat/Makefile19
-rw-r--r--www/wwwstat/pkg-plist6
2 files changed, 12 insertions, 13 deletions
diff --git a/www/wwwstat/Makefile b/www/wwwstat/Makefile
index c79d6fab7a5..fe01f2c633f 100644
--- a/www/wwwstat/Makefile
+++ b/www/wwwstat/Makefile
@@ -3,12 +3,13 @@
# Date created: So 2 Mär 1997 18:10:49 MET
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
-# $Id: Makefile,v 1.9 1998/08/24 12:40:21 asami Exp $
+# $Id: Makefile,v 1.10 1999/03/22 17:45:21 andreas Exp $
#
DISTNAME= wwwstat-2.01
CATEGORIES= www
-MASTER_SITES= ftp://www.ics.uci.edu/pub/websoft/wwwstat/
+MASTER_SITES= ftp://www.ics.uci.edu/pub/websoft/wwwstat/ \
+ ftp://ftp.gwdg.de/pub/misc/www-stat/websoft/wwwstat/
DISTFILES= wwwstat-2.0.tar.gz
PATCH_SITES= ${MASTER_SITES}
@@ -16,13 +17,14 @@ PATCHFILES= patch-2.01.txt
MAINTAINER= andreas@FreeBSD.ORG
-RUN_DEPENDS= ${PREFIX}/etc/apache/srm.conf:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${PREFIX}/etc/apache/httpd.conf:${PORTSDIR}/www/apache13
USE_PERL5= yes
MAKE_ENV+= PERL5=${PERL5}
DIST_SUBDIR= wwwstat
WRKSRC= ${WRKDIR}/wwwstat-2.0
MAN1= wwwstat.1 splitlog.1
+SITEPERL= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/wwwstat ${PREFIX}/bin
@@ -30,17 +32,14 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/monthly ${PREFIX}/bin
@${INSTALL_SCRIPT} ${WRKSRC}/wwwerrs ${PREFIX}/bin
@${INSTALL_SCRIPT} ${WRKSRC}/oldlog2new ${PREFIX}/bin
- @${INSTALL_DATA} ${WRKSRC}/wwwstat.rc \
- ${PREFIX}/lib/perl5/site_perl/i386-freebsd
- @${INSTALL_DATA} ${WRKSRC}/splitlog.rc \
- ${PREFIX}/lib/perl5/site_perl/i386-freebsd
- @${INSTALL_DATA} ${WRKSRC}/domains.pl \
- ${PREFIX}/lib/perl5/site_perl/i386-freebsd
+ @${INSTALL_DATA} ${WRKSRC}/wwwstat.rc ${SITEPERL}
+ @${INSTALL_DATA} ${WRKSRC}/splitlog.rc ${SITEPERL}
+ @${INSTALL_DATA} ${WRKSRC}/domains.pl ${SITEPERL}
@${INSTALL_MAN} ${WRKSRC}/wwwstat.1 ${PREFIX}/man/man1
@${INSTALL_MAN} ${WRKSRC}/splitlog.1 ${PREFIX}/man/man1
@${ECHO_MSG} "Edit the wwwstat.rc and splitlog.rc file ..."
@${ECHO_MSG} "If needed, edit wwwstat and splitlog directly ..."
@${ECHO_MSG} "These files are located in:"
- @${ECHO_MSG} " ${PREFIX}/lib/perl5/site_perl/i386-freebsd"
+ @${ECHO_MSG} " ${SITEPERL}"
.include <bsd.port.mk>
diff --git a/www/wwwstat/pkg-plist b/www/wwwstat/pkg-plist
index 44d8457ab7b..1f0bb230383 100644
--- a/www/wwwstat/pkg-plist
+++ b/www/wwwstat/pkg-plist
@@ -3,6 +3,6 @@ bin/oldlog2new
bin/splitlog
bin/wwwerrs
bin/wwwstat
-lib/perl5/site_perl/i386-freebsd/domains.pl
-lib/perl5/site_perl/i386-freebsd/splitlog.rc
-lib/perl5/site_perl/i386-freebsd/wwwstat.rc
+lib/perl5/site_perl/5.005/i386-freebsd/domains.pl
+lib/perl5/site_perl/5.005/i386-freebsd/splitlog.rc
+lib/perl5/site_perl/5.005/i386-freebsd/wwwstat.rc