aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-01-29 11:26:27 +0800
committerade <ade@FreeBSD.org>2000-01-29 11:26:27 +0800
commit4c46cee02907780e3c68111ef038ff201cd72130 (patch)
tree4b50a8484f9c14c968debe29ccdd6d8530fbae33 /www
parentf7ff6e602ceee30b3988a129f06a62fc87c16577 (diff)
downloadfreebsd-ports-graphics-4c46cee02907780e3c68111ef038ff201cd72130.tar.gz
freebsd-ports-graphics-4c46cee02907780e3c68111ef038ff201cd72130.tar.zst
freebsd-ports-graphics-4c46cee02907780e3c68111ef038ff201cd72130.zip
A collection of modules that represent, create, and
extract information from HTML syntax trees. PR: 15862 Submitted by: Dmitry Sivachenko <dima@Chg.RU>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTML-Tree/Makefile28
-rw-r--r--www/p5-HTML-Tree/distinfo1
-rw-r--r--www/p5-HTML-Tree/pkg-comment1
-rw-r--r--www/p5-HTML-Tree/pkg-descr21
-rw-r--r--www/p5-HTML-Tree/pkg-plist7
6 files changed, 59 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index feb999c5cda..4b7dd1b944e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -91,6 +91,7 @@
SUBDIR += p5-HTML-Parser
SUBDIR += p5-HTML-QuickCheck
SUBDIR += p5-HTML-Stream
+ SUBDIR += p5-HTML-Tree
SUBDIR += p5-HTTPD-Tools
SUBDIR += p5-ParallelUA
SUBDIR += p5-WWW-Search
diff --git a/www/p5-HTML-Tree/Makefile b/www/p5-HTML-Tree/Makefile
new file mode 100644
index 00000000000..ed754261bd8
--- /dev/null
+++ b/www/p5-HTML-Tree/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-HTML-Tree
+# Version required: 0.62
+# Date created: 3 January 2000
+# Whom: Dmitry Sivachenko <dima@Chg.RU>
+#
+# $FreeBSD$
+#
+
+DISTNAME= HTML-Tree-0.62
+PKGNAME= p5-HTML-Tree-0.62
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+
+MAINTAINER= dima@Chg.RU
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/HTML/HeadParser.pm:${PORTSDIR}/www/p5-HTML-Parser
+
+USE_PERL5= YES
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+MAN3= HTML::Parse.3 HTML::TreeBuilder.3 HTML::AsSubs.3 HTML::Element.3
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Tree/distinfo b/www/p5-HTML-Tree/distinfo
new file mode 100644
index 00000000000..f38d0c226af
--- /dev/null
+++ b/www/p5-HTML-Tree/distinfo
@@ -0,0 +1 @@
+MD5 (HTML-Tree-0.62.tar.gz) = 4bf6a0b2545ffe43b150a6c0d23faf78
diff --git a/www/p5-HTML-Tree/pkg-comment b/www/p5-HTML-Tree/pkg-comment
new file mode 100644
index 00000000000..fc30b10e8cd
--- /dev/null
+++ b/www/p5-HTML-Tree/pkg-comment
@@ -0,0 +1 @@
+A collection of modules to manupulate HTML syntax trees
diff --git a/www/p5-HTML-Tree/pkg-descr b/www/p5-HTML-Tree/pkg-descr
new file mode 100644
index 00000000000..9c4c57d76f8
--- /dev/null
+++ b/www/p5-HTML-Tree/pkg-descr
@@ -0,0 +1,21 @@
+This is a collection of modules that represent, create, and extract
+information from HTML syntax trees.
+
+The modules present in this collection are:
+
+ HTML::Element - represents the nodes of the HTML syntax trees. The
+ elements have other elements and text segments as children.
+ The HTML::Element class have methods to methods to build,
+ alter, and traverse the structure of the tree.
+
+ HTML::TreeBuilder - uses HTML::Parser to read HTML document text and
+ build from it a syntax tree made of HTML::Element nodes.
+
+ HTML::Parse - deprecated. Now just a wrapper around
+ HTML::TreeBuilder
+
+ HTML::AsSubs - Easy way to build an HTML syntax tree by nesting
+ functions.
+
+--Dima
+dima@Chg.RU
diff --git a/www/p5-HTML-Tree/pkg-plist b/www/p5-HTML-Tree/pkg-plist
new file mode 100644
index 00000000000..63e48d86ce0
--- /dev/null
+++ b/www/p5-HTML-Tree/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/HTML/AsSubs.pm
+lib/perl5/site_perl/%%PERL_VER%%/HTML/Element.pm
+lib/perl5/site_perl/%%PERL_VER%%/HTML/Parse.pm
+lib/perl5/site_perl/%%PERL_VER%%/HTML/TreeBuilder.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML-Tree/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML-Tree
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/HTML 2>/dev/null || true