aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2010-12-05 19:05:38 +0800
committerrene <rene@FreeBSD.org>2010-12-05 19:05:38 +0800
commit5945be402b0e5a47dbf0983a5b17ea96f9d7c2f5 (patch)
tree995088f7104f0ef0765646b59eee2393f8f47c65 /www
parentc2d158cfff8e4aa9997a85e90a5d7359434be03d (diff)
downloadfreebsd-ports-graphics-5945be402b0e5a47dbf0983a5b17ea96f9d7c2f5.tar.gz
freebsd-ports-graphics-5945be402b0e5a47dbf0983a5b17ea96f9d7c2f5.tar.zst
freebsd-ports-graphics-5945be402b0e5a47dbf0983a5b17ea96f9d7c2f5.zip
Use the correct way to handle OPTIONS, as per bsd.port.options.mk
Prodded by: dougb
Diffstat (limited to 'www')
-rw-r--r--www/chromium/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index facc3140b37..95e67636e7d 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -64,11 +64,15 @@ GYP_DEFINES+= use_system_libxml=1
#GYP_DEFINES+= use_system_sqlite=0
#GYP_DEFINES+= use_system_zlib=1
+.include <bsd.port.options.mk>
+
OPTIONS= CODECS "Compile and enable patented codecs like H.264" off \
GCONF "Use gconf2 for preferences" on \
SSE2 "Use SSE2, disable this for PIII or older" on \
VPX "Use system libvpx for VP8 codec" on
+.include <bsd.port.pre.mk>
+
.if defined(WITH_CODECS)
GYP_DEFINES+= ffmpeg_branding=Chrome
.else
@@ -148,4 +152,4 @@ do-install:
cd ${WRKSRC}/out/${BUILDTYPE} && ${COPYTREE_SHARE} "locales resources" ${DATADIR}
${LN} -sf ${DATADIR}/chrome ${PREFIX}/bin/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>