aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-02-24 18:36:05 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-02-24 18:36:05 +0800
commit5a00ec87d2d48d307832589bccfa11aa0bafcda1 (patch)
tree9780838b90d51f37ef7ff80f855e3961f64b1bf9 /www
parent607f93351c77f7f6776208c3f3cf5b05bcae943e (diff)
downloadfreebsd-ports-graphics-5a00ec87d2d48d307832589bccfa11aa0bafcda1.tar.gz
freebsd-ports-graphics-5a00ec87d2d48d307832589bccfa11aa0bafcda1.tar.zst
freebsd-ports-graphics-5a00ec87d2d48d307832589bccfa11aa0bafcda1.zip
- Add HPACK option
Diffstat (limited to 'www')
-rw-r--r--www/nghttp2/Makefile6
-rw-r--r--www/nghttp2/pkg-plist2
2 files changed, 8 insertions, 0 deletions
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index 4712de06379..9bcc48a3133 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -14,6 +14,9 @@ LICENSE= MIT
LIB_DEPENDS= libevent_openssl.so:${PORTSDIR}/devel/libevent2 \
libspdylay.so:${PORTSDIR}/www/spdylay
+OPTIONS_DEFINE= HPACK
+OPTIONS_SUB= yes
+
CONFIGURE_ARGS= --disable-python-bindings \
--enable-app \
--enable-examples
@@ -31,6 +34,9 @@ USES= compiler:c++11-lang pathfix pkgconfig
PORTDOCS= *
+HPACK_CONFIGURE_ARGS= --enable-hpack-tools
+HPACK_LIB_DEPENDS= libjansson.so:${PORTSDIR}/devel/jansson
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 1000000 && !defined(WITH_OPENSSL_PORT)
diff --git a/www/nghttp2/pkg-plist b/www/nghttp2/pkg-plist
index 2b293642eed..2b89c6531ee 100644
--- a/www/nghttp2/pkg-plist
+++ b/www/nghttp2/pkg-plist
@@ -1,3 +1,5 @@
+%%HPACK%%bin/deflatehd
+%%HPACK%%bin/inflatehd
bin/nghttp
bin/nghttpd
bin/nghttpx