aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
committermarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
commit5cc9328814fb9b8e64ff3588af7e6031c1d3514b (patch)
treedf0b6bb8e4e84920da9881d421090dc67f70c629 /www
parente058c31decaf84a24b7ab7306f65221b33ada080 (diff)
downloadfreebsd-ports-graphics-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.gz
freebsd-ports-graphics-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.zst
freebsd-ports-graphics-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.zip
Apply a big libtool patch to allow porters to use the libtool installed by
the libtoolX ports instead of the one included with each port. Ports that set USE_LIBTOOL_VER=X will now use the ports version of libtool instead of the included version. To restore previous behavior, use the new macro, USE_INC_LIBTOOL_VER. Both macros accept the same argument: a libtool version. For example, to use the ports version of libtool-1.5, add the following to your Makefile: USE_LIBTOOL_VER= 15 To use the included version of libtool with extra hacks provided by libtool-1.5, add the following to your Makefile: USE_INC_LIBTOOL_VER= 15 With this change, ports that had to add additional libtool hacks to prevent .la files from being installed or to fix certain threading issues can now delete those hacks (after appropriate testing, of course). PR: 63944 Based on work by:eik and marcus Approved by: ade (autotools maintainer) Tested by: kris on pointyhat Bound to be hidden problems: You bet
Diffstat (limited to 'www')
-rw-r--r--www/bookmarkbridge/Makefile2
-rw-r--r--www/cgicc/Makefile2
-rw-r--r--www/glibwww/Makefile2
-rw-r--r--www/gtkhtml/Makefile2
-rw-r--r--www/libghttp/Makefile2
-rw-r--r--www/libgtkhtml/Makefile2
-rw-r--r--www/libwww/Makefile2
-rw-r--r--www/screem-devel/Makefile2
-rw-r--r--www/screem/Makefile2
9 files changed, 9 insertions, 9 deletions
diff --git a/www/bookmarkbridge/Makefile b/www/bookmarkbridge/Makefile
index 10be4fbb06e..1fa50b7601f 100644
--- a/www/bookmarkbridge/Makefile
+++ b/www/bookmarkbridge/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
USE_QT_VER= 3
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-mt --program-prefix="" \
--with-libxml2-include="${LOCALBASE}/include/libxml2"
diff --git a/www/cgicc/Makefile b/www/cgicc/Makefile
index 97519e43f3b..7a0a8e5c71a 100644
--- a/www/cgicc/Makefile
+++ b/www/cgicc/Makefile
@@ -16,7 +16,7 @@ COMMENT= A C++ class library for writing CGI applications
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAKE_ARGS= NOPORTDOCS=${NOPORTDOCS}
INSTALLS_SHLIB= yes
diff --git a/www/glibwww/Makefile b/www/glibwww/Makefile
index 4e4e2aecca0..f4100e528fd 100644
--- a/www/glibwww/Makefile
+++ b/www/glibwww/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= wwwzip.1:${PORTSDIR}/www/libwww
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomelibs
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/www/gtkhtml/Makefile b/www/gtkhtml/Makefile
index bf3ca17511f..9a29a009205 100644
--- a/www/gtkhtml/Makefile
+++ b/www/gtkhtml/Makefile
@@ -23,7 +23,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix gnomehier glibwww libghttp libcapplet gal
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_ARGS= --with-gconf=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/www/libghttp/Makefile b/www/libghttp/Makefile
index 537f0a6b221..ec0b2c9886c 100644
--- a/www/libghttp/Makefile
+++ b/www/libghttp/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= sources/libghttp/1.0
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME http client library
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
.include <bsd.port.mk>
diff --git a/www/libgtkhtml/Makefile b/www/libgtkhtml/Makefile
index 044cf61c9b1..5c409936855 100644
--- a/www/libgtkhtml/Makefile
+++ b/www/libgtkhtml/Makefile
@@ -21,7 +21,7 @@ USE_GMAKE= yes
USE_REINPLACE= yes
USE_GNOME= gnomeprefix gnomehack lthack libxslt gnomevfs2 gail
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/www/libwww/Makefile b/www/libwww/Makefile
index 0ad9196703e..eab75b71930 100644
--- a/www/libwww/Makefile
+++ b/www/libwww/Makefile
@@ -16,7 +16,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= The W3C Reference Library
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_GMAKE= yes
CONFIGURE_ARGS= --enable-shared --enable-static --with-zlib
USE_PERL5_BUILD=yes
diff --git a/www/screem-devel/Makefile b/www/screem-devel/Makefile
index f7edccb371c..0475749ea68 100644
--- a/www/screem-devel/Makefile
+++ b/www/screem-devel/Makefile
@@ -23,7 +23,7 @@ USE_X_PREFIX= yes
USE_XPM= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui libgnomeprintui libgtkhtml \
gtksourceview lthack intlhack
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
.ifndef WITHOUT_OPENSSL
diff --git a/www/screem/Makefile b/www/screem/Makefile
index f7edccb371c..0475749ea68 100644
--- a/www/screem/Makefile
+++ b/www/screem/Makefile
@@ -23,7 +23,7 @@ USE_X_PREFIX= yes
USE_XPM= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui libgnomeprintui libgtkhtml \
gtksourceview lthack intlhack
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
.ifndef WITHOUT_OPENSSL