aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-10-09 02:34:51 +0800
committermiwi <miwi@FreeBSD.org>2006-10-09 02:34:51 +0800
commit5f935638be7c207148bcf778b38e3dc6667194ab (patch)
tree52e4397d90239479cf846e93bafa17d12de7e488 /www
parent4d38dac59eae555d1bf283689a0c326400bd732b (diff)
downloadfreebsd-ports-graphics-5f935638be7c207148bcf778b38e3dc6667194ab.tar.gz
freebsd-ports-graphics-5f935638be7c207148bcf778b38e3dc6667194ab.tar.zst
freebsd-ports-graphics-5f935638be7c207148bcf778b38e3dc6667194ab.zip
- Add MASTER_SITES
- Switch to bz2 distfile - cleanup Makefile PR: ports/104150 Submitted by: Babak Farrokhi <babak@farrokhi.net> (Maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/kannel/Makefile16
-rw-r--r--www/kannel/distinfo6
2 files changed, 12 insertions, 10 deletions
diff --git a/www/kannel/Makefile b/www/kannel/Makefile
index 11ed6d9cca2..470217a8ec9 100644
--- a/www/kannel/Makefile
+++ b/www/kannel/Makefile
@@ -7,7 +7,8 @@
PORTNAME= kannel
PORTVERSION= 1.4.1
CATEGORIES= www
-MASTER_SITES= http://www.kannel.org/download/%SUBDIR%/
+MASTER_SITES= http://www.kannel.org/download/%SUBDIR%/ \
+ http://farrokhi.net/distfiles/
MASTER_SITE_SUBDIR= ${PORTVERSION}
DISTNAME= gateway-${PORTVERSION}
@@ -19,6 +20,7 @@ LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_GNOME= libxml2
USE_OPENSSL= yes
USE_GMAKE= yes
+USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-cflags="${CPPFLAGS}" --with-libs="${LDFLAGS}" \
--enable-pcre=yes --enable-docs=no --with-malloc=native \
@@ -42,14 +44,14 @@ post-patch:
s|-lkse||g' ${WRKSRC}/configure
post-install:
-.for file in wapkannel.conf smskannel.conf
- ${INSTALL_DATA} ${WRKSRC}/gw/${file} ${PREFIX}/etc/${file}.sample
+.for filename in wapkannel.conf smskannel.conf
+ ${INSTALL_DATA} ${WRKSRC}/gw/${filename} ${PREFIX}/etc/${filename}.sample
.endfor
-.for file in mtbatch seewbmp wmlsc wmlsdasm
- @${STRIP_CMD} ${PREFIX}/bin/${file}
+.for filename in mtbatch seewbmp wmlsc wmlsdasm
+ @${STRIP_CMD} ${PREFIX}/bin/${filename}
.endfor
-.for file in bearerbox run_kannel_box smsbox wapbox
- @${STRIP_CMD} ${PREFIX}/sbin/${file}
+.for filename in bearerbox run_kannel_box smsbox wapbox
+ @${STRIP_CMD} ${PREFIX}/sbin/${filename}
.endfor
.include <bsd.port.post.mk>
diff --git a/www/kannel/distinfo b/www/kannel/distinfo
index 5476c227d31..fbd75598855 100644
--- a/www/kannel/distinfo
+++ b/www/kannel/distinfo
@@ -1,3 +1,3 @@
-MD5 (gateway-1.4.1.tar.gz) = fe7b782c1e47639718ecd3deca05b023
-SHA256 (gateway-1.4.1.tar.gz) = 0a70a1507883cba9bd44a0de39a04d3480f9781359a79f6f662020862270e44b
-SIZE (gateway-1.4.1.tar.gz) = 2596267
+MD5 (gateway-1.4.1.tar.bz2) = ae78aec906931e2af73f5a6245520cca
+SHA256 (gateway-1.4.1.tar.bz2) = 846d13676deaf6e4ffd485bb0bb963bd6716d169da1285f16eb017b7d5d3f396
+SIZE (gateway-1.4.1.tar.bz2) = 2240388