aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2002-01-10 23:22:14 +0800
committerkevlo <kevlo@FreeBSD.org>2002-01-10 23:22:14 +0800
commit5fd3e4a308f026c43a93a632c82763df0352722e (patch)
treedc21fd6e47d9a21728bd1d4016e49aa2496046a2 /www
parentaa67e48f47bc7669fddf0e08c4dd257c4e76f2bb (diff)
downloadfreebsd-ports-graphics-5fd3e4a308f026c43a93a632c82763df0352722e.tar.gz
freebsd-ports-graphics-5fd3e4a308f026c43a93a632c82763df0352722e.tar.zst
freebsd-ports-graphics-5fd3e4a308f026c43a93a632c82763df0352722e.zip
Fix for Python 2.2 re module
PR: 33726 Submitted by: MAINTAINER
Diffstat (limited to 'www')
-rw-r--r--www/moinmoin/Makefile1
-rw-r--r--www/moinmoin/files/patch-MoinMoin::parser::wiki.py11
2 files changed, 12 insertions, 0 deletions
diff --git a/www/moinmoin/Makefile b/www/moinmoin/Makefile
index ffb66576244..48a8ad67661 100644
--- a/www/moinmoin/Makefile
+++ b/www/moinmoin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= moinmoin
PORTVERSION= 0.10
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= moin
diff --git a/www/moinmoin/files/patch-MoinMoin::parser::wiki.py b/www/moinmoin/files/patch-MoinMoin::parser::wiki.py
new file mode 100644
index 00000000000..91bc343ba18
--- /dev/null
+++ b/www/moinmoin/files/patch-MoinMoin::parser::wiki.py
@@ -0,0 +1,11 @@
+--- MoinMoin/parser/wiki.py.orig Wed Jan 9 21:20:17 2002
++++ MoinMoin/parser/wiki.py Wed Jan 9 21:22:55 2002
+@@ -388,7 +388,7 @@
+ def replace(self, match):
+ #hit = filter(lambda g: g[1], match.groupdict().items())
+ for type, hit in match.groupdict().items():
+- if hit is not None:
++ if hit is not None and type != 'hmarker':
+ ##print "###", cgi.escape(`type`), cgi.escape(`hit`), "###"
+ if self.in_pre and type not in ['pre', 'ent']:
+ return self.highlight_text(hit)