aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2004-10-28 10:32:09 +0800
committerclsung <clsung@FreeBSD.org>2004-10-28 10:32:09 +0800
commit614091ba4d5338e38a1c12a0d2af2d0e35aa5854 (patch)
tree23ab191856b80aa880539b9555d4ebe81ab5669f /www
parent07708f1e288a3ef88e34adda4ed72e60187ef5eb (diff)
downloadfreebsd-ports-graphics-614091ba4d5338e38a1c12a0d2af2d0e35aa5854.tar.gz
freebsd-ports-graphics-614091ba4d5338e38a1c12a0d2af2d0e35aa5854.tar.zst
freebsd-ports-graphics-614091ba4d5338e38a1c12a0d2af2d0e35aa5854.zip
- A PHP and MySQL based blogging platform
- Run in Apache PR: ports/73190 Submitted by: clsung Approved by: co-mentor (vanilla)
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/lifetype/Makefile62
-rw-r--r--www/lifetype/distinfo2
-rw-r--r--www/lifetype/pkg-descr8
-rw-r--r--www/lifetype/pkg-message7
-rw-r--r--www/lifetype/pkg-plist1
-rw-r--r--www/plog/Makefile62
-rw-r--r--www/plog/distinfo2
-rw-r--r--www/plog/pkg-descr8
-rw-r--r--www/plog/pkg-message7
-rw-r--r--www/plog/pkg-plist1
11 files changed, 161 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e44e3d55d5f..24c47275c57 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -576,6 +576,7 @@
SUBDIR += phpgedview
SUBDIR += phpwebapp
SUBDIR += phpwiki
+ SUBDIR += plog
SUBDIR += plone
SUBDIR += plugger
SUBDIR += plugger-plugins-hubbe
diff --git a/www/lifetype/Makefile b/www/lifetype/Makefile
new file mode 100644
index 00000000000..65cf7741b27
--- /dev/null
+++ b/www/lifetype/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: plog
+# Date created: 2004-10-27
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= plog
+PORTVERSION= 0.3.2
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= plog
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= A PHP and MySQL based blogging platform
+
+USE_BZIP2= YES
+
+USE_PHP= mysql
+PHP4_PORT?= www/mod_php4
+NO_BUILD= YES
+WANT_PHP_WEB= YES
+PLOGDIR?= www/data-dist/plog
+PLIST= ${WRKDIR}/pkg-plist
+
+OPTIONS= GD "With GD Support" on \
+ IMAGICK "With ImageMagick Support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GD)
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/gd.so:${PORTSDIR}/${gd_DEPENDS}
+.endif
+
+.if defined(WITH_IMAGICK)
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/imagick.so:${PORTSDIR}/${imagick_DEPENDS}
+.endif
+
+.if !defined(WITH_GD) && !defined(WITH_IMAGICK)
+pre-patch:
+ @${ECHO_CMD} "Without GD or ImageMagick support. No thumbnails will be generated at all."
+.endif
+
+pre-install:
+ @${RM} ${WRKSRC}/.cvsignore
+ cd ${WRKSRC} && ${FIND} -s . -type f | \
+ ${SED} -e 's|^./||;s|^|${PLOGDIR}/|' > ${PLIST} \
+ && ${FIND} -d * -type d | \
+ ${SED} -e 's|^|@dirrm ${PLOGDIR}/|' >> ${PLIST} \
+ && ${ECHO_CMD} @dirrm ${PLOGDIR} >> ${PLIST}
+
+do-install:
+ -${MKDIR} ${PREFIX}/${PLOGDIR}
+ @${CHOWN} www:www ${PREFIX}/${PLOGDIR}
+ @${CHMOD} 755 ${PREFIX}/${PLOGDIR}
+ @${CP} -R ${WRKSRC}/ ${PREFIX}/${PLOGDIR}
+ @${CHOWN} www:www ${PREFIX}/${PLOGDIR}/tmp
+
+post-install:
+ @${SED} -e 's|%%PLOGDIR%%|${PREFIX}/${PLOGDIR}|' ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/lifetype/distinfo b/www/lifetype/distinfo
new file mode 100644
index 00000000000..486b907aa1c
--- /dev/null
+++ b/www/lifetype/distinfo
@@ -0,0 +1,2 @@
+MD5 (plog-0.3.2.tar.bz2) = 1c6bb120930306646af92ddc0f0b557f
+SIZE (plog-0.3.2.tar.bz2) = 1003647
diff --git a/www/lifetype/pkg-descr b/www/lifetype/pkg-descr
new file mode 100644
index 00000000000..31e8fe0cb66
--- /dev/null
+++ b/www/lifetype/pkg-descr
@@ -0,0 +1,8 @@
+pLog is a PHP and MySQL based blogging platform and its main goals
+are flexibility and extendibility. It uses a powerful template system
+based on the Smarty template engine to render the templates, whick
+makes the platform highly customizable and safer to let other people
+customize the templates, since the presentation code is isolated from
+the PHP code.
+
+WWW: http://www.plogworld.org/
diff --git a/www/lifetype/pkg-message b/www/lifetype/pkg-message
new file mode 100644
index 00000000000..7adf1a1a9bc
--- /dev/null
+++ b/www/lifetype/pkg-message
@@ -0,0 +1,7 @@
+
+ **** NOTE ****
+For first use of pLog, remember to point your browser to
+
+http://your.plog.host/wizard.php
+
+Maybe you should prepare a empty database first.
diff --git a/www/lifetype/pkg-plist b/www/lifetype/pkg-plist
new file mode 100644
index 00000000000..d0ac09258d0
--- /dev/null
+++ b/www/lifetype/pkg-plist
@@ -0,0 +1 @@
+@comment real PLIST will be generated in pre-install phase
diff --git a/www/plog/Makefile b/www/plog/Makefile
new file mode 100644
index 00000000000..65cf7741b27
--- /dev/null
+++ b/www/plog/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: plog
+# Date created: 2004-10-27
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= plog
+PORTVERSION= 0.3.2
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= plog
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= A PHP and MySQL based blogging platform
+
+USE_BZIP2= YES
+
+USE_PHP= mysql
+PHP4_PORT?= www/mod_php4
+NO_BUILD= YES
+WANT_PHP_WEB= YES
+PLOGDIR?= www/data-dist/plog
+PLIST= ${WRKDIR}/pkg-plist
+
+OPTIONS= GD "With GD Support" on \
+ IMAGICK "With ImageMagick Support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GD)
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/gd.so:${PORTSDIR}/${gd_DEPENDS}
+.endif
+
+.if defined(WITH_IMAGICK)
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/imagick.so:${PORTSDIR}/${imagick_DEPENDS}
+.endif
+
+.if !defined(WITH_GD) && !defined(WITH_IMAGICK)
+pre-patch:
+ @${ECHO_CMD} "Without GD or ImageMagick support. No thumbnails will be generated at all."
+.endif
+
+pre-install:
+ @${RM} ${WRKSRC}/.cvsignore
+ cd ${WRKSRC} && ${FIND} -s . -type f | \
+ ${SED} -e 's|^./||;s|^|${PLOGDIR}/|' > ${PLIST} \
+ && ${FIND} -d * -type d | \
+ ${SED} -e 's|^|@dirrm ${PLOGDIR}/|' >> ${PLIST} \
+ && ${ECHO_CMD} @dirrm ${PLOGDIR} >> ${PLIST}
+
+do-install:
+ -${MKDIR} ${PREFIX}/${PLOGDIR}
+ @${CHOWN} www:www ${PREFIX}/${PLOGDIR}
+ @${CHMOD} 755 ${PREFIX}/${PLOGDIR}
+ @${CP} -R ${WRKSRC}/ ${PREFIX}/${PLOGDIR}
+ @${CHOWN} www:www ${PREFIX}/${PLOGDIR}/tmp
+
+post-install:
+ @${SED} -e 's|%%PLOGDIR%%|${PREFIX}/${PLOGDIR}|' ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/plog/distinfo b/www/plog/distinfo
new file mode 100644
index 00000000000..486b907aa1c
--- /dev/null
+++ b/www/plog/distinfo
@@ -0,0 +1,2 @@
+MD5 (plog-0.3.2.tar.bz2) = 1c6bb120930306646af92ddc0f0b557f
+SIZE (plog-0.3.2.tar.bz2) = 1003647
diff --git a/www/plog/pkg-descr b/www/plog/pkg-descr
new file mode 100644
index 00000000000..31e8fe0cb66
--- /dev/null
+++ b/www/plog/pkg-descr
@@ -0,0 +1,8 @@
+pLog is a PHP and MySQL based blogging platform and its main goals
+are flexibility and extendibility. It uses a powerful template system
+based on the Smarty template engine to render the templates, whick
+makes the platform highly customizable and safer to let other people
+customize the templates, since the presentation code is isolated from
+the PHP code.
+
+WWW: http://www.plogworld.org/
diff --git a/www/plog/pkg-message b/www/plog/pkg-message
new file mode 100644
index 00000000000..7adf1a1a9bc
--- /dev/null
+++ b/www/plog/pkg-message
@@ -0,0 +1,7 @@
+
+ **** NOTE ****
+For first use of pLog, remember to point your browser to
+
+http://your.plog.host/wizard.php
+
+Maybe you should prepare a empty database first.
diff --git a/www/plog/pkg-plist b/www/plog/pkg-plist
new file mode 100644
index 00000000000..d0ac09258d0
--- /dev/null
+++ b/www/plog/pkg-plist
@@ -0,0 +1 @@
+@comment real PLIST will be generated in pre-install phase