aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-01-07 08:44:11 +0800
committerclement <clement@FreeBSD.org>2004-01-07 08:44:11 +0800
commit63e14b346207b99b3874c2e2fc7a6bf5afd11007 (patch)
tree81d1a51aa8204d470a41326a8a7857a8116c51fc /www
parent6709dfea20a94c3883660d0d98f444e9fcab739b (diff)
downloadfreebsd-ports-graphics-63e14b346207b99b3874c2e2fc7a6bf5afd11007.tar.gz
freebsd-ports-graphics-63e14b346207b99b3874c2e2fc7a6bf5afd11007.tar.zst
freebsd-ports-graphics-63e14b346207b99b3874c2e2fc7a6bf5afd11007.zip
Add mod_cvs-0.5.91 (known as mod_cvs2), apache2 version of mod_cvs.
mod_cvs recognizes if the files in your webtree are checked out from a CVS repository. If so, it checks if the file is up-to-date and, if not, updates it. Another neat feature of mod_cvs is the date-checkout feature. You can specify a date in the URI that gets passed to CVS, which checks out an older revision of the requested file and sends it to the user. WWW: http://resare.com/noa/mod_cvs/ Approved by: erwin (mentor) (implicitly)
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_cvs2/Makefile36
-rw-r--r--www/mod_cvs2/distinfo1
-rw-r--r--www/mod_cvs2/pkg-descr10
-rw-r--r--www/mod_cvs2/pkg-message6
-rw-r--r--www/mod_cvs2/pkg-plist4
6 files changed, 58 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f49767fda46..3e241c0cadc 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -214,6 +214,7 @@
SUBDIR += mod_color
SUBDIR += mod_csacek
SUBDIR += mod_cvs
+ SUBDIR += mod_cvs2
SUBDIR += mod_dav
SUBDIR += mod_dtcl
SUBDIR += mod_encoding
diff --git a/www/mod_cvs2/Makefile b/www/mod_cvs2/Makefile
new file mode 100644
index 00000000000..8a0f57f4671
--- /dev/null
+++ b/www/mod_cvs2/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: mod_cvs2
+# Date created: 6 January 2003
+# Whom: Clement Laforet <clement@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_cvs
+PORTVERSION= 0.5.91
+CATEGORIES= www
+MASTER_SITES= http://resare.com/noa/mod_cvs/dist/
+
+MAINTAINER= clement@FreeBSD.org
+COMMENT= A module that makes Apache 2 CVS aware
+
+USE_APACHE= yes
+WITH_APACHE2= yes
+
+LATEST_LINK= mod_cvs2
+
+PORTDOCS= reference.html guide.html README
+
+do-build:
+ @(cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c)
+
+do-install:
+ @(cd ${WRKSRC} && ${APXS} -i -A -n ${PORTNAME:S/mod_//} ${PORTNAME}.la)
+.if !defined (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+. for f in ${PORTDOCS:NREADME}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_cvs2/distinfo b/www/mod_cvs2/distinfo
new file mode 100644
index 00000000000..de3d66d8b5c
--- /dev/null
+++ b/www/mod_cvs2/distinfo
@@ -0,0 +1 @@
+MD5 (mod_cvs-0.5.91.tar.gz) = ef100c30ff734464c6194a2e707136b5
diff --git a/www/mod_cvs2/pkg-descr b/www/mod_cvs2/pkg-descr
new file mode 100644
index 00000000000..d0b9f664b22
--- /dev/null
+++ b/www/mod_cvs2/pkg-descr
@@ -0,0 +1,10 @@
+mod_cvs recognizes if the files in your webtree are checked out
+from a CVS repository. If so, it checks if the file is up-to-date
+and, if not, updates it.
+
+Another neat feature of mod_cvs is the date-checkout feature. You
+can specify a date in the URI that gets passed to CVS, which checks
+out an older revision of the requested file and sends it to the
+user.
+
+WWW: http://resare.com/noa/mod_cvs/
diff --git a/www/mod_cvs2/pkg-message b/www/mod_cvs2/pkg-message
new file mode 100644
index 00000000000..980fb7be273
--- /dev/null
+++ b/www/mod_cvs2/pkg-message
@@ -0,0 +1,6 @@
+-----------------------------------------------------------------
+You have installed mod_cvs, a module that makes Apache CVS aware.
+
+For help on using this module, please see the mod_cvs reference:
+ http://www.sub.nu/mod_cvs/reference.shtml
+-----------------------------------------------------------------
diff --git a/www/mod_cvs2/pkg-plist b/www/mod_cvs2/pkg-plist
new file mode 100644
index 00000000000..cb494f3c116
--- /dev/null
+++ b/www/mod_cvs2/pkg-plist
@@ -0,0 +1,4 @@
+libexec/apache2/mod_cvs.so
+@exec %D/sbin/apxs -e -a -n cvs %D/%f
+@unexec %D/sbin/apxs -e -a -n cvs %D/%f
+@unexec echo "===> If you do not plan on reinstalling mod_cvs, you must manually remove"; echo "===> references to it in httpd.conf."