aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2000-02-26 07:43:27 +0800
committerdirk <dirk@FreeBSD.org>2000-02-26 07:43:27 +0800
commit6b4c099efcb99f34d101f8cda518f697fce378c2 (patch)
tree7daf9a75f88e27436ce568f1503aaa07a8bc9ad7 /www
parent4bbf93da6c75cd429ec54ca3535ae9e68500cdd4 (diff)
downloadfreebsd-ports-graphics-6b4c099efcb99f34d101f8cda518f697fce378c2.tar.gz
freebsd-ports-graphics-6b4c099efcb99f34d101f8cda518f697fce378c2.tar.zst
freebsd-ports-graphics-6b4c099efcb99f34d101f8cda518f697fce378c2.zip
Merge openssl related changes from apache13-php3.
Diffstat (limited to 'www')
-rw-r--r--www/mod_php4/Makefile6
-rw-r--r--www/mod_php4/scripts/configure.php14
-rw-r--r--www/mod_php5/Makefile6
-rw-r--r--www/mod_php5/scripts/configure.php14
4 files changed, 26 insertions, 14 deletions
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index 5286218b36d..53f80b4d830 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -171,4 +171,10 @@ clean:
.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
+
+# Modssl needs to include bsd.port.pre.mk, so correct for this situation.
+.if defined(_PREMKINCLUDED)
+.include <bsd.port.post.mk>
+.else
.include <bsd.port.mk>
+.endif
diff --git a/www/mod_php4/scripts/configure.php b/www/mod_php4/scripts/configure.php
index 93cd6b66604..b639c1284e4 100644
--- a/www/mod_php4/scripts/configure.php
+++ b/www/mod_php4/scripts/configure.php
@@ -133,21 +133,21 @@ while [ "$1" ]; do
PKGNAME= apache+php+mod_ssl-\${VERSION_APACHE}+\${VERSION_PHP}+\${VERSION_MODSSL}
DISTFILES+= mod_ssl-\${VERSION_MODSSL}-\${VERSION_APACHE}\${EXTRACT_SUFX}
-BUILD_DEPENDS+= openssl:\${PORTSDIR}/security/openssl \\
- mm-config:\${PORTSDIR}/devel/mm \\
+USE_OPENSSL= RSA
+
+.include <bsd.port.pre.mk>
+
+BUILD_DEPENDS+= mm-config:\${PORTSDIR}/devel/mm \\
\${PREFIX}/lib/libmm.a:\${PORTSDIR}/devel/mm
-LIB_DEPENDS+= crypto.1:\${PORTSDIR}/security/openssl \\
- ssl.1:\${PORTSDIR}/security/openssl
-RUN_DEPENDS+= openssl:\${PORTSDIR}/security/openssl
VERSION_MODSSL= 2.5.0
-RESTRICTED= "Contains cryptography"
-
CONFIGURE_ARGS+=--enable-module=ssl \\
--enable-module=define
CONFIGURE_ENV+= SSL_BASE='SYSTEM' EAPI_MM='SYSTEM' PATH="\${PREFIX}/bin:\${PATH}"
+EXTRA_PATCHES+= \${PATCHDIR}/ssl_patch-aa
+
PLIST= \${PKGDIR}/PLIST.modssl
SSL= ssl
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index 5286218b36d..53f80b4d830 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -171,4 +171,10 @@ clean:
.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
+
+# Modssl needs to include bsd.port.pre.mk, so correct for this situation.
+.if defined(_PREMKINCLUDED)
+.include <bsd.port.post.mk>
+.else
.include <bsd.port.mk>
+.endif
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index 93cd6b66604..b639c1284e4 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -133,21 +133,21 @@ while [ "$1" ]; do
PKGNAME= apache+php+mod_ssl-\${VERSION_APACHE}+\${VERSION_PHP}+\${VERSION_MODSSL}
DISTFILES+= mod_ssl-\${VERSION_MODSSL}-\${VERSION_APACHE}\${EXTRACT_SUFX}
-BUILD_DEPENDS+= openssl:\${PORTSDIR}/security/openssl \\
- mm-config:\${PORTSDIR}/devel/mm \\
+USE_OPENSSL= RSA
+
+.include <bsd.port.pre.mk>
+
+BUILD_DEPENDS+= mm-config:\${PORTSDIR}/devel/mm \\
\${PREFIX}/lib/libmm.a:\${PORTSDIR}/devel/mm
-LIB_DEPENDS+= crypto.1:\${PORTSDIR}/security/openssl \\
- ssl.1:\${PORTSDIR}/security/openssl
-RUN_DEPENDS+= openssl:\${PORTSDIR}/security/openssl
VERSION_MODSSL= 2.5.0
-RESTRICTED= "Contains cryptography"
-
CONFIGURE_ARGS+=--enable-module=ssl \\
--enable-module=define
CONFIGURE_ENV+= SSL_BASE='SYSTEM' EAPI_MM='SYSTEM' PATH="\${PREFIX}/bin:\${PATH}"
+EXTRA_PATCHES+= \${PATCHDIR}/ssl_patch-aa
+
PLIST= \${PKGDIR}/PLIST.modssl
SSL= ssl