aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormmoll <mmoll@FreeBSD.org>2015-05-08 20:51:40 +0800
committermmoll <mmoll@FreeBSD.org>2015-05-08 20:51:40 +0800
commit6dc6bdb71d7f396bccf5beaa8d172afc225382cc (patch)
tree5b7defdab604c207174da978fd57d5587229e240 /www
parent9dfecd55274104594f4d61b6774b5aa790297602 (diff)
downloadfreebsd-ports-graphics-6dc6bdb71d7f396bccf5beaa8d172afc225382cc.tar.gz
freebsd-ports-graphics-6dc6bdb71d7f396bccf5beaa8d172afc225382cc.tar.zst
freebsd-ports-graphics-6dc6bdb71d7f396bccf5beaa8d172afc225382cc.zip
new port: www/rubygem-asana
Ruby wrapper for the Asana REST API WWW: http://github.com/rbright/asana PR: 199782 Differential Revision: https://reviews.freebsd.org/D2481 Submitted by: Torsten Zuehlsdorff <ports@toco-domains.de> Approved by: mat (mentor)
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-asana/Makefile20
-rw-r--r--www/rubygem-asana/distinfo2
-rw-r--r--www/rubygem-asana/pkg-descr5
4 files changed, 28 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e7317040fe8..846719afac7 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1789,6 +1789,7 @@
SUBDIR += rubygem-akami
SUBDIR += rubygem-amazon-ecs
SUBDIR += rubygem-anemone
+ SUBDIR += rubygem-asana
SUBDIR += rubygem-async_sinatra
SUBDIR += rubygem-bluecloth
SUBDIR += rubygem-bootstrap-sass
diff --git a/www/rubygem-asana/Makefile b/www/rubygem-asana/Makefile
new file mode 100644
index 00000000000..92aa31ae9c0
--- /dev/null
+++ b/www/rubygem-asana/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= asana
+PORTVERSION= 0.0.6
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby wrapper for the Asana REST API
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-activeresource>=3.2.3:${PORTSDIR}/www/rubygem-activeresource
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-asana/distinfo b/www/rubygem-asana/distinfo
new file mode 100644
index 00000000000..d85d0885af8
--- /dev/null
+++ b/www/rubygem-asana/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/asana-0.0.6.gem) = 97b5746426956cd347627f80f83e267084572282cf84f4320ea90dc8fd2d62f4
+SIZE (rubygem/asana-0.0.6.gem) = 11264
diff --git a/www/rubygem-asana/pkg-descr b/www/rubygem-asana/pkg-descr
new file mode 100644
index 00000000000..ceeb55d3247
--- /dev/null
+++ b/www/rubygem-asana/pkg-descr
@@ -0,0 +1,5 @@
+This gem is a simple Ruby wrapper for the Asana REST API. It uses
+ActiveResource to provide a simple, familiar interface for
+accessing your Asana account.
+
+WWW: http://github.com/rbright/asana