aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2002-06-08 04:22:28 +0800
committertobez <tobez@FreeBSD.org>2002-06-08 04:22:28 +0800
commit723136887cb610cb7cdce9b78ba0bd47a2542d4e (patch)
treed8ffd98dd744c05cce0c74ed93ca8b1da85aa09c /www
parent5d2320f6d503026ec035903660fe9f01c6448549 (diff)
downloadfreebsd-ports-graphics-723136887cb610cb7cdce9b78ba0bd47a2542d4e.tar.gz
freebsd-ports-graphics-723136887cb610cb7cdce9b78ba0bd47a2542d4e.tar.zst
freebsd-ports-graphics-723136887cb610cb7cdce9b78ba0bd47a2542d4e.zip
Add WWW::Automate, a perl5 module to automate interaction with websites.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-WWW-Automate/Makefile33
-rw-r--r--www/p5-WWW-Automate/distinfo1
-rw-r--r--www/p5-WWW-Automate/pkg-comment1
-rw-r--r--www/p5-WWW-Automate/pkg-descr12
-rw-r--r--www/p5-WWW-Automate/pkg-plist5
6 files changed, 53 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e15e986b1e4..93474790cf9 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -293,6 +293,7 @@
SUBDIR += p5-ParallelUA
SUBDIR += p5-Template-Toolkit
SUBDIR += p5-URI-Sequin
+ SUBDIR += p5-WWW-Automate
SUBDIR += p5-WWW-Babelfish
SUBDIR += p5-WWW-Link
SUBDIR += p5-WWW-Robot
diff --git a/www/p5-WWW-Automate/Makefile b/www/p5-WWW-Automate/Makefile
new file mode 100644
index 00000000000..9336d3f477a
--- /dev/null
+++ b/www/p5-WWW-Automate/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-WWW-Automate
+# Date created: 07 June 2002
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Automate
+PORTVERSION= 0.20
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/TokeParser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= WWW::Automate.3
+
+post-patch:
+ ${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1);$$1/;' \
+ ${WRKSRC}/lib/WWW/Automate.pm
+
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Automate/distinfo b/www/p5-WWW-Automate/distinfo
new file mode 100644
index 00000000000..ea34eeeec22
--- /dev/null
+++ b/www/p5-WWW-Automate/distinfo
@@ -0,0 +1 @@
+MD5 (WWW-Automate-0.20.tar.gz) = 0ab6c4cb5a6b62e760acbd854e16d684
diff --git a/www/p5-WWW-Automate/pkg-comment b/www/p5-WWW-Automate/pkg-comment
new file mode 100644
index 00000000000..29f549b71b9
--- /dev/null
+++ b/www/p5-WWW-Automate/pkg-comment
@@ -0,0 +1 @@
+A perl5 module to automate interaction with websites
diff --git a/www/p5-WWW-Automate/pkg-descr b/www/p5-WWW-Automate/pkg-descr
new file mode 100644
index 00000000000..4ae6e59e991
--- /dev/null
+++ b/www/p5-WWW-Automate/pkg-descr
@@ -0,0 +1,12 @@
+This module is intended to help you automate interaction with a website.
+It bears a not-very-remarkable outwards resemblance to WWW::Chat, on
+which it is based. The main difference between this module and
+WWW::Chat is that WWW::Chat requires a pre-processing stage before you
+can run your script, whereas WWW::Automate does not.
+
+WWW::Automate is a subclass of LWP::UserAgent, so anything you can do
+with an LWP::UserAgent, you can also do with this. See LWP::UserAgent
+for more information on the possibilities.
+
+Author: Kirrily 'Skud' Robert <skud@infotrope.net>
+WWW: http://search.cpan.org/search?dist=WWW-Automate
diff --git a/www/p5-WWW-Automate/pkg-plist b/www/p5-WWW-Automate/pkg-plist
new file mode 100644
index 00000000000..7c9e801e385
--- /dev/null
+++ b/www/p5-WWW-Automate/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/WWW/Automate/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/WWW/Automate.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/WWW/Automate
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/WWW 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/WWW 2>/dev/null || true