aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-08-22 14:30:05 +0800
committerclsung <clsung@FreeBSD.org>2006-08-22 14:30:05 +0800
commit7882e3c4fcc586422a87d661f3d91d5a1a1932b6 (patch)
tree502fb851cd1a8c474ed20056180fe639076de728 /www
parent3c59174bdb12c26d01cc465f7f2395a2b97bfb00 (diff)
downloadfreebsd-ports-graphics-7882e3c4fcc586422a87d661f3d91d5a1a1932b6.tar.gz
freebsd-ports-graphics-7882e3c4fcc586422a87d661f3d91d5a1a1932b6.tar.zst
freebsd-ports-graphics-7882e3c4fcc586422a87d661f3d91d5a1a1932b6.zip
Add p5-WebService-Basecamp 0.1.1, perl interface to the Basecamp API
webservice. PR: ports/102233 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-WebService-Basecamp/Makefile31
-rw-r--r--www/p5-WebService-Basecamp/distinfo3
-rw-r--r--www/p5-WebService-Basecamp/pkg-descr21
-rw-r--r--www/p5-WebService-Basecamp/pkg-plist6
5 files changed, 62 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a482fc50fb0..992a1c69324 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -810,6 +810,7 @@
SUBDIR += p5-WWW-TWSMS
SUBDIR += p5-WWW-VenusEnvy
SUBDIR += p5-WWW-Wikipedia
+ SUBDIR += p5-WebService-Basecamp
SUBDIR += p5-WebService-Bloglines
SUBDIR += p5-WebService-NoPaste
SUBDIR += p5-WebService-Technorati
diff --git a/www/p5-WebService-Basecamp/Makefile b/www/p5-WebService-Basecamp/Makefile
new file mode 100644
index 00000000000..cc3d0f7e18c
--- /dev/null
+++ b/www/p5-WebService-Basecamp/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-WebService-Basecamp
+# Date created: 2006-08-18
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WebService-Basecamp
+PORTVERSION= 0.1.1
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WebService
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl interface to the Basecamp API webservice
+
+RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple
+
+PERL_CONFIGURE= yes
+
+MAN3= WebService::Basecamp.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # Inherited from www/p5-libwww
+IGNORE= requires Perl 5.6.0 or newer. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WebService-Basecamp/distinfo b/www/p5-WebService-Basecamp/distinfo
new file mode 100644
index 00000000000..2592c2b4904
--- /dev/null
+++ b/www/p5-WebService-Basecamp/distinfo
@@ -0,0 +1,3 @@
+MD5 (WebService-Basecamp-0.1.1.tar.gz) = 85beddbdd1ce6e4d87a5eef066a95dbc
+SHA256 (WebService-Basecamp-0.1.1.tar.gz) = 284bba537743326ba883102017332f4373efebc6682c2ab9452c6f34b3411a4a
+SIZE (WebService-Basecamp-0.1.1.tar.gz) = 23204
diff --git a/www/p5-WebService-Basecamp/pkg-descr b/www/p5-WebService-Basecamp/pkg-descr
new file mode 100644
index 00000000000..59cb367477a
--- /dev/null
+++ b/www/p5-WebService-Basecamp/pkg-descr
@@ -0,0 +1,21 @@
+Basecamp is a web based project collaboration tool that makes it
+simple to communicate and collaborate on projects. Basecamp is built
+on the Ruby on Rails platform but provides a webservice API to many of
+the application functions. WebService::Basecamp is a Perl interface to
+the Basecamp web service API.
+
+For more information on Basecamp, visit the Basecamp website.
+http://www.basecamphq.com.
+
+This module does much of the heavy lifting for you when accessing the
+Basecamp API. Once initialising a WebService::Basecamp object you can
+access the API function via method calls. The module takes care of the
+creation and parsing of the XML (using XML::Simple) that relays the
+data across the web service, however there is an option to access the
+XML directly (see new()).
+
+The documentation for this module is based on the Basecamp API docs
+available at http://www.basecamphq.com/api. It is recommended you read
+the official docs to become familiar with the data reference.
+
+WWW: http://search.cpan.org/dist/WebService-Basecamp/
diff --git a/www/p5-WebService-Basecamp/pkg-plist b/www/p5-WebService-Basecamp/pkg-plist
new file mode 100644
index 00000000000..c52287bf0be
--- /dev/null
+++ b/www/p5-WebService-Basecamp/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/Basecamp/.packlist
+%%SITE_PERL%%/WebService/Basecamp.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/Basecamp
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService
+@dirrmtry %%SITE_PERL%%/WebService