aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-03-18 02:32:27 +0800
committerclement <clement@FreeBSD.org>2004-03-18 02:32:27 +0800
commit844635eaa07eabcabae4685504035a183a550916 (patch)
treeec64d9ab8b1e08fc39702d3affcca1962a88209f /www
parent55101ad97da703b3bf8549cbbf9b7040e246d106 (diff)
downloadfreebsd-ports-graphics-844635eaa07eabcabae4685504035a183a550916.tar.gz
freebsd-ports-graphics-844635eaa07eabcabae4685504035a183a550916.tar.zst
freebsd-ports-graphics-844635eaa07eabcabae4685504035a183a550916.zip
Add mod_rpaf 0.5
rpaf changes the remote address of the client on incoming proxy requests. It is used in backend servers that needs to know the IP of the client, and works in conjunction with mod_proxy_add_forward (which sets the X-Forwarded-For header). When an X-Host header exists rpaf will take the hostname found here, put it into Apache, and update the virtualhost settings so that you can serve virtualhosts on the backend. Author: Thomas Eibner
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_rpaf/Makefile34
-rw-r--r--www/mod_rpaf/distinfo2
-rw-r--r--www/mod_rpaf/pkg-descr8
-rw-r--r--www/mod_rpaf/pkg-plist3
5 files changed, 48 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 783faf86092..c029ab21ac1 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -264,6 +264,7 @@
SUBDIR += mod_python3
SUBDIR += mod_roaming
SUBDIR += mod_roaming2
+ SUBDIR += mod_rpaf
SUBDIR += mod_ruby
SUBDIR += mod_scgi
SUBDIR += mod_security
diff --git a/www/mod_rpaf/Makefile b/www/mod_rpaf/Makefile
new file mode 100644
index 00000000000..6052e83cff2
--- /dev/null
+++ b/www/mod_rpaf/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: mod_rpaf
+# Date created: Mar 17, 2003
+# Whom: Clement Laforet <clement@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_rpaf
+PORTVERSION= 0.5
+CATEGORIES= www
+MASTER_SITES= http://stderr.net/apache/rpaf/download/
+
+MAINTAINER= clement@FreeBSD.org
+COMMENT= Make proxied requests appear with client IP
+
+USE_APACHE= yes
+
+.if defined(WITH_APACHE2)
+PLIST_SUB+= APACHE=apache2
+AP_EXT= la
+SRC_FILE= mod_rpaf-2.0.c
+.else
+PLIST_SUB+= APACHE=apache
+AP_EXT= so
+SRC_FILE= mod_rpaf.c
+.endif
+
+do-build:
+ @cd ${WRKSRC} && ${APXS} -c -o ${PORTNAME}.${AP_EXT} ${SRC_FILE}
+
+do-install:
+ ${APXS} -i -a -n ${PORTNAME:S/mod_//} ${WRKSRC}/${PORTNAME}.${AP_EXT}
+
+.include <bsd.port.mk>
diff --git a/www/mod_rpaf/distinfo b/www/mod_rpaf/distinfo
new file mode 100644
index 00000000000..8b06e2f6ed2
--- /dev/null
+++ b/www/mod_rpaf/distinfo
@@ -0,0 +1,2 @@
+MD5 (mod_rpaf-0.5.tar.gz) = 471fb059d6223a394f319b7c8ab45c4d
+SIZE (mod_rpaf-0.5.tar.gz) = 4482
diff --git a/www/mod_rpaf/pkg-descr b/www/mod_rpaf/pkg-descr
new file mode 100644
index 00000000000..533e405e23c
--- /dev/null
+++ b/www/mod_rpaf/pkg-descr
@@ -0,0 +1,8 @@
+rpaf changes the remote address of the client on incoming proxy
+requests. It is used in backend servers that needs to know the IP of the
+client, and works in conjunction with mod_proxy_add_forward (which sets
+the X-Forwarded-For header). When an X-Host header exists rpaf will take
+the hostname found here, put it into Apache, and update the virtualhost
+settings so that you can serve virtualhosts on the backend.
+
+WWW: http://stderr.net/apache/rpaf/
diff --git a/www/mod_rpaf/pkg-plist b/www/mod_rpaf/pkg-plist
new file mode 100644
index 00000000000..de91bc63a46
--- /dev/null
+++ b/www/mod_rpaf/pkg-plist
@@ -0,0 +1,3 @@
+libexec/%%APACHE%%/mod_rpaf.so
+@exec %D/sbin/apxs -e -a -n rpaf %D/%F
+@unexec %D/sbin/apxs -e -A -n rpaf %D/%F