aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-10-05 18:51:26 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-10-05 18:51:26 +0800
commit8bac7d61e58f89afea8f8b88cd67cf160a4c7bf1 (patch)
tree7b366ecb39e25117f0a644fabb63bf5650f44507 /www
parent9f6f248cef442222603c14a021c178db2885a994 (diff)
downloadfreebsd-ports-graphics-8bac7d61e58f89afea8f8b88cd67cf160a4c7bf1.tar.gz
freebsd-ports-graphics-8bac7d61e58f89afea8f8b88cd67cf160a4c7bf1.tar.zst
freebsd-ports-graphics-8bac7d61e58f89afea8f8b88cd67cf160a4c7bf1.zip
- Add p5-Net-Plurk 0.11
Net::Plurk - A perl interface to Plurk API WWW: http://search.cpan.org/dist/Net-Plurk/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Net-Plurk/Makefile39
-rw-r--r--www/p5-Net-Plurk/distinfo2
-rw-r--r--www/p5-Net-Plurk/pkg-descr3
-rw-r--r--www/p5-Net-Plurk/pkg-plist10
5 files changed, 55 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 2f3125ae130..b0c6c203774 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1098,6 +1098,7 @@
SUBDIR += p5-Net-Flickr-RDF
SUBDIR += p5-Net-FreshBooks-API
SUBDIR += p5-Net-GeoPlanet
+ SUBDIR += p5-Net-Plurk
SUBDIR += p5-Net-Trac
SUBDIR += p5-Net-YAP
SUBDIR += p5-Net-eBay
diff --git a/www/p5-Net-Plurk/Makefile b/www/p5-Net-Plurk/Makefile
new file mode 100644
index 00000000000..bc28e5edb32
--- /dev/null
+++ b/www/p5-Net-Plurk/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: p5-Net-Plurk
+# Date created: 2010-07-06
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Plurk
+PORTVERSION= 0.11
+CATEGORIES= www net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:CLSUNG
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= A perl interface to Plurk API
+
+BUILD_DEPENDS= p5-AnyEvent-HTTP>=0:${PORTSDIR}/www/p5-AnyEvent-HTTP \
+ p5-DateTime-Format-Strptime>=0:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
+ p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-HTTP-Lite>=0:${PORTSDIR}/www/p5-HTTP-Lite \
+ p5-JSON-Any>=0:${PORTSDIR}/converters/p5-JSON-Any \
+ p5-Math-Base36>=0:${PORTSDIR}/math/p5-Math-Base36 \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-Net-OAuth>=0.27:${PORTSDIR}/net/p5-Net-OAuth \
+ p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Plurk.3 \
+ Net::Plurk::OAuth.3 \
+ Net::Plurk::Plurk.3 \
+ Net::Plurk::User.3 \
+ Net::Plurk::UserProfile.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Net-Plurk/distinfo b/www/p5-Net-Plurk/distinfo
new file mode 100644
index 00000000000..213f3136ddd
--- /dev/null
+++ b/www/p5-Net-Plurk/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-Plurk-0.11.tar.gz) = 36684334cee4ebc55cc031f8cfbac0d5421dc741630630f19c82e95c91dbb35d
+SIZE (Net-Plurk-0.11.tar.gz) = 10089
diff --git a/www/p5-Net-Plurk/pkg-descr b/www/p5-Net-Plurk/pkg-descr
new file mode 100644
index 00000000000..cea3d658942
--- /dev/null
+++ b/www/p5-Net-Plurk/pkg-descr
@@ -0,0 +1,3 @@
+Net::Plurk - A perl interface to Plurk API
+
+WWW: http://search.cpan.org/dist/Net-Plurk/
diff --git a/www/p5-Net-Plurk/pkg-plist b/www/p5-Net-Plurk/pkg-plist
new file mode 100644
index 00000000000..5cff2961aa9
--- /dev/null
+++ b/www/p5-Net-Plurk/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/Net/Plurk.pm
+%%SITE_PERL%%/Net/Plurk/OAuth.pm
+%%SITE_PERL%%/Net/Plurk/Plurk.pm
+%%SITE_PERL%%/Net/Plurk/User.pm
+%%SITE_PERL%%/Net/Plurk/UserProfile.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Plurk/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Plurk
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/Net/Plurk
+@dirrmtry %%SITE_PERL%%/Net