aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2016-06-27 09:52:14 +0800
committerwen <wen@FreeBSD.org>2016-06-27 09:52:14 +0800
commit9911fa625c32cf7d145f0181b0927a968208f33f (patch)
treec4f98abab0e52845eaebf49593ceee1696dbb176 /www
parent59a0b6a7192c9fa91cdfd8d040fb26411caa2d73 (diff)
downloadfreebsd-ports-graphics-9911fa625c32cf7d145f0181b0927a968208f33f.tar.gz
freebsd-ports-graphics-9911fa625c32cf7d145f0181b0927a968208f33f.tar.zst
freebsd-ports-graphics-9911fa625c32cf7d145f0181b0927a968208f33f.zip
URLObject is a utility class for manipulating URLs. The latest incarnation of
this library builds upon the ideas of its predecessor, but aims for a clearer API, focusing on proper method names over operator overrides. It's also being developed from the ground up in a test-driven manner, and has full Sphinx documentation. WWW: http://github.com/zacharyvoase/urlobject PR: 210604 Submitted by: freebsd@skinc.ru
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-urlobject/Makefile22
-rw-r--r--www/py-urlobject/distinfo3
-rw-r--r--www/py-urlobject/pkg-descr7
4 files changed, 33 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index daf312140fa..2eb9ac10eef 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1778,6 +1778,7 @@
SUBDIR += py-uliweb
SUBDIR += py-urlgrabber
SUBDIR += py-urljr
+ SUBDIR += py-urlobject
SUBDIR += py-user_agent
SUBDIR += py-utidy
SUBDIR += py-w3lib
diff --git a/www/py-urlobject/Makefile b/www/py-urlobject/Makefile
new file mode 100644
index 00000000000..8ea725f2feb
--- /dev/null
+++ b/www/py-urlobject/Makefile
@@ -0,0 +1,22 @@
+# Created by: Ilia Skalozubov <freebsd@skinc.ru>
+# $FreeBSD$
+
+PORTNAME= urlobject
+PORTVERSION= 2.4.0
+CATEGORIES= www devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= URLObject-${PORTVERSION}
+
+MAINTAINER= freebsd@skinc.ru
+COMMENT= Utility class for manipulating URLs
+
+LICENSE= Unlicense
+LICENSE_NAME= The Unlicense
+LICENSE_FILE= ${WRKSRC}/UNLICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+USES= python:2.7+
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/www/py-urlobject/distinfo b/www/py-urlobject/distinfo
new file mode 100644
index 00000000000..e8fa3337e35
--- /dev/null
+++ b/www/py-urlobject/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1466991799
+SHA256 (URLObject-2.4.0.tar.gz) = f51272b12846db98af530b0a64f6593d2b1e8405f0aa580285b37ce8009b8d9c
+SIZE (URLObject-2.4.0.tar.gz) = 12533
diff --git a/www/py-urlobject/pkg-descr b/www/py-urlobject/pkg-descr
new file mode 100644
index 00000000000..3f52507fbcf
--- /dev/null
+++ b/www/py-urlobject/pkg-descr
@@ -0,0 +1,7 @@
+URLObject is a utility class for manipulating URLs. The latest incarnation of
+this library builds upon the ideas of its predecessor, but aims for a clearer
+API, focusing on proper method names over operator overrides. It's also being
+developed from the ground up in a test-driven manner, and has full Sphinx
+documentation.
+
+WWW: http://github.com/zacharyvoase/urlobject