aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-03-18 23:29:11 +0800
committerpav <pav@FreeBSD.org>2006-03-18 23:29:11 +0800
commit9f219d938eccbd5ec2c4b30127b1e2078c443df3 (patch)
tree9206d3d60a39e9113a075bf9be8e40ef12a73870 /www
parent7ad5cc53d7079447bd60565001a2c1cb819c2a29 (diff)
downloadfreebsd-ports-graphics-9f219d938eccbd5ec2c4b30127b1e2078c443df3.tar.gz
freebsd-ports-graphics-9f219d938eccbd5ec2c4b30127b1e2078c443df3.tar.zst
freebsd-ports-graphics-9f219d938eccbd5ec2c4b30127b1e2078c443df3.zip
- Allow to override install location
- Take maintainership PR: ports/94584 Submitted by: Shaun Amott <shaun@inerd.com>
Diffstat (limited to 'www')
-rw-r--r--www/phpSysInfo/Makefile20
-rw-r--r--www/phpSysInfo/distinfo1
-rw-r--r--www/phpsysinfo-dev/Makefile20
-rw-r--r--www/phpsysinfo-dev/distinfo1
-rw-r--r--www/phpsysinfo/Makefile20
-rw-r--r--www/phpsysinfo/distinfo1
6 files changed, 27 insertions, 36 deletions
diff --git a/www/phpSysInfo/Makefile b/www/phpSysInfo/Makefile
index bd451afeffd..f0c75094058 100644
--- a/www/phpSysInfo/Makefile
+++ b/www/phpSysInfo/Makefile
@@ -11,7 +11,7 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:L}
DISTNAME= ${PORTNAME:L}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@inerd.com
COMMENT= A php script that displays info about the host being accessed
USE_PHP= pcre xml
@@ -20,26 +20,24 @@ WANT_PHP_WEB= yes
WRKSRC= ${WRKDIR}/${PORTNAME:L}
WWWOWN?= www
WWWGRP?= www
-APACHEDIR= ${PREFIX}/www/data
-INSTALLDIR= ${APACHEDIR}/phpSysInfo
+WWWDIR?= www/data/${PORTNAME}
+DATADIR= ${PREFIX}/${WWWDIR}
NO_BUILD= yes
PLIST= ${WRKDIR}/plist
-PLIST_SUB= INSTALLDIR=${INSTALLDIR:S,^${PREFIX}/,,}
-
post-patch:
${RM} -f ${PLIST}
cd ${WRKSRC};\
- ${FIND} . ! -type d | ${SORT} | ${SED} "s|^.|%%INSTALLDIR%%|"\
+ ${FIND} . ! -type d | ${SORT} | ${SED} "s|^\.|${WWWDIR}|"\
>${PLIST};\
- ${FIND} . -type d | ${SORT} -r | ${SED} "s|^.|@dirrm %%INSTALLDIR%%|"\
+ ${FIND} . -type d | ${SORT} -r | ${SED} "s|^\.|@dirrm ${WWWDIR}|"\
>>${PLIST}
do-install:
- ${MKDIR} ${INSTALLDIR}
+ ${MKDIR} ${DATADIR}
cd ${WRKSRC}; ${FIND} . \
- | ${CPIO} -pdm -R ${WWWOWN}:${WWWGRP} ${INSTALLDIR}
- ${CHMOD} -R ${BINMODE} ${INSTALLDIR}
- ${FIND} ${INSTALLDIR} ! -type d | ${XARGS} ${CHMOD} ${NOBINMODE}
+ | ${CPIO} -pdm -R ${WWWOWN}:${WWWGRP} ${DATADIR}
+ ${CHMOD} -R ${BINMODE} ${DATADIR}
+ ${FIND} ${DATADIR} ! -type d | ${XARGS} ${CHMOD} ${NOBINMODE}
.include <bsd.port.mk>
diff --git a/www/phpSysInfo/distinfo b/www/phpSysInfo/distinfo
index ee211560508..def396d0367 100644
--- a/www/phpSysInfo/distinfo
+++ b/www/phpSysInfo/distinfo
@@ -1,4 +1,3 @@
MD5 (phpsysinfo-2.5.1.tar.gz) = 3b42b9df6685c81241d807a8ec8b1254
SHA256 (phpsysinfo-2.5.1.tar.gz) = 23b2d92c401fd10c0618639f96ce4aae90aa3ac74568ef0d535b20d0cec74f57
SIZE (phpsysinfo-2.5.1.tar.gz) = 196226
-
diff --git a/www/phpsysinfo-dev/Makefile b/www/phpsysinfo-dev/Makefile
index bd451afeffd..f0c75094058 100644
--- a/www/phpsysinfo-dev/Makefile
+++ b/www/phpsysinfo-dev/Makefile
@@ -11,7 +11,7 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:L}
DISTNAME= ${PORTNAME:L}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@inerd.com
COMMENT= A php script that displays info about the host being accessed
USE_PHP= pcre xml
@@ -20,26 +20,24 @@ WANT_PHP_WEB= yes
WRKSRC= ${WRKDIR}/${PORTNAME:L}
WWWOWN?= www
WWWGRP?= www
-APACHEDIR= ${PREFIX}/www/data
-INSTALLDIR= ${APACHEDIR}/phpSysInfo
+WWWDIR?= www/data/${PORTNAME}
+DATADIR= ${PREFIX}/${WWWDIR}
NO_BUILD= yes
PLIST= ${WRKDIR}/plist
-PLIST_SUB= INSTALLDIR=${INSTALLDIR:S,^${PREFIX}/,,}
-
post-patch:
${RM} -f ${PLIST}
cd ${WRKSRC};\
- ${FIND} . ! -type d | ${SORT} | ${SED} "s|^.|%%INSTALLDIR%%|"\
+ ${FIND} . ! -type d | ${SORT} | ${SED} "s|^\.|${WWWDIR}|"\
>${PLIST};\
- ${FIND} . -type d | ${SORT} -r | ${SED} "s|^.|@dirrm %%INSTALLDIR%%|"\
+ ${FIND} . -type d | ${SORT} -r | ${SED} "s|^\.|@dirrm ${WWWDIR}|"\
>>${PLIST}
do-install:
- ${MKDIR} ${INSTALLDIR}
+ ${MKDIR} ${DATADIR}
cd ${WRKSRC}; ${FIND} . \
- | ${CPIO} -pdm -R ${WWWOWN}:${WWWGRP} ${INSTALLDIR}
- ${CHMOD} -R ${BINMODE} ${INSTALLDIR}
- ${FIND} ${INSTALLDIR} ! -type d | ${XARGS} ${CHMOD} ${NOBINMODE}
+ | ${CPIO} -pdm -R ${WWWOWN}:${WWWGRP} ${DATADIR}
+ ${CHMOD} -R ${BINMODE} ${DATADIR}
+ ${FIND} ${DATADIR} ! -type d | ${XARGS} ${CHMOD} ${NOBINMODE}
.include <bsd.port.mk>
diff --git a/www/phpsysinfo-dev/distinfo b/www/phpsysinfo-dev/distinfo
index ee211560508..def396d0367 100644
--- a/www/phpsysinfo-dev/distinfo
+++ b/www/phpsysinfo-dev/distinfo
@@ -1,4 +1,3 @@
MD5 (phpsysinfo-2.5.1.tar.gz) = 3b42b9df6685c81241d807a8ec8b1254
SHA256 (phpsysinfo-2.5.1.tar.gz) = 23b2d92c401fd10c0618639f96ce4aae90aa3ac74568ef0d535b20d0cec74f57
SIZE (phpsysinfo-2.5.1.tar.gz) = 196226
-
diff --git a/www/phpsysinfo/Makefile b/www/phpsysinfo/Makefile
index bd451afeffd..f0c75094058 100644
--- a/www/phpsysinfo/Makefile
+++ b/www/phpsysinfo/Makefile
@@ -11,7 +11,7 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:L}
DISTNAME= ${PORTNAME:L}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@inerd.com
COMMENT= A php script that displays info about the host being accessed
USE_PHP= pcre xml
@@ -20,26 +20,24 @@ WANT_PHP_WEB= yes
WRKSRC= ${WRKDIR}/${PORTNAME:L}
WWWOWN?= www
WWWGRP?= www
-APACHEDIR= ${PREFIX}/www/data
-INSTALLDIR= ${APACHEDIR}/phpSysInfo
+WWWDIR?= www/data/${PORTNAME}
+DATADIR= ${PREFIX}/${WWWDIR}
NO_BUILD= yes
PLIST= ${WRKDIR}/plist
-PLIST_SUB= INSTALLDIR=${INSTALLDIR:S,^${PREFIX}/,,}
-
post-patch:
${RM} -f ${PLIST}
cd ${WRKSRC};\
- ${FIND} . ! -type d | ${SORT} | ${SED} "s|^.|%%INSTALLDIR%%|"\
+ ${FIND} . ! -type d | ${SORT} | ${SED} "s|^\.|${WWWDIR}|"\
>${PLIST};\
- ${FIND} . -type d | ${SORT} -r | ${SED} "s|^.|@dirrm %%INSTALLDIR%%|"\
+ ${FIND} . -type d | ${SORT} -r | ${SED} "s|^\.|@dirrm ${WWWDIR}|"\
>>${PLIST}
do-install:
- ${MKDIR} ${INSTALLDIR}
+ ${MKDIR} ${DATADIR}
cd ${WRKSRC}; ${FIND} . \
- | ${CPIO} -pdm -R ${WWWOWN}:${WWWGRP} ${INSTALLDIR}
- ${CHMOD} -R ${BINMODE} ${INSTALLDIR}
- ${FIND} ${INSTALLDIR} ! -type d | ${XARGS} ${CHMOD} ${NOBINMODE}
+ | ${CPIO} -pdm -R ${WWWOWN}:${WWWGRP} ${DATADIR}
+ ${CHMOD} -R ${BINMODE} ${DATADIR}
+ ${FIND} ${DATADIR} ! -type d | ${XARGS} ${CHMOD} ${NOBINMODE}
.include <bsd.port.mk>
diff --git a/www/phpsysinfo/distinfo b/www/phpsysinfo/distinfo
index ee211560508..def396d0367 100644
--- a/www/phpsysinfo/distinfo
+++ b/www/phpsysinfo/distinfo
@@ -1,4 +1,3 @@
MD5 (phpsysinfo-2.5.1.tar.gz) = 3b42b9df6685c81241d807a8ec8b1254
SHA256 (phpsysinfo-2.5.1.tar.gz) = 23b2d92c401fd10c0618639f96ce4aae90aa3ac74568ef0d535b20d0cec74f57
SIZE (phpsysinfo-2.5.1.tar.gz) = 196226
-