aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-12-15 12:44:16 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-12-15 12:44:16 +0800
commita768a348435ffe14a9e05fe089c51beaf1c0f528 (patch)
tree86fa30f1e5dd43136d0d9aaf12e2e03cc090f07b /www
parentfd39318564b4a3c5b9e84efc80c344b26048de7b (diff)
downloadfreebsd-ports-graphics-a768a348435ffe14a9e05fe089c51beaf1c0f528.tar.gz
freebsd-ports-graphics-a768a348435ffe14a9e05fe089c51beaf1c0f528.tar.zst
freebsd-ports-graphics-a768a348435ffe14a9e05fe089c51beaf1c0f528.zip
- Fix run-time linker errors due to missing -I, -L flags for.
Reported by: Dmitry Banschikov <d.banschikov@peterhost.ru> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/mod_tsa/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/www/mod_tsa/Makefile b/www/mod_tsa/Makefile
index a9ffe98b81e..6b20f3f579f 100644
--- a/www/mod_tsa/Makefile
+++ b/www/mod_tsa/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mod_tsa
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://am.nesiac.org/static/ \
http://ubique.spb.ru/src/
@@ -36,6 +36,8 @@ AP_EXTRAS+= -DMOD_TSA_VERSION=\\\"mod_tsa/${PORTVERSION}\\\"
AP_FAST_BUILD= yes
AP_GENPLIST= yes
SRC_FILE= mod_tsa.c tsa_util.c
+AP_INC= ${LOCALBASE}/include
+AP_LIB= ${LOCALBASE}/lib
PORTEXAMPLES= *.sql tsa.conf
@@ -45,18 +47,22 @@ PORTEXAMPLES= *.sql tsa.conf
USE_MYSQL= yes
CONFIGURE_ARGS+= --enable-mysql=yes
SRC_FILE+= db_mysql.c
+AP_INC+= -I${LOCALBASE}/include/mysql
+AP_LIB+= -L${LOCALBASE}/lib/mysql -lmysqlclient
.endif
.if defined(WITH_PGSQL)
USE_PGSQL= yes
CONFIGURE_ARGS+= --enable-pgsql=yes
SRC_FILE+= db_postgresql.c
+AP_LIB+= -lpq
.endif
.if defined(WITH_FIREBIRD)
USE_FIREBIRD= yes
CONFIGURE_ARGS+= --enable-firebird=yes
SRC_FILE+= db_firebird.c
+AP_LIB+= -lgds
.endif
.if defined(WITH_DEBUG)