aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-06-12 17:46:09 +0800
committeradamw <adamw@FreeBSD.org>2003-06-12 17:46:09 +0800
commitaaf166713559a44a8e20404e1e6eb14e1758a66b (patch)
tree001522fb512c55afb05368bed1bedb1a54f687a4 /www
parentbdac09a776abef8765f436443280f4aa3ba8ca0f (diff)
downloadfreebsd-ports-graphics-aaf166713559a44a8e20404e1e6eb14e1758a66b.tar.gz
freebsd-ports-graphics-aaf166713559a44a8e20404e1e6eb14e1758a66b.tar.zst
freebsd-ports-graphics-aaf166713559a44a8e20404e1e6eb14e1758a66b.zip
Remove REINPLACE commands that were rolled into gnomehack.
Diffstat (limited to 'www')
-rw-r--r--www/epiphany/Makefile4
-rw-r--r--www/galeon/Makefile5
-rw-r--r--www/gtkhtml/Makefile4
-rw-r--r--www/libgtkhtml/Makefile4
4 files changed, 2 insertions, 15 deletions
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index 45eb73df6b6..9ed8809c190 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -74,9 +74,7 @@ pre-everything::
@${ECHO_MSG} ""
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|mozilla-gtkmozembed|mozilla-gtkmozembed${HEADERS_SUFX}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|mozilla-gtkmozembed|mozilla-gtkmozembed${HEADERS_SUFX}|g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
's|-lpthread|${PTHREAD_LIBS}|g'
@${FIND} ${WRKSRC} -name "*.cpp" | ${XARGS} ${REINPLACE_CMD} -e \
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index 85d7284b1e8..6ddcc731105 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -12,8 +12,7 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A GNOME Web browser based on gecko (the Mozilla rendering engine)
-
+COMMENT= A GNOME Web browser based on gecko (the Mozilla rendering engine)
BUILD_DEPENDS= ${X11BASE}/include/mozilla${HEADERS_SUFX}/gtkembedmoz/gtkmozembed.h:${PORTSDIR}/www/mozilla-headers${HEADERS_SUFX} \
${X11BASE}/lib/${MOZILLA}/libgtkembedmoz.so:${PORTSDIR}/www/${MOZILLA}
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
@@ -93,8 +92,6 @@ pre-everything::
@${ECHO_MSG} ""
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
's|-lpthread|${PTHREAD_LIBS}|g'
@${FIND} ${WRKSRC} -name "*.cpp" | ${XARGS} ${REINPLACE_CMD} -e \
diff --git a/www/gtkhtml/Makefile b/www/gtkhtml/Makefile
index 4fa8c5674f3..ce9599e785f 100644
--- a/www/gtkhtml/Makefile
+++ b/www/gtkhtml/Makefile
@@ -36,10 +36,6 @@ VERSION= ${PORTNAME}-${PORTVERSION}
LIB_DEPENDS+= soup.6:${PORTSDIR}/devel/soup
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
post-configure:
@${SED} -e 's|%%PREFIX%%|${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g ; \
diff --git a/www/libgtkhtml/Makefile b/www/libgtkhtml/Makefile
index eb455c33c42..7473e02b156 100644
--- a/www/libgtkhtml/Makefile
+++ b/www/libgtkhtml/Makefile
@@ -26,8 +26,4 @@ USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>