aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2009-09-04 14:33:13 +0800
committeritetcu <itetcu@FreeBSD.org>2009-09-04 14:33:13 +0800
commitae942be4aa847f52854c3207fb2396056e3dcab3 (patch)
treeed1196c39ef500a51ccb3245d2ae16bccf897227 /www
parent4785eee4af0e3684a4df31428c3521d658471588 (diff)
downloadfreebsd-ports-graphics-ae942be4aa847f52854c3207fb2396056e3dcab3.tar.gz
freebsd-ports-graphics-ae942be4aa847f52854c3207fb2396056e3dcab3.tar.zst
freebsd-ports-graphics-ae942be4aa847f52854c3207fb2396056e3dcab3.zip
Sync with www/opera current version 10.00
PR: 138472 Submitted by: maintainer
Diffstat (limited to 'www')
-rw-r--r--www/opera-linuxplugins/Makefile42
-rw-r--r--www/opera-linuxplugins/distinfo6
2 files changed, 25 insertions, 23 deletions
diff --git a/www/opera-linuxplugins/Makefile b/www/opera-linuxplugins/Makefile
index b70d91f8739..58b1f1853f8 100644
--- a/www/opera-linuxplugins/Makefile
+++ b/www/opera-linuxplugins/Makefile
@@ -8,21 +8,21 @@
PORTNAME= opera
PORTVERSION= ${OPERA_VER}.${OPERA_DATE}
CATEGORIES= www linux
-MASTER_SITES= ftp://opera.inode.at/linux/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/i386/shared/ \
- http://gd.tuwien.ac.at/infosys/browsers/opera/linux/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/i386/shared/ \
- http://ftp.ucr.ac.cr/WWW/opera/linux/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/i386/shared/ \
- http://www.microrpm.ca/pub/opera/linux/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/i386/shared/ \
- http://www.opera.mirroarrr.de/linux/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/i386/shared/ \
- http://opera.eurenet.net/linux/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/i386/shared/ \
- ftp://opera.ftp.fu-berlin.de/linux/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/i386/shared/ \
- http://ftp.ntua.gr/pub/www/Opera/linux/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/i386/shared/ \
- ftp://ftp.wayne.edu/opera/linux/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/i386/shared/ \
- http://mirrors.dedipower.com/opera/linux/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/i386/shared/ \
- ftp://ftp.mirror.ac.uk/sites/ftp.opera.com/linux/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/i386/shared/ \
- http://opera.nedmirror.nl/linux/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/i386/shared/ \
- ftp://ftp.tiscali.nl/pub/mirrors/opera/linux/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/i386/shared/ \
- ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/www/opera/linux/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/i386/shared/&,} \
- ftp://ftp.opera.com/pub/opera/linux/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/i386/shared/
+MASTER_SITES= ftp://opera.inode.at/${MASTER_SITES_VER_PATH} \
+ http://gd.tuwien.ac.at/infosys/browsers/opera/${MASTER_SITES_VER_PATH} \
+ http://ftp.ucr.ac.cr/WWW/opera/${MASTER_SITES_VER_PATH} \
+ http://www.microrpm.ca/pub/opera/${MASTER_SITES_VER_PATH} \
+ http://www.opera.mirroarrr.de/${MASTER_SITES_VER_PATH} \
+ http://opera.eurenet.net/${MASTER_SITES_VER_PATH} \
+ ftp://opera.ftp.fu-berlin.de/${MASTER_SITES_VER_PATH} \
+ http://ftp.ntua.gr/pub/www/Opera/${MASTER_SITES_VER_PATH} \
+ ftp://ftp.wayne.edu/opera/${MASTER_SITES_VER_PATH} \
+ http://mirrors.dedipower.com/opera/${MASTER_SITES_VER_PATH} \
+ ftp://ftp.mirror.ac.uk/sites/ftp.opera.com/${MASTER_SITES_VER_PATH} \
+ http://opera.nedmirror.nl/${MASTER_SITES_VER_PATH} \
+ ftp://ftp.tiscali.nl/pub/mirrors/opera/${MASTER_SITES_VER_PATH} \
+ ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/www/opera/${MASTER_SITES_VER_PATH}&,} \
+ ftp://ftp.opera.com/pub/opera/${MASTER_SITES_VER_PATH}
PKGNAMESUFFIX= -linuxplugins
DISTNAME= ${PORTNAME}-${OPERA_VER}.gcc3-shared-qt3.i386
@@ -31,23 +31,25 @@ COMMENT= Linux plugin support for the native Opera browser
RUN_DEPENDS= ${PREFIX}/share/opera/bin/operapluginwrapper:${PORTSDIR}/www/opera
-OPERA_VER= 9.61
+OPERA_VER= 10.00
OPERA_MINVER=
OPERA_REL= final
-OPERA_DATE= 20081017
-OPERA_BUILD= 2456
+OPERA_DATE= 20090830
+OPERA_BUILD= 4585
+MASTER_SITES_VER_PATH= linux/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/i386/shared/
+WRKSRC= ${WRKDIR}/${PORTNAME}-${OPERA_VER}-${OPERA_BUILD}.gcc3-shared-qt3.i386
USE_BZIP2= yes
USE_LINUX= yes
USE_LINUX_APPS= xorglibs
+
ONLY_FOR_ARCHS= i386 amd64
-WRKSRC= ${WRKDIR}/${PORTNAME}-${OPERA_VER}-${OPERA_BUILD}.gcc3-shared-qt3.i386
NO_BUILD= yes
PLIST_FILES= share/opera/bin/operapluginwrapper.linux
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/usr/lib/opera/${OPERA_VER}/operapluginwrapper ${PREFIX}/share/opera/bin/operapluginwrapper.linux
+ ${INSTALL_PROGRAM} ${WRKSRC}/usr/lib/opera/operapluginwrapper ${PREFIX}/share/opera/bin/operapluginwrapper.linux
.include <bsd.port.mk>
diff --git a/www/opera-linuxplugins/distinfo b/www/opera-linuxplugins/distinfo
index dec2d6fa373..74e0383fde7 100644
--- a/www/opera-linuxplugins/distinfo
+++ b/www/opera-linuxplugins/distinfo
@@ -1,3 +1,3 @@
-MD5 (opera-9.61.gcc3-shared-qt3.i386.tar.bz2) = 12cb3ce5ad031c38ede4385e1a298d89
-SHA256 (opera-9.61.gcc3-shared-qt3.i386.tar.bz2) = 15163faab9d9eb9c5000c944f5d81a003ec7a43927f2d02c7f145fadd870a9e6
-SIZE (opera-9.61.gcc3-shared-qt3.i386.tar.bz2) = 7301358
+MD5 (opera-10.00.gcc3-shared-qt3.i386.tar.bz2) = 44d69eb6e560817c6f43f1088c177410
+SHA256 (opera-10.00.gcc3-shared-qt3.i386.tar.bz2) = 3c8903b70eaa0814be32c53f487f608cc188921a53ce79891d0d54defd856e3b
+SIZE (opera-10.00.gcc3-shared-qt3.i386.tar.bz2) = 8560423