aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>1999-11-08 06:25:40 +0800
committerdirk <dirk@FreeBSD.org>1999-11-08 06:25:40 +0800
commitb69114316e53cc13ea8e80defd247b8bff50965b (patch)
treef3ab188fc13b5209e082e7e5e7906353adac4b24 /www
parentdcd00432e99667e00b21b120336004cde4965e57 (diff)
downloadfreebsd-ports-graphics-b69114316e53cc13ea8e80defd247b8bff50965b.tar.gz
freebsd-ports-graphics-b69114316e53cc13ea8e80defd247b8bff50965b.tar.zst
freebsd-ports-graphics-b69114316e53cc13ea8e80defd247b8bff50965b.zip
Change dependencies from static to shared openssl libraries,
because openssl also builds shared libraries, now.
Diffstat (limited to 'www')
-rw-r--r--www/apache13-modssl/Makefile4
-rw-r--r--www/apache13-ssl/Makefile4
-rw-r--r--www/lynx-ssl/Makefile2
-rw-r--r--www/mod_php3/scripts/configure.php4
-rw-r--r--www/mod_php4/scripts/configure.php4
-rw-r--r--www/mod_php5/scripts/configure.php4
6 files changed, 12 insertions, 10 deletions
diff --git a/www/apache13-modssl/Makefile b/www/apache13-modssl/Makefile
index cd8f5d21a46..100d35bf3b7 100644
--- a/www/apache13-modssl/Makefile
+++ b/www/apache13-modssl/Makefile
@@ -43,9 +43,9 @@ MAINTAINER= rse@engelschall.com
BUILD_DEPENDS= openssl:${PORTSDIR}/security/openssl \
mm-config:${PORTSDIR}/devel/mm \
- ${PREFIX}/lib/libssl.a:${PORTSDIR}/security/openssl \
- ${PREFIX}/lib/libcrypto.a:${PORTSDIR}/security/openssl \
${PREFIX}/lib/libmm.a:${PORTSDIR}/devel/mm
+LIB_DEPENDS= crypto.1:${PORTSDIR}/security/openssl \
+ ssl.1:${PORTSDIR}/security/openssl
RUN_DEPENDS= openssl:${PORTSDIR}/security/openssl
VERSION_APACHE= 1.3.9
diff --git a/www/apache13-ssl/Makefile b/www/apache13-ssl/Makefile
index ad3570c8126..019d7fbfc44 100644
--- a/www/apache13-ssl/Makefile
+++ b/www/apache13-ssl/Makefile
@@ -39,8 +39,8 @@ MAINTAINER= adam@algroup.co.uk
BUILD_DEPENDS= openssl:${PORTSDIR}/security/openssl
-BUILD_DEPENDS= ${PREFIX}/lib/libcrypto.a:${PORTSDIR}/security/openssl \
- ${PREFIX}/lib/libssl.a:${PORTSDIR}/security/openssl
+LIB_DEPENDS= crypto.1:${PORTSDIR}/security/openssl \
+ ssl.1:${PORTSDIR}/security/openssl
RUN_DEPENDS= openssl:${PORTSDIR}/security/openssl
HAS_CONFIGURE= yes
diff --git a/www/lynx-ssl/Makefile b/www/lynx-ssl/Makefile
index 08f6a0b82a0..418366d58f1 100644
--- a/www/lynx-ssl/Makefile
+++ b/www/lynx-ssl/Makefile
@@ -23,6 +23,8 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= sec@42.org
BUILD_DEPENDS= openssl:${PORTSDIR}/security/openssl
+LIB_DEPENDS= crypto.1:${PORTSDIR}/security/openssl \
+ ssl.1:${PORTSDIR}/security/openssl
RESTRICTED= "Contains cryptography"
diff --git a/www/mod_php3/scripts/configure.php b/www/mod_php3/scripts/configure.php
index afabc2dd562..40f57f46ee4 100644
--- a/www/mod_php3/scripts/configure.php
+++ b/www/mod_php3/scripts/configure.php
@@ -132,9 +132,9 @@ DISTFILES+= mod_ssl-\${VERSION_MODSSL}-\${VERSION_APACHE}\${EXTRACT_SUFX}
BUILD_DEPENDS+= openssl:\${PORTSDIR}/security/openssl \\
mm-config:\${PORTSDIR}/devel/mm \\
- \${PREFIX}/lib/libssl.a:\${PORTSDIR}/security/openssl \\
- \${PREFIX}/lib/libcrypto.a:\${PORTSDIR}/security/openssl \\
\${PREFIX}/lib/libmm.a:\${PORTSDIR}/devel/mm
+LIB_DEPENDS+= crypto.1:\${PORTSDIR}/security/openssl \\
+ ssl.1:\${PORTSDIR}/security/openssl
RUN_DEPENDS+= openssl:\${PORTSDIR}/security/openssl
VERSION_MODSSL= 2.4.8
diff --git a/www/mod_php4/scripts/configure.php b/www/mod_php4/scripts/configure.php
index 7f227ba462f..76c467e782f 100644
--- a/www/mod_php4/scripts/configure.php
+++ b/www/mod_php4/scripts/configure.php
@@ -144,9 +144,9 @@ DISTFILES+= mod_ssl-\${VERSION_MODSSL}-\${VERSION_APACHE}\${EXTRACT_SUFX}
BUILD_DEPENDS+= openssl:\${PORTSDIR}/security/openssl \\
mm-config:\${PORTSDIR}/devel/mm \\
- \${PREFIX}/lib/libssl.a:\${PORTSDIR}/security/openssl \\
- \${PREFIX}/lib/libcrypto.a:\${PORTSDIR}/security/openssl \\
\${PREFIX}/lib/libmm.a:\${PORTSDIR}/devel/mm
+LIB_DEPENDS+= crypto.1:\${PORTSDIR}/security/openssl \\
+ ssl.1:\${PORTSDIR}/security/openssl
RUN_DEPENDS+= openssl:\${PORTSDIR}/security/openssl
VERSION_MODSSL= 2.4.8
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index 7f227ba462f..76c467e782f 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -144,9 +144,9 @@ DISTFILES+= mod_ssl-\${VERSION_MODSSL}-\${VERSION_APACHE}\${EXTRACT_SUFX}
BUILD_DEPENDS+= openssl:\${PORTSDIR}/security/openssl \\
mm-config:\${PORTSDIR}/devel/mm \\
- \${PREFIX}/lib/libssl.a:\${PORTSDIR}/security/openssl \\
- \${PREFIX}/lib/libcrypto.a:\${PORTSDIR}/security/openssl \\
\${PREFIX}/lib/libmm.a:\${PORTSDIR}/devel/mm
+LIB_DEPENDS+= crypto.1:\${PORTSDIR}/security/openssl \\
+ ssl.1:\${PORTSDIR}/security/openssl
RUN_DEPENDS+= openssl:\${PORTSDIR}/security/openssl
VERSION_MODSSL= 2.4.8