aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2016-10-19 04:53:13 +0800
committerfeld <feld@FreeBSD.org>2016-10-19 04:53:13 +0800
commitc2d6f88bd13459104f37015cded79eaa06303eb7 (patch)
tree52689a847beab319c2fd4919e91c7e911b612514 /www
parent1129cdc06520d3cfe4225c038bec0c9bea3b0cdd (diff)
downloadfreebsd-ports-graphics-c2d6f88bd13459104f37015cded79eaa06303eb7.tar.gz
freebsd-ports-graphics-c2d6f88bd13459104f37015cded79eaa06303eb7.tar.zst
freebsd-ports-graphics-c2d6f88bd13459104f37015cded79eaa06303eb7.zip
Identity management for Flask.
WWW: http://packages.python.org/Flask-Principal/ PR: 213326 Submitted by: Kyle Evans <bsdports@kyle-evans.net>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-flask-principal/Makefile21
-rw-r--r--www/py-flask-principal/distinfo3
-rw-r--r--www/py-flask-principal/pkg-descr3
4 files changed, 28 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 658ae562152..d8ab211e351 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1615,6 +1615,7 @@
SUBDIR += py-flask-flatpages
SUBDIR += py-flask-login
SUBDIR += py-flask-oauthlib
+ SUBDIR += py-flask-principal
SUBDIR += py-flask-restful
SUBDIR += py-flask-restplus
SUBDIR += py-flask-restplus08
diff --git a/www/py-flask-principal/Makefile b/www/py-flask-principal/Makefile
new file mode 100644
index 00000000000..7f41c8e26bd
--- /dev/null
+++ b/www/py-flask-principal/Makefile
@@ -0,0 +1,21 @@
+# Created by: Kyle Evans <bsdports@kyle-evans.net>
+# $FreeBSD$
+
+PORTNAME= Flask-Principal
+PORTVERSION= 0.4.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= bsdports@kyle-evans.net
+COMMENT= Identity management for flask
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask>=0:www/py-flask \
+ ${PYTHON_PKGNAMEPREFIX}blinker>=0:devel/py-blinker
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/www/py-flask-principal/distinfo b/www/py-flask-principal/distinfo
new file mode 100644
index 00000000000..152ab9dab61
--- /dev/null
+++ b/www/py-flask-principal/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475951496
+SHA256 (Flask-Principal-0.4.0.tar.gz) = f5d6134b5caebfdbb86f32d56d18ee44b080876a27269560a96ea35f75c99453
+SIZE (Flask-Principal-0.4.0.tar.gz) = 5452
diff --git a/www/py-flask-principal/pkg-descr b/www/py-flask-principal/pkg-descr
new file mode 100644
index 00000000000..d9067d8fd46
--- /dev/null
+++ b/www/py-flask-principal/pkg-descr
@@ -0,0 +1,3 @@
+Identity management for Flask.
+
+WWW: http://packages.python.org/Flask-Principal/