aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbrix <brix@FreeBSD.org>2008-07-05 17:24:34 +0800
committerbrix <brix@FreeBSD.org>2008-07-05 17:24:34 +0800
commitd40a478db5dde43293c569028b380ab82c3dd205 (patch)
tree61f511d710826837dcc36dbad656bd072a937fa1 /www
parente9870e69443b4640f47c057b7d96999badfb5bba (diff)
downloadfreebsd-ports-graphics-d40a478db5dde43293c569028b380ab82c3dd205.tar.gz
freebsd-ports-graphics-d40a478db5dde43293c569028b380ab82c3dd205.tar.zst
freebsd-ports-graphics-d40a478db5dde43293c569028b380ab82c3dd205.zip
CGI search application built on Xapian
This package contains two index building utilities (omindex and scriptindex) and a CGI search application (omega). These use the Xapian search library to provide a search over a collection of documents. Approved by: erwin (mentor)
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/xapian-omega/Makefile66
-rw-r--r--www/xapian-omega/distinfo3
-rw-r--r--www/xapian-omega/files/patch-runfilter.cc10
-rw-r--r--www/xapian-omega/pkg-descr6
-rw-r--r--www/xapian-omega/pkg-plist11
-rw-r--r--www/xapian-omega10/Makefile66
-rw-r--r--www/xapian-omega10/distinfo3
-rw-r--r--www/xapian-omega10/files/patch-runfilter.cc10
-rw-r--r--www/xapian-omega10/pkg-descr6
-rw-r--r--www/xapian-omega10/pkg-plist11
11 files changed, 193 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b516bf1bd79..3d6ea799b07 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1436,6 +1436,7 @@
SUBDIR += wwwoffle
SUBDIR += wwwstat
SUBDIR += wyvern
+ SUBDIR += xapian-omega
SUBDIR += xaraya
SUBDIR += xcache
SUBDIR += xfce4-smartbookmark-plugin
diff --git a/www/xapian-omega/Makefile b/www/xapian-omega/Makefile
new file mode 100644
index 00000000000..a5145773a8d
--- /dev/null
+++ b/www/xapian-omega/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: xapian-omega
+# Date created: 05 Jul 2008
+# Whom: Henrik Brix Andersen <brix@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= xapian-omega
+PORTVERSION= 1.0.6
+CATEGORIES= www
+MASTER_SITES= http://oligarchy.co.uk/xapian/${PORTVERSION}/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= brix
+
+MAINTAINER= brix@FreeBSD.org
+COMMENT= CGI search application built on Xapian
+
+LIB_DEPENDS= xapian.19:${PORTSDIR}/databases/xapian-core
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_PERL5_RUN= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= omindex.1 scriptindex.1
+
+MORE_PORTDOCS= AUTHORS ChangeLog NEWS README TODO
+PORTDOCS= cgiparams.html omegascript.html overview.html \
+ quickstart.html scriptindex.html termprefixes.html \
+ ${MORE_PORTDOCS}
+PORTEXAMPLES= omega.conf
+
+OPTIONS= ICONV "Enable iconv character set conversion support" On
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ICONV)
+USE_ICONV= yes
+CONFIGURE_ARGS+= --with-iconv
+.else
+CONFIGURE_ARGS+= --without-iconv
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|^\(dist_sysconf_DATA\ =\ omega\.conf\)|#\1|' \
+ -e "s|^\(pkglibbindir\)\ =.*/bin|\1\ =\ \$$(prefix)/${WWWDIR_REL}/cgi-bin|" \
+ ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} \
+ -e 's|^\(SUBDIRS\ =\ \.\) docs|\1|' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${MORE_PORTDOCS:S@^@${WRKSRC}/@} ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S@^@${WRKSRC}/@} ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/xapian-omega/distinfo b/www/xapian-omega/distinfo
new file mode 100644
index 00000000000..1b4d599bb19
--- /dev/null
+++ b/www/xapian-omega/distinfo
@@ -0,0 +1,3 @@
+MD5 (xapian-omega-1.0.6.tar.gz) = 7746c428d7081e637aecbeef23432cda
+SHA256 (xapian-omega-1.0.6.tar.gz) = fd316c38c46f621d6fe5f26f316abe2dda2e8263b588b41c41f4b8f86918b850
+SIZE (xapian-omega-1.0.6.tar.gz) = 490233
diff --git a/www/xapian-omega/files/patch-runfilter.cc b/www/xapian-omega/files/patch-runfilter.cc
new file mode 100644
index 00000000000..679282f33bd
--- /dev/null
+++ b/www/xapian-omega/files/patch-runfilter.cc
@@ -0,0 +1,10 @@
+--- runfilter.cc.orig 2008-07-03 21:16:54.000000000 +0200
++++ runfilter.cc 2008-07-03 21:18:48.000000000 +0200
+@@ -25,6 +25,7 @@
+ #include "safeerrno.h"
+ #include <sys/types.h>
+ #include <stdio.h>
++#include <signal.h>
+ #include "safefcntl.h"
+
+ #ifdef HAVE_SYS_TIME_H
diff --git a/www/xapian-omega/pkg-descr b/www/xapian-omega/pkg-descr
new file mode 100644
index 00000000000..e27c624eb37
--- /dev/null
+++ b/www/xapian-omega/pkg-descr
@@ -0,0 +1,6 @@
+This package contains two index building utilities (omindex and
+scriptindex) and a CGI search application (omega). These use the
+Xapian search library to provide a search over a collection of
+documents.
+
+WWW: http://www.xapian.org/
diff --git a/www/xapian-omega/pkg-plist b/www/xapian-omega/pkg-plist
new file mode 100644
index 00000000000..b05808b0fd9
--- /dev/null
+++ b/www/xapian-omega/pkg-plist
@@ -0,0 +1,11 @@
+bin/dbi2omega
+bin/htdig2omega
+bin/mbox2omega
+bin/omindex
+bin/scriptindex
+www/xapian-omega/cgi-bin/omega
+share/omega/htdig2omega.script
+share/omega/mbox2omega.script
+@dirrm www/xapian-omega/cgi-bin
+@dirrm www/xapian-omega
+@dirrm share/omega
diff --git a/www/xapian-omega10/Makefile b/www/xapian-omega10/Makefile
new file mode 100644
index 00000000000..a5145773a8d
--- /dev/null
+++ b/www/xapian-omega10/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: xapian-omega
+# Date created: 05 Jul 2008
+# Whom: Henrik Brix Andersen <brix@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= xapian-omega
+PORTVERSION= 1.0.6
+CATEGORIES= www
+MASTER_SITES= http://oligarchy.co.uk/xapian/${PORTVERSION}/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= brix
+
+MAINTAINER= brix@FreeBSD.org
+COMMENT= CGI search application built on Xapian
+
+LIB_DEPENDS= xapian.19:${PORTSDIR}/databases/xapian-core
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_PERL5_RUN= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= omindex.1 scriptindex.1
+
+MORE_PORTDOCS= AUTHORS ChangeLog NEWS README TODO
+PORTDOCS= cgiparams.html omegascript.html overview.html \
+ quickstart.html scriptindex.html termprefixes.html \
+ ${MORE_PORTDOCS}
+PORTEXAMPLES= omega.conf
+
+OPTIONS= ICONV "Enable iconv character set conversion support" On
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ICONV)
+USE_ICONV= yes
+CONFIGURE_ARGS+= --with-iconv
+.else
+CONFIGURE_ARGS+= --without-iconv
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|^\(dist_sysconf_DATA\ =\ omega\.conf\)|#\1|' \
+ -e "s|^\(pkglibbindir\)\ =.*/bin|\1\ =\ \$$(prefix)/${WWWDIR_REL}/cgi-bin|" \
+ ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} \
+ -e 's|^\(SUBDIRS\ =\ \.\) docs|\1|' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${MORE_PORTDOCS:S@^@${WRKSRC}/@} ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S@^@${WRKSRC}/@} ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/xapian-omega10/distinfo b/www/xapian-omega10/distinfo
new file mode 100644
index 00000000000..1b4d599bb19
--- /dev/null
+++ b/www/xapian-omega10/distinfo
@@ -0,0 +1,3 @@
+MD5 (xapian-omega-1.0.6.tar.gz) = 7746c428d7081e637aecbeef23432cda
+SHA256 (xapian-omega-1.0.6.tar.gz) = fd316c38c46f621d6fe5f26f316abe2dda2e8263b588b41c41f4b8f86918b850
+SIZE (xapian-omega-1.0.6.tar.gz) = 490233
diff --git a/www/xapian-omega10/files/patch-runfilter.cc b/www/xapian-omega10/files/patch-runfilter.cc
new file mode 100644
index 00000000000..679282f33bd
--- /dev/null
+++ b/www/xapian-omega10/files/patch-runfilter.cc
@@ -0,0 +1,10 @@
+--- runfilter.cc.orig 2008-07-03 21:16:54.000000000 +0200
++++ runfilter.cc 2008-07-03 21:18:48.000000000 +0200
+@@ -25,6 +25,7 @@
+ #include "safeerrno.h"
+ #include <sys/types.h>
+ #include <stdio.h>
++#include <signal.h>
+ #include "safefcntl.h"
+
+ #ifdef HAVE_SYS_TIME_H
diff --git a/www/xapian-omega10/pkg-descr b/www/xapian-omega10/pkg-descr
new file mode 100644
index 00000000000..e27c624eb37
--- /dev/null
+++ b/www/xapian-omega10/pkg-descr
@@ -0,0 +1,6 @@
+This package contains two index building utilities (omindex and
+scriptindex) and a CGI search application (omega). These use the
+Xapian search library to provide a search over a collection of
+documents.
+
+WWW: http://www.xapian.org/
diff --git a/www/xapian-omega10/pkg-plist b/www/xapian-omega10/pkg-plist
new file mode 100644
index 00000000000..b05808b0fd9
--- /dev/null
+++ b/www/xapian-omega10/pkg-plist
@@ -0,0 +1,11 @@
+bin/dbi2omega
+bin/htdig2omega
+bin/mbox2omega
+bin/omindex
+bin/scriptindex
+www/xapian-omega/cgi-bin/omega
+share/omega/htdig2omega.script
+share/omega/mbox2omega.script
+@dirrm www/xapian-omega/cgi-bin
+@dirrm www/xapian-omega
+@dirrm share/omega