aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-02-19 23:33:51 +0800
committerwxs <wxs@FreeBSD.org>2009-02-19 23:33:51 +0800
commitd729bc78f155c093ef1d23f994b82ac2b83c5ec6 (patch)
tree452020e84ca836a9484be58573b10d37bb70d1e5 /www
parent0ed7a8a645a7d954279bb8b57ec11c5772ffe5ed (diff)
downloadfreebsd-ports-graphics-d729bc78f155c093ef1d23f994b82ac2b83c5ec6.tar.gz
freebsd-ports-graphics-d729bc78f155c093ef1d23f994b82ac2b83c5ec6.tar.zst
freebsd-ports-graphics-d729bc78f155c093ef1d23f994b82ac2b83c5ec6.zip
- Update to 0.06
- Provide rt38 compatability (default) - Optionally install for rt36 - Split pkg-plist into pkg-plist.rt36 and pkg-plist.rt38 PR: ports/131698 Submitted by: Matthew Seaman <m.seaman@infracaninophile.co.uk> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/p5-RTx-Calendar/Makefile36
-rw-r--r--www/p5-RTx-Calendar/distinfo6
-rw-r--r--www/p5-RTx-Calendar/pkg-plist.rt36 (renamed from www/p5-RTx-Calendar/pkg-plist)0
-rw-r--r--www/p5-RTx-Calendar/pkg-plist.rt3848
4 files changed, 78 insertions, 12 deletions
diff --git a/www/p5-RTx-Calendar/Makefile b/www/p5-RTx-Calendar/Makefile
index 42699811e6e..0c15bf36be6 100644
--- a/www/p5-RTx-Calendar/Makefile
+++ b/www/p5-RTx-Calendar/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= RTx-Calendar
-PORTVERSION= 0.05
+PORTVERSION= 0.06
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,27 +14,45 @@ PKGNAMEPREFIX= p5-
MAINTAINER= m.seaman@infracaninophile.co.uk
COMMENT= Calendar extension module for the RT ticketing system
-BUILD_DEPENDS= ${LOCALBASE}/${RTHOME}/bin/rt:${PORTSDIR}/www/rt36 \
- ${SITE_PERL}/Date/ICal.pm:${PORTSDIR}/devel/p5-Date-ICal \
+BUILD_DEPENDS= ${SITE_PERL}/Date/ICal.pm:${PORTSDIR}/devel/p5-Date-ICal \
${SITE_PERL}/Data/ICal.pm:${PORTSDIR}/deskutils/p5-Data-ICal \
${SITE_PERL}/DateTime/Set.pm:${PORTSDIR}/devel/p5-DateTime-Set
RUN_DEPENDS= ${BUILD_DEPENDS}
-RTHOME?= rt3
-PLIST_SUB+= RTHOME=${RTHOME}
+OPTIONS= RT36 "Install for rt-3.6.x (default rt-3.8.x)" off
PERL_CONFIGURE= yes
-CONFIGURE_ENV+= RTHOME=${PREFIX}/${RTHOME}
-MAN3PREFIX= ${PREFIX}/${RTHOME}/local
MAN3= RTx::Calendar.3
+PLIST_SUB+= RTHOME=${RTHOME}
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_RT36)
+
+RTHOME?= rt3
+RT_PM_DIR= ${LOCALBASE}/${RTHOME}/lib
+BUILD_DEPENDS+= ${RT_PM_DIR}/RT.pm:${PORTSDIR}/www/rt36
+PLIST= ${PKGDIR}/pkg-plist.rt36
+MAN3PREFIX= ${PREFIX}/${RTHOME}/local
+
+.else
+
+RTHOME?= share/rt38
+RT_PM_DIR= ${SITE_PERL}
+BUILD_DEPENDS+= ${RT_PM_DIR}/RT.pm:${PORTSDIR}/www/rt38
+PLIST= ${PKGDIR}/pkg-plist.rt38
+MAN3PREFIX= ${PREFIX}
+
+.endif
+
# Don't use normal CONFIGURE_ARGS. Disable doc_?????_indstall targets to
# suppress installing perllocal.pod. This duplicates code from bsd.perl.mk
# rather undesirably.
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
- ${SETENV} ${CONFIGURE_ENV} ${PERL5} ./${CONFIGURE_SCRIPT} && \
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${RT_PM_DIR} ./${CONFIGURE_SCRIPT} && \
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/p5-RTx-Calendar/distinfo b/www/p5-RTx-Calendar/distinfo
index 64135f407d2..65b2d0ecd11 100644
--- a/www/p5-RTx-Calendar/distinfo
+++ b/www/p5-RTx-Calendar/distinfo
@@ -1,3 +1,3 @@
-MD5 (RTx-Calendar-0.05.tar.gz) = 53a305c3a5929d77276f98c255186591
-SHA256 (RTx-Calendar-0.05.tar.gz) = f9311929943f35bd631df442da3e428e8524b8236c449d0ccd9266e3aa0d9721
-SIZE (RTx-Calendar-0.05.tar.gz) = 27640
+MD5 (RTx-Calendar-0.06.tar.gz) = f24991d0ed92ab0ae0ecdf348c481d57
+SHA256 (RTx-Calendar-0.06.tar.gz) = 29375bb1fd6a9d96cbf1c7aaa97c731a20e95beb19ef1f9aaec3d25f91fb4b29
+SIZE (RTx-Calendar-0.06.tar.gz) = 27974
diff --git a/www/p5-RTx-Calendar/pkg-plist b/www/p5-RTx-Calendar/pkg-plist.rt36
index e642f30edaa..e642f30edaa 100644
--- a/www/p5-RTx-Calendar/pkg-plist
+++ b/www/p5-RTx-Calendar/pkg-plist.rt36
diff --git a/www/p5-RTx-Calendar/pkg-plist.rt38 b/www/p5-RTx-Calendar/pkg-plist.rt38
new file mode 100644
index 00000000000..102b2c093f9
--- /dev/null
+++ b/www/p5-RTx-Calendar/pkg-plist.rt38
@@ -0,0 +1,48 @@
+%%RTHOME%%/plugins/RTx-Calendar/lib/RTx/Calendar.pm
+%%RTHOME%%/plugins/RTx-Calendar/html/Search/Calendar.html
+%%RTHOME%%/plugins/RTx-Calendar/html/Prefs/Elements/CalendarFeed
+%%RTHOME%%/plugins/RTx-Calendar/html/Prefs/Calendar.html
+%%RTHOME%%/plugins/RTx-Calendar/html/NoAuth/images/updated.png
+%%RTHOME%%/plugins/RTx-Calendar/html/NoAuth/images/starts_due.png
+%%RTHOME%%/plugins/RTx-Calendar/html/NoAuth/images/starts.png
+%%RTHOME%%/plugins/RTx-Calendar/html/NoAuth/images/started.png
+%%RTHOME%%/plugins/RTx-Calendar/html/NoAuth/images/resolved.png
+%%RTHOME%%/plugins/RTx-Calendar/html/NoAuth/images/reminder.png
+%%RTHOME%%/plugins/RTx-Calendar/html/NoAuth/images/due.png
+%%RTHOME%%/plugins/RTx-Calendar/html/NoAuth/images/created_due.png
+%%RTHOME%%/plugins/RTx-Calendar/html/NoAuth/images/created.png
+%%RTHOME%%/plugins/RTx-Calendar/html/NoAuth/css/calendar.css
+%%RTHOME%%/plugins/RTx-Calendar/html/NoAuth/Calendar/dhandler
+%%RTHOME%%/plugins/RTx-Calendar/html/Elements/MyCalendar
+%%RTHOME%%/plugins/RTx-Calendar/html/Elements/CalendarEvent
+%%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/User/Elements/Tabs/Default
+%%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/Ticket/Elements/Tabs/Default
+%%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/Elements/Header/Head
+man/auto/RTx/Calendar/.packlist
+lib/RTx/Calendar.pm
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/lib/RTx
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/lib
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html/Search
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html/Prefs/Elements
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html/Prefs
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html/NoAuth/images
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html/NoAuth/css
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html/NoAuth/Calendar
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html/NoAuth
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html/Elements
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/User/Elements/Tabs
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/User/Elements
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/User
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/Ticket/Elements/Tabs
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/Ticket/Elements
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/Ticket
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/Elements/Header
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/Elements
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks
+@dirrm %%RTHOME%%/plugins/RTx-Calendar/html
+@dirrm %%RTHOME%%/plugins/RTx-Calendar
+@dirrm man/auto/RTx/Calendar
+@dirrmtry man/auto/RTx
+@dirrmtry man/auto
+@dirrmtry lib/RTx