aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-12-13 18:01:29 +0800
committerrafan <rafan@FreeBSD.org>2007-12-13 18:01:29 +0800
commitdf8096ea0bb012744c5a0f86b99a49f329728999 (patch)
treed2b20828985e44eb7fda79a69440ec31e470a290 /www
parent83944eac146bdb53d588e7473fe23503968f5731 (diff)
downloadfreebsd-ports-graphics-df8096ea0bb012744c5a0f86b99a49f329728999.tar.gz
freebsd-ports-graphics-df8096ea0bb012744c5a0f86b99a49f329728999.tar.zst
freebsd-ports-graphics-df8096ea0bb012744c5a0f86b99a49f329728999.zip
khtml2png is a command line program to create screenshots of webpages. It
uses libkhtml (the library that is used in the KDE webbrowser Konqueror) and Qt to do graphic conversion. WWW: http://khtml2png.sourceforge.net/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/khtml2png/Makefile37
-rw-r--r--www/khtml2png/distinfo3
-rw-r--r--www/khtml2png/pkg-descr5
-rw-r--r--www/khtml2png/pkg-message2
5 files changed, 48 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e295940e7c5..2f7e8c6c141 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -258,6 +258,7 @@
SUBDIR += kazehakase
SUBDIR += kdedict
SUBDIR += kdewebdev
+ SUBDIR += khtml2png
SUBDIR += knowledgekit
SUBDIR += kompozer
SUBDIR += larbin
diff --git a/www/khtml2png/Makefile b/www/khtml2png/Makefile
new file mode 100644
index 00000000000..db04ccc9c2f
--- /dev/null
+++ b/www/khtml2png/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: www/khtml2png
+# Date created: Nov 27 2007
+# Whom: Rong-En Fan <rafan@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= khtml2png
+DISTVERSION= 2.6.7a
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= rafan@FreeBSD.org
+COMMENT= Command line program to create screenshots of webpages
+
+BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
+
+USE_KDELIBS_VER= 3
+
+CMAKE?= ${LOCALBASE}/bin/cmake
+
+CMAKE_ARGS= -DCMAKE_BUILD_TYPE:STRING=Release \
+ -DCMAKE_C_COMPILER:STRING='${CC}' \
+ -DCMAKE_CXX_COMPILER:STRING=${CXX} \
+ -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}" \
+ -DCMAKE_INSTALL_PREFIX=${PREFIX}
+
+PLIST_FILES= bin/khtml2png2
+
+.include <bsd.port.pre.mk>
+
+do-configure:
+ @cd ${WRKSRC} && ${CMAKE} ${CMAKE_ARGS} -G KDevelop3 ${WRKSRC} && \
+ ${CMAKE} ${CMAKE_ARGS} ${WRKSRC}
+
+.include <bsd.port.post.mk>
diff --git a/www/khtml2png/distinfo b/www/khtml2png/distinfo
new file mode 100644
index 00000000000..e8562d1482b
--- /dev/null
+++ b/www/khtml2png/distinfo
@@ -0,0 +1,3 @@
+MD5 (khtml2png-2.6.7a.tar.gz) = 43a2514147b33f84ad85d4d841184ca3
+SHA256 (khtml2png-2.6.7a.tar.gz) = 4709800a22f4c1c02264b36c492ce6be256a75bc2fae1175faf69b46b4b73aaa
+SIZE (khtml2png-2.6.7a.tar.gz) = 7727
diff --git a/www/khtml2png/pkg-descr b/www/khtml2png/pkg-descr
new file mode 100644
index 00000000000..dd99fc54bc0
--- /dev/null
+++ b/www/khtml2png/pkg-descr
@@ -0,0 +1,5 @@
+khtml2png is a command line program to create screenshots of webpages. It
+uses libkhtml (the library that is used in the KDE webbrowser Konqueror) and
+Qt to do graphic conversion.
+
+WWW: http://khtml2png.sourceforge.net/
diff --git a/www/khtml2png/pkg-message b/www/khtml2png/pkg-message
new file mode 100644
index 00000000000..1a7ab51a855
--- /dev/null
+++ b/www/khtml2png/pkg-message
@@ -0,0 +1,2 @@
+khtml2png requires an X window display. If you don't have it, you can
+use either VNC or X Virtual Frame Buffer server (xorg-vfbserver).