aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-03-25 17:44:55 +0800
committerrafan <rafan@FreeBSD.org>2007-03-25 17:44:55 +0800
commite7f1227d202ddeacc443c942befd1e91630fe4c2 (patch)
tree40af07012297f7e95df26cf6364def2377a42b55 /www
parent76c31e5e85f1caaad16f9d0ac87055d0a8fa4a49 (diff)
downloadfreebsd-ports-graphics-e7f1227d202ddeacc443c942befd1e91630fe4c2.tar.gz
freebsd-ports-graphics-e7f1227d202ddeacc443c942befd1e91630fe4c2.tar.zst
freebsd-ports-graphics-e7f1227d202ddeacc443c942befd1e91630fe4c2.zip
- Fixing taxonomy module for add-on ticker module
- Switch to drupal5/bsd.drupal.mk - Rename to drupal4- PR: ports/110412 Submitted by: Nick Hilliard <nick at foobar.org> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/drupal4/Makefile10
-rw-r--r--www/drupal4/files/patch-modules-taxonomy-taxonomy.module11
2 files changed, 19 insertions, 2 deletions
diff --git a/www/drupal4/Makefile b/www/drupal4/Makefile
index a4b5e06e716..9782b9d3ecf 100644
--- a/www/drupal4/Makefile
+++ b/www/drupal4/Makefile
@@ -5,10 +5,12 @@
# $FreeBSD$
#
-PORTNAME= drupal
+PORTNAME= drupal4
PORTVERSION= 4.7.6
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://ftp.osuosl.org/pub/drupal/files/projects/
+DISTNAME= drupal-${PORTVERSION}
DIST_SUBDIR= drupal
MAINTAINER= nick@foobar.org
@@ -35,8 +37,12 @@ USE_PHP+= mysql
.endif
.if defined(WITH_PGSQL)
RUN_DEPENDS+= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
+USE_PHP+= pgsql
.endif
+post-patch:
+ ${RM} ${WRKSRC}/modules/taxonomy.module.orig
+
do-install:
${MKDIR} ${DRUPAL_DIR}
${CP} ${WRKSRC}/.htaccess ${DRUPAL_DIR}
@@ -64,5 +70,5 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include "${.CURDIR}/bsd.drupal.mk"
+.include "${.CURDIR}/../../www/drupal5/bsd.drupal.mk"
.include <bsd.port.post.mk>
diff --git a/www/drupal4/files/patch-modules-taxonomy-taxonomy.module b/www/drupal4/files/patch-modules-taxonomy-taxonomy.module
new file mode 100644
index 00000000000..ee3ecd14047
--- /dev/null
+++ b/www/drupal4/files/patch-modules-taxonomy-taxonomy.module
@@ -0,0 +1,11 @@
+--- modules/taxonomy.module~ Sat Mar 17 00:26:28 2007
++++ modules/taxonomy.module Sat Mar 17 00:26:28 2007
+@@ -619,7 +619,7 @@
+ foreach ($vocabularies as $vid => $vocabulary) {
+ if ($vocabulary->tags && !$free_tags) { continue; }
+ $tree = taxonomy_get_tree($vid);
+- if ($tree && (count($tree) > 1)) {
++ if ($tree && (count($tree) >= 1)) {
+ $options[$vocabulary->name] = array();
+ foreach ($tree as $term) {
+ $options[$vocabulary->name][$term->tid] = str_repeat('-', $term->depth) . $term->name;