aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-05-17 12:53:49 +0800
committersat <sat@FreeBSD.org>2006-05-17 12:53:49 +0800
commite819fcf50dcacfa0cda4d00d375318b80a79d4d7 (patch)
tree58c5951334af69ef961280f2fe431d80f06d2cf0 /www
parent83ea246aa4564c8c7ce4aaf63ca9fdd1f2ebc112 (diff)
downloadfreebsd-ports-graphics-e819fcf50dcacfa0cda4d00d375318b80a79d4d7.tar.gz
freebsd-ports-graphics-e819fcf50dcacfa0cda4d00d375318b80a79d4d7.tar.zst
freebsd-ports-graphics-e819fcf50dcacfa0cda4d00d375318b80a79d4d7.zip
- Style change: convert to tabstop=4
Approved by: krion (implicit)
Diffstat (limited to 'www')
-rw-r--r--www/xpi-adblock/Makefile.xpi36
1 files changed, 18 insertions, 18 deletions
diff --git a/www/xpi-adblock/Makefile.xpi b/www/xpi-adblock/Makefile.xpi
index fe20ba07d0c..7e4f72b9356 100644
--- a/www/xpi-adblock/Makefile.xpi
+++ b/www/xpi-adblock/Makefile.xpi
@@ -3,27 +3,27 @@
#
# New ports collection makefile for: xpi infrastructure
# Date created: 28 March 2006
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
#
# $FreeBSD$
#
-# XPI_ID - Extension id, might be in {12345-...} or dev@org format
-# XPI_FILES - List of files in xpi archive. This is used to produce
-# PLIST_FILES. XPI_FILES can be generated by xpi-gen, but be
-# sure to put chrome.manifest in ${FILESDIR} before that if you
-# need it.
-# XPI_DIRS - List of directories in xpi archive. This is used to produce
-# PLIST_DIRS.
+# XPI_ID - Extension id, might be in {12345-...} or dev@org format
+# XPI_FILES - List of files in xpi archive. This is used to produce
+# PLIST_FILES. XPI_FILES can be generated by xpi-gen, but be
+# sure to put chrome.manifest in ${FILESDIR} before that if you
+# need it.
+# XPI_DIRS - List of directories in xpi archive. This is used to produce
+# PLIST_DIRS.
# XPI_DISTNAME - The name of distribution
-# Default: ${PORTNAME}
+# Default: ${PORTNAME}
# PORTNAME, PORTVERSION, DISTVERSIONSUFFIX, CATEGORIES, MAINTAINER, COMMENT
-# - These should all be set manually for port to be functional. See
-# ${PORTSDIR}/Mk/bsd.port.mk for details.
+# - These should all be set manually for port to be functional. See
+# ${PORTSDIR}/Mk/bsd.port.mk for details.
# MASTER_SITES - This should be set if port is unavailable at the default site.
-# Default: ${MASTER_SITE_MOZILLA}
+# Default: ${MASTER_SITE_MOZILLA}
# MASTER_SITE_SUBDIR
-# - Default: extensions/${PORTNAME}
+# - Default: extensions/${PORTNAME}
# LATEST_LINK - Default: ${PKGBASE:S/_//g}
#
# This Makefile is an alpha-version of the new xpi infrastructure. It currently
@@ -51,7 +51,7 @@ MASTER_SITES?= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR?= extensions/${XPI_DISTNAME}
PKGNAMEPREFIX?= xpi-
EXTRACT_SUFX?= .xpi
-DISTNAME?= ${XPI_DISTNAME}-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
+DISTNAME?= ${XPI_DISTNAME}-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
DIST_SUBDIR?= xpi
LATEST_LINK?= ${PKGBASE:S/_//g}
@@ -60,20 +60,20 @@ USE_ZIP= yes
EXTRACT_AFTER_ARGS= -d ${WRKSRC}
XPI_DISTNAME?= ${PORTNAME}
-XPI_DIRS?= chrome components defaults/preferences defaults
+XPI_DIRS?= chrome components defaults/preferences defaults
WITH_XPI_APPS?= *firefox* *thunderbird* *flock*
-XPI_APPS?= ${WITH_XPI_APPS:S.^.${X11BASE}/lib/.:S.$./extensions.}
+XPI_APPS?= ${WITH_XPI_APPS:S.^.${X11BASE}/lib/.:S.$./extensions.}
_TD= lib/xpi/${XPI_ID}
_TD_FULL= ${PREFIX}/${_TD}
-_Q= 2>/dev/null || true
+_Q= 2>/dev/null || true
PLIST_FILES_CMD+='@exec for _app in ${XPI_APPS} ; { ${LN} -sf ${_TD_FULL} $$_app ${_Q}; }'
PLIST_FILES_CMD+='@unexec for _app in ${XPI_APPS} ; { ${RM} -f $$_app/${XPI_ID} ; }'
PLIST_FILES+= ${XPI_FILES:S!^!${_TD}/!}
PLIST_FILES+= ${PLIST_FILES_CMD:S/ /%%SPACE%%/g}
PLIST_DIRS+= ${XPI_DIRS:S!^!${_TD}/!}
PLIST_DIRS+= ${_TD} lib/xpi
-PLIST_SUB+= SPACE=" "
+PLIST_SUB+= SPACE=" "
do-install:
@${INSTALL} -d ${_TD_FULL}