aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-02-13 23:17:15 +0800
committerkrion <krion@FreeBSD.org>2004-02-13 23:17:15 +0800
commitec9c51ebe9da9f20af0f5280090655362e3002e1 (patch)
tree6e672c45840f6f64cb2cd2469e7a61af611aecf9 /www
parent701fbb42278135d6a0028161fa4293ce18b619a6 (diff)
downloadfreebsd-ports-graphics-ec9c51ebe9da9f20af0f5280090655362e3002e1.tar.gz
freebsd-ports-graphics-ec9c51ebe9da9f20af0f5280090655362e3002e1.tar.zst
freebsd-ports-graphics-ec9c51ebe9da9f20af0f5280090655362e3002e1.zip
- Fix installation: create missing directory
- Use PLIST_* - Respect CC & CFLAGS - Doesn't need gmake - Don't create unsafe log file, print post-install message instead. PR: ports/62787 ports/62691 Submitted by: maintainer, Volker Stolz <stolz@i2.informatik.rwth-aachen.de>
Diffstat (limited to 'www')
-rw-r--r--www/chpasswd/Makefile14
-rw-r--r--www/chpasswd/files/patch-Makefile.in27
2 files changed, 37 insertions, 4 deletions
diff --git a/www/chpasswd/Makefile b/www/chpasswd/Makefile
index e0c04ccf0bd..be9348a6411 100644
--- a/www/chpasswd/Makefile
+++ b/www/chpasswd/Makefile
@@ -7,18 +7,24 @@
PORTNAME= chpasswd
PORTVERSION= 2.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
-MASTER_SITES= http://web.onda.com.br/orso/
+MASTER_SITES= http://web.onda.com.br/orso/ \
+ http://fresh.t-systems-sfr.com/unix/src/privat2/
MAINTAINER= jmelo@freebsdbrasil.com.br
COMMENT= Allow users to change their Squid or Web password using the browser
HAS_CONFIGURE= yes
-USE_GMAKE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}/etc/chpasswd \
--enable-language=English \
- --enable-cgidir=${PREFIX}/www/cgi-bin \
+ --enable-cgidir=${PREFIX}/www/cgi-bin
+
+pre-install:
+ @${MKDIR} ${PREFIX}/www/cgi-bin
+
+post-install:
+ @${ECHO} 'Remember, passwd and log file must be owned by httpd user, or chmod 777'
.include <bsd.port.mk>
diff --git a/www/chpasswd/files/patch-Makefile.in b/www/chpasswd/files/patch-Makefile.in
new file mode 100644
index 00000000000..3db8991b957
--- /dev/null
+++ b/www/chpasswd/files/patch-Makefile.in
@@ -0,0 +1,27 @@
+--- Makefile.in.orig Wed Feb 11 14:56:26 2004
++++ Makefile.in Wed Feb 11 14:57:15 2004
+@@ -1,13 +1,13 @@
+ # Makefile.in for chpasswd.cgi
+
+-CC = gcc
++CC ?= gcc
+ LANGUAGE = @LANGUAGE@
+ CGIDIR = @CGIDIR@
+ SRCDIR = .
+ VPATH = .
+ INSTALL = cp
+ LIBCRYPT = @CRYPTLIB@
+-CFLAGS = -O2 -w $(DEFINES)
++CFLAGS += -w $(DEFINES)
+ PREFIX = @prefix@
+ DEFS = -I. @DEFS@ -DPREFIX=\"@prefix@\"
+
+@@ -43,7 +43,7 @@
+ @if test ! -f $(PREFIX)/chpasswd.log; then \
+ echo "touch $(PREFIX)/chpasswd.log"; \
+ touch $(PREFIX)/chpasswd.log; \
+- chmod 777 $(PREFIX)/chpasswd.log; \
++ chmod 775 $(PREFIX)/chpasswd.log; \
+ fi
+
+ uninstall: